Script Mode Screenplay & Screenplay (Final Draft)

Hi Guys,

I’d just like to first of all say Hi to everyone, I’m a newbee to the site, so please treat me as you mean to go on! :wink:

I first bought Scrivener back in May 2010, before version 2, however, it’s taken me a while to get around to starting my writing… yes I’m a wage slave with a dream of writing my way to a better life!

I have Final Draft 8 and over the last few days have been delighted by the new features I’m finding in version 2.2. However, I’m a little puzzled as to why there’s a Screenplay and Screenplay (Final Draft) to choose from.

Screenplay works fine for me and I can compile to Final Draft 8 and everything ends up in the right place. However, when I try Screenplay (Final Draft) the slug lines have the tops of the words cut in half and the layout is all over the place. I’ve worked out that this is the settings for this mode. But why have both these modes when the normal Screenplay mode works perfectly with Final Draft 8? :confused:

Also, I’ve noticed that if I select the Final Draft Elements setting in compile, the script in Final Draft 8 has only one linespace between the end of the last scene and the start of the next, instead of two linespaces as the industry likes to see for neatness. So why is this mode there where it does this?

Hope someone can shed some light on this for me.

Now for your ego boost for the day, Keith, if you read this: Scrivener is without a shadow of a doubt the best writing software in the world! I’ve tried all the main products in the market today, and none come close to the ease of use, flexibility, and power of Scrivener! Keith, thank you very much for having the idea for Scrivener and developing the software from that first seed of an idea to the powerhouse software it is today.

All the best,

Dave

Hi Dave,

First, many thanks for the kind words - much appreciated! I’m glad you’re liking it now that you’re embarking on your writing dreams (heh, I’ll get there too…).

Regarding the “Screenplay (Final Draft)” format, in fact, no such format exists in version 2.x, but it did in version 1.x, so this will be a legacy setting left over from version 1.x. When you installed the extras that came with version 1.x, that installed certain script formats in the Application Support folder, and Scrivener 2.x will read in those formats too, just in case any were created by the user, and to ensure that users updating from 1.x can continue to use formats they used in earlier versions.

The “Screenplay (Final Draft)” format was even out-of-date in version 1.x. It was set up for exporting to RTF - if you generated an RTF from it, and opened the RTF in Final Draft, FD would do a good job of interpreting all of the script elements properly. This format dated from before we had the Final Draft FDX and FCF export, so at one time exporting to RTF was the only way to get to Final Draft. Once the FDX export had been implemented, this “Screenplay (Final Draft)” format was no longer needed, but I had to keep it around in version 1.x so that the format didn’t disappear during an update when someone was halfway through a script.

These days, you should just use “Screenplay” format when exporting to Final Draft. If you like, you can delete all of those old 1.x settings, too. To do so:

  1. In the Finder, navigate to ~/Library/Application Support/Scrivener (where the tilde represents your home folder - note that on Lion, the ~/Library folder is hidden, but you can still access it by opening the Go menu in the Finder and holding down the Option key). Actually, that’s the long way - I always forget I added this, but in 2.2 you can just go to the Scrivener menu and choose “Reveal Support Folder in Finder”.

  2. In there, you will find a folder entitled “ScriptFormats”. You can drag that to the Trash (assuming you have created none of your own custom script formats that you want to keep).

Hmm, I’m not sure about that - that may be a Final Draft bug. When you tick that, Scrivener doesn’t include any information about the element formatting in the FDX file, it just includes the element type (e.g. “This line is a Scene Heading”). By including no information, it forces Final Draft to use its default settings, so it may be that Final Draft isn’t adding the correct spacing by default here. The best thing to do is use the regular “Screenplay” script format in Scrivener and not tick this setting - that should result in a good script format.

Hope that helps!

All the best,
Keith

Hi Keith,

Thank you very much for the incredibly fast reply to my questions. Appreciated.

It makes sense now, after what you say, about the Screenplay (Final Draft) mode not working very well, and to just use the Screenplay mode. I’ve now followed your instructions and deleted all the old version 1.x templates.

With regard the Final Draft elements option in compile, I’ve tried several compiles with this option turned on and off and having it switched off does make Final Draft double space between scenes. So must be a bug in Final Draft as you say.

Hope all goes well with your writing Keith.

All the best,

Dave