Script Mode: TAB and RETURN not working, & styles not sticking through typing (v. 2.9.9.7)

Hi,

Am trying to write a screenplay,

In short: TAB & RETURN don’t move to the next styles as specified in Script Settings, and the chosen style also does not stick for the current line. Details:

  • Script Mode - Screenplay is toggled on.
  • In Script Settings, all the “Allow tabs” checkboxes are unchecked (so as not to insert normal tabs)
  • I DO see the drop-up menu in the lower-right with the various formats (e.g. “Scene Heading” “Dialog” etc.)
  • If I select one of those, say, “Scene Heading”, it will put the current line into that format. Good. BUT, then if I continue typing the line, it doesn’t keep that format. For example, If I select “Scene Heading” the line will go all caps, but then anything I continue to type on the same line will not be all caps.
  • The bar at the bottom of the screen doesn’t show word count (good), BUT it also does not show what TAB and RETURN are supposed to do. It’s just blank.
  • Using TAB or RETURN do not change to the next styles as specified in the Script Settings. Instead, they just act normal, creating an actual tab or new line.
  • If I press RETURN 2x in a row, then I get the styles popup under the cursor, which I suspect is right.

On Win 7, 64 bit
Running Scrivener Version: 2.9.9.7 Beta (955095) 64-bit - 13 Jun 2020

I s anyone else experiencing this?

I feel a bit alone here? Has anyone successfully used Script Mode as described? Or does anyone know of a possible timeline for a fix here? I’m curious if I should wait for a fix or just do the actual writing part in Final Draft.

Update: It seems to work on new scenes I’m making, but does not work on my older scenes. I’m not sure why. Toggling script mode doesn’t make a difference.

ANOTHER UPDATE:

What’s happening is that somehow, over time with Scrivener open, the Script Mode files lose the expected TAB/RETURN functionality. In my last post I said that new files had the functionality working fine, but the older ones did not. That is true, but even the new ones had since lost the proper functionality.

However, if I close out of the project, then reopen the project, all Script Mode files REGAIN the proper TAB/RETURN functionality.

The way I tend to work is that I leave the project open over many days. I sleep my computer in between, and rarely shut down. So I’m not sure at what point it’s losing the proper functionality – but right now the workaround is to close/reopen the project.

I’ve upgraded from RC7 --> RC8.

This bug still exists. And I’m having a case where closing/reopening Scrivener doesn’t fix the behavior anymore.

Has anyone looked into this?

I’m looking into it, but I’m not terribly familiar with Script mode in Scrivener. Using tab appears to do nothing, even when set to do something on a blank line. Using return after a Character line appears to shift to dialog, but sometimes the cursor goes all the way to the left edge and stays there. Backspace, try again, but that interrupts the creative flow.

If that’s what you’re experiencing, it’s confirmed. I did mess with some of the settings for Scriptwriting (the default “next” line styles, mostly).

Thanks for checking. Those sound like symptoms of the same issue.

I guess maybe nobody really uses Scrivener to WRITE screenplays, otherwise I’d expect to hear a lot more about this problem because it makes the actual WRITING impossible. I’ve personally moved to just planning in Scrivener, and then typing it up elsewhere (someone recommended WriterSolo, which I’m enjoying).

Hope it gets fixed eventually.