Script settings lost after installing 3.01

In my screenplay, I had to set each separate document to Screenplay mode. Tedious with 60-odd scenes, but fair enough as a one-off. But after installing 3.01 I opened my screenplay again, only to find that all my scenes have reset themselves to prose mode. Do I have to reset every single scene to screenwriting mode again, or did the update also add a global way of rectifying this error?



I forgot the most serious part.When I click on the little round symbol in the bottom right of the Editor to change the settings back to script, something else pops up instead–a dialogue box for project targets. And in the Format menu, Script Settings is greyed out and the drop-down list on Change Element To… is also greyed out. So I can’t actually work on the script [tries not to panic.]

That little target button has never brought up script settings but document targets. Scrivener 3.0.1 shouldn’t have swapped out script mode, however, and I cannot reproduce this issue. It did fix a bug whereby script mode wasn’t properly set sometimes when switching to it, though.

To switch multiple documents to script mode, simply select them all in the binder and then go to Format > Scriptwriting > Script Mode.

All the best,

But Script Mode is greyed out. A number of other items are also greyed out, such as Merge and Move to Trash, Redo, Cut and Copy.As far as I can see I have no access anywhere to any script format settings.

Have you made sure that only text files are selected? If you have selected a document that can’t enter script mode, such as the Draft or Research folder, or an image, then Script Mode will indeed be greyed out.

Thank you for these replies. I am only working with documents in in my draft–all text-only documents that were performing quite happily as screenplay documents before I ran the update… Oddly, there was one scene I removed from the draft yesterday (before installing the update) and placed in another folder outside of the draftr; this document has not reverted to prose format but has retained its script formatting.

Here’s a partial list of items that are greyed out since updating: Undo, Redo, Cut, Paste, Paste and Match Style, Delete, Add and Remove Link, Insert Table/Comment/Inline Annotation/Endnote Marker/Current Date and Time, Merge, Ungroup, Remove from Project Documents, Replace Media File, Copy/Pate/Preserve Formatting, Show Previous/Next Tab, Move Tab to New Window, Merge all Windows, Align Left/Right/Centre, most of the Styles, everything on the Tables menu and the Lists menu, Revision Mode…

Is it possible to remove the update? Or would I be better off simply going back to Scrivener 2? I think I read that it was possible to save a copy of a Scrivener 3 project in a way that it could be read by scrivener 2–is that true? Thank you.

I have managed to restore Scriptwriting mode to the documents, which is a huge relief. The greying-out is still present, but I have discovered that I am suffering from partial greying-out in Safari and Word as well (and probably elsewhere too). This makes me think there is something more serious going wrong elsewhere, and it happening right after I installed the update was simply a weird coincidence. The main thing is that I can continue to work. I fear I have wasted your time. So sorry.

You haven’t wasted my time at all! I hope you figure out what’s going on with your system, as that does sound strange. If you haven’t already tried it, a simple restart might help.

All the best,