Script Writing mode & full screen

Hi,
Scriptwriting mode & full screen are incompatible. It is impossible to use shortcuts. But… you probably already know :slight_smile:
Thanks,

I don’t know what you mean here, sorry. What shortcuts? All should work. If you mean Function+letter, then that was never an intentional shortcut anyway, but just something OS X implements on laptops when a pop-up button is visible. The shortcuts in the pop-up button at the bottom of script mode are supposed to work after you’ve opened the pop-up menu (by clicking on it or hitting Shift-Cmd-Y).

The main shortcuts for scriptwriting are Opt-Cmd-1 - 9, and these should work in any mode.

All the best,
Keith

This is the Mac bug hunt forum, but your platform is listed as Windows, so I’m not sure which you’re actually referring to. Ctrl+\ does call up the element pop-up menu in full screen on Windows, and you can then choose the letter that you want for the element; Tab and Enter work as in the regular editor to move to the common next element. Which shortcuts are you trying to use that aren’t functioning properly (and which platform are you on)?

Hi,
Oh sorry. I’m on Mac. I was on PC before but I moved to Mac at the beginning of this year.
I just updated my profile.

Well… Yes, I was speaking of Function+Letter.
I tried wat Keith said. So I open the pop-up button (it doesn’t stay opened). Then if I use fn+letter sometimes it doesn’t work. OR, sometimes it changes the format but not on the line I am !
That looks like a bug.
Opt-CMD 1-9 doesn’t seem to work neither. What it supposed to do ?
Thanks,

As I said, Function+letter isn’t intended to work anyway, that is just a curiosity of Mac laptops. You are only supposed to press the letter on its own once the pop-up is open, not Function as well.

The pop-up stays open fine for me when I call it up, and is then dismissed again when I hit a letter or select something, as it should be. It may just be that you were hitting Function+letter which isn’t a valid combo, so dismissing it.

Opt-Cmd 1-9 works fine for me too. Take a look in the Format > Scriptwriting > Change Element To menu, where you should see all the elements listed with these shortcuts next to them. They should be enabled so long as you are in script mode.

All the best,
Keith

Ok, I understand for Function+Letter.
It works as you say.

But alt+Cmd 1-9 does nothing for me in fullscreen…
Thanks,

Perhaps you have them hooked up to something else? Check the Format > Scriptwriting > Change Element To menu - is it greyed out or available?

No, they look available :
Capture d’écran 2013-07-04 à 12.57.06.png

In that case, there’s nothing going wrong in Scrivener and either you have assigned keyboard shortcuts to other menu items with these shortcuts so that they clash, or another application you are running is intercepting keyboard shortcuts. I say this because as long as the menu items are available and the shortcuts are there, everything else is handled by the system, not by Scrivener. The way keyboard shortcuts work is that OS X detects the key-presses and then searches through the menus of the active application looking for an active menu item that matches that keyboard shortcut. When it finds one, it simulates clicking on that menu item. If it doesn’t find them, then it means either the same shortcut is assigned to a menu item it looked in first, or that another application is hooking into keyboard shortcuts.

All the best,
Keith

Well, thanks. But I don’t understand. Scrivener is the only application I’m running…

But the way, when I just press ALT my mouse pointer changes into a cross.
Is it the way it should work ?

Yes, Alt will change the pointer into a cross, that’s just something that happens in the OS X text system, not quite sure why. Have you defined any custom keyboard shortcuts for Scrivener in System Preferences?

Hi,
No, sorry, I defined no custom keyboard shorcuts for Scrivener.

Very strange. I’m afraid I don’t know what else to suggest, seeing as keyboard shortcuts are handled at the OS level and there is zero code handling them in Scrivener that could go wrong. If the menu items are enabled, then Scrivener is doing everything right its end. Maybe try logging in to a test user account and see if it works there.

I did another test.
I just bought a new Mac laptop.
After installed Scrivener… the same thing happened.
Shortcuts are ALT+CMD+ (one number between 1 and 9), right ?
Thanks

Yes:

OK.
So I confirm: it doesn’t work on two different computers.
One is completely new.

The trouble is that nobody else has reported this as an issue and I’ve just tried this on six different computers, and it worked fine on each. One was running Tiger and another Snow Leopard: the shortcuts worked fine in regular and Compose mode. Three were running Mountain Lion, and on those, the shortcuts worked fine in regular mode, Compose mode, and Lion+ full screen mode. I also booted one machine into Lion, and the shortcuts worked fine in regular, Compose and full screen mode.

Did you perhaps use Migration Assistant to transfer data from your old computer to your new one? If so, any problems you encountered on your old machine could also be transferred across.

And, to go back over the obvious:

  1. Is this happening on all projects or only one? (If the latter, please send us the project for testing).

  2. Have you double-checked you are in scriptwriting mode?

  3. Are there any specific factors involved? Page view, fixed width view or suchlike?

Mmh, bizarre.
There is probably something I do wrong.
No, I didn’t use Migration Assistant. The other machine isn’t old. It’s a new Imac I bought in february this year. Both run on Lion.
When you say to press ALT+CMD+ 1-9, you don’t need to press SHIFT+CMD+Y before, right?
Because it works when the pop-up menu is opened.

It does that in all my projects.
Yes I am in scriptwriting mode.
I made a screenshot for my parameters view.

I just noticed (when the pop-up menu is not opened) everything does nothing.
Except ALT+CMD+5 : align text on the left.

No, the pop-up shouldn’t need to be opened. What letter shortcuts have you assigned to the Shift-Cmd-Y menu?

See the screenshot below for letter shortcuts:
Capture d’écran 2013-07-10 à 17.07.32.png