Scriptwriting Auto-Complete [SOLVED]

It’s been a long while since I’ve typed script pages in Scrivener 3. How do I get Auto-Complete to work in Scene Headings and Character Names? I must be doing something wrong.

EDITED/SOLVED – The problem seems to have been caused by loading an FDX file from Final Draft 12 into the Elements section of Screenplay Settings. I reset to defaults and now auto-complete works fine.

The FDX file was blank, so this may be a case of Scrivener 3.2.3 not being 100% compatible with the current version of the FDX file format. I’m going to do more testing about this, and I’ll update this topic if I learn anything conclusive.

For now, I’d advise not loading a Final Draft 12 FDX into the Elements area of Script Settings.

Through trial and error, I’ve come to the conclusion that importing Elements from an FDX or FDXT file from FD12, FD11 or FD10 will mess up auto-complete.

I found if I recreated the format by hand in Scrivener with the same fonts, styles and margins, auto-complete works fine.

Maybe @AmberV can take a look at this and see if it’s repeatable. I can send FDX and FDXT files if you don’t have FD at hand.

Just to verify the nature of the problem as I understand it: if you import your Script Settings from another program that produces FDX files, they lack the settings necessary to recognise names and locations? If so, I think that makes sense, and I don’t think there is any way around that—essentially because that is handled via Scrivener-specific settings rather than something communicated with the FDX file itself. It’s like the keyboard shortcuts settings, they aren’t formal script settings, but stuff added on top by the software.

I think a solution would be somewhere in between what you tried:

  1. Import the script settings.
  2. Go through the elements in the sidebar, and set up the Auto-Complete tab as desired.

For that, it might be helpful to have a sample project open to the side so you can compare how our stock settings are configured and copy them. So at least then you would only be recreating part of the configuration by hand, rather than everything.

Thanks for looking into this.

After some more testing, here’s what I’ve found:

If I change the Elements in Script Settings by clicking the Manage pop-up and importing a blank FDX or FDXT file from Final Draft v 10/11/12, Autocomplete will not work in documents created from those settings.


For example, if I make a new Scriptwriting document, make sure the first paragraph is a Scene heading, and I type “I”, Scrivener fails to offer me the auto-completion of “INT.”

If I type new character names in the document, Scrivener will not offer them as auto-completion, even after I type the name followed by dialogue several times.

If I open Script Settings, click the Manage pop-up and select “Reset to Defaults”, Auto completion will now work on new documents.

I tried this again using an FDX file that was not blank, and auto-complete works properly. It seems the problem comes from importing a blank FDX or FDXT file. (All FDXT files are blank because they are templates.)

So there is a workaround – use an FDX file with text in it. AFAIK, FDXT files and blank FDX files seem to cripple Scrivener’s auto-complete system.

Can you please check if this behavior is repeatable?


Hmm, I’m not quite seeing the same result, but it could be a matter of me testing with a completely stock screenplay FDX file. It does appear as though Scrivener has some potentially hard-coded recognition of standard element names, like “Transition”, which when detected will have the completion table populated with defaults (“FADE IN:”, “CUT TO:” etc). What doesn’t import, whether the FDX has content or not, are the Automatically add phrases to project list that occur… settings.

Now, if I’m not using a standard screenplay (and realistically, why would I be at that point, as there is already one in the software), then I would expect these hard-coded assumptions to be absent. If I call my element “Super Fun Swipes”, I wouldn’t expect the software to know that the Transitions completion list is appropriate. Obviously your element names are more serious, but hopefully the point conveys.

At any rate, no I’m not seeing a substantial difference between empty script files or those with a little sample content in them. Maybe the point of difference is more the FDXT than anything else. If you could supply an FDXT that is producing this result that would likely be the easiest way to see if there is something we can do about recognising standard named elements.