Scriv 2.0.4.5 build 9307 Project targets glitch

I’m downloading the latest build to check this bug against, but I didn’t see it addressed in your most recent release notes…

I was working on my manuscript last night, and when I opened the project today in Scrivener, I still had the same word count as yesterday. I clicked on the Reset button and began to write, starting with 0 words in the progress bar.

After a short while, I decided that I wanted it to reset at midnight, so with a couple hundred words of progress for the day, I clicked on the Projects Targets “Options…” button, and I checked on the “Automatically Reset at Midnight” option. When I clicked “OK”, it reset my current progress. I had expected it to keep my current progress until midnight (local time) tonight, and then reset it to zero.

So to sum up the steps:

Un-check “Automatically reset at midnight”
Reset the Session Target
Write something.
Check the “automatically reset at midnight” option.
… and the Session Target progress will be reset to 0 of 1100* words.

I’ll post back when I see if this is fixed by the latest beta.

*My current session target, obviously will vary.

I just installed the latest; build 9464. When I launched it, and it automatically opened my project, the session target was reset to zero out of 1100 words*. I had over 100 words written just 10 minutes ago (1:17pm local time)

My current set of check-boxes are:
Draft Target:
Count documents included in compile only

Session Target:
Allow Negatives
Automatically reset at midnight

  • This only seems to happen when launching the latest version of Scrivener build 9307 from the previous version. I have opened & closed scrivener build 9307 multiple times now, and it does not reset my progress.

I should have address the original issue as well: I typed a few words, incrementing the session target progress bar & word count. Then I deselected the “reset at midnight” option. So far, so good; progress remained at 11 out of 1100 words.

Then I checked the “automatically reset at midnight” option, and the progress went back to 0 out of 1100.

Hi Robert,

Please try the latest beta (build 9486), which I’ve just uploaded a second ago. Although it’s not mentioned in the release notes, I’ve just (hopefully) fixed this - the previous code was returning a false positive which resulted in resetting the session count when settings were being updated rather than just when midnight had passed.

Thanks for bringing it to my attention - please let me know if you find any more bugs with the updates to the session count feature.

All the best,
Keith

Build 9486 test results:

On upgrade, session progress is preserved from when using the previous build of Scrivener.

When selecting “Automatically reset at midnight” from the options, the session’s word count is no longer reset to zero.

Excellent! Have a good night!

Phew! Thanks for catching this - let me know if there are any more problems.
All the best,
Keith