Scriv 3 hanging continually

I use Scriv 3 across a Mac and Macbook, saving in Dropbox. No probs the past year, but now on Mac it keeps hanging while (seemingly) backing up, making it unusable to write with. Tried saving and backup to C/ disk instead, but same problem. Any suggestions? Have disk space, RAM and haven’t changed my configuration for more than a year, so this is a sudden problem. Thanks, James

Sounds like you are using Windows? (This a Mac forum). Perhaps as first step simply un-install and reinstall Scrivener in case files became corrupted? Odds are there is something on the computer causes this (independent of Scrivener).

Well, the OP states he is using a Mac and a MacBook, so I’m not sure how that conclusion was arrived at.

However, it would not harm anything to try a utility like Onyx to see if there is any underlying problem with the hard disk or the like. Clearing out caches and associated rubbish can mysteriously clear up all sorts of stuff.

Thought Windows as c/ drive mentioned. My bad.

Instead of saving where? Dropbox is a folder on your Mac HD, but was is the C disk?

Thanks all for the helpful suggestions and, yes, I am a Mac user. Will report back back what worked. Problem is the same on both machines I use, so the issue must lie with auto-saving/back-up method or location.

If you have an external drive you can temporarily use for testing, that would be a good idea. I also second the notion of running those diagnostics and repair tools linked above. If nothing has changed with your configuration and you’re suddenly getting hangs when saving, that’s not a good sign.

Dropbox as a factor can be ignored, there is nothing fundamentally different about the folder named Dropbox in your user folder, and the folder named Documents, from the perspective of software.

Having run the cache-clearing tools suggested and re-checked my back-up and saving locations, nothing changed. However, I created a new, dedicated Dropbox folder and Scrivener is now running better on both machines. The Mac is still a little tardy, with a spinning pin-wheel popping up periodically, but it’s not as intrusive as before and I can actually write with it.

Not sure I have resolved it completely, but the new save location has made a vast improvement.

How much did you have in the previous folder? Perhaps if it was overloaded with too many thousands of things, it was taking a long time to even build up a list of icons and such, into the dialogue box. I’ve noticed Finder (and for the same reasons, the file open/save dialogues) are not the most efficient when folders are big—probably because some of the default settings are bad for that: like drawing real-time high quality preview thumbnails.

I have had this problem recently and created a Scrivener account just to figure out what’s going on.

I would say about 30% of the time when I try to exit the program I get the beachball when it tries to backup and I have to force quit.

The file I’m currently working on is only a 200 pg novel – shouldn’t be very big at all. I save it to my dropbox folder but I dont see how that should be a problem – it saves it directly to a folder on my Mac and then after it closes it syncs online

Any suggestions? Is this a bug that needs to be fixed?

You can use Finder to see how big the project actually is. 200 pages of just text shouldn’t be very big, but I’ve encountered cases where people inadvertently pulled in extremely large research files.

Also, check the amount of free space on the drive you’re using for backups.


My problem is a bit different, it is with switching editors. Every ****ing time I move from one editor to the other, I get the beachball. I am using Catalina, which I suspect is at the root of all ills at the moment, up to and including COVID19. All software up to date. It is driving me crazy. I have had to resort to having two projects open, and rather than using the editor windows to compare and make changes, I move text from (a document in) one project to (a document in) the other. The project I am trying to work on is currently only 9.5MB.

Does anyone have any suggestions?

thank you

Have you updated Scrivener to the latest and greatest version?

Does the documents your project include a lot of inspector comments? That seems to slow loading documents down considerably.


Long shot: try File (with Option)/Save and Rebuild Search Indexes (or Cmd+Opt+S)