Scriv1.1 - Spell checker buglets [BUG LOGGED]

I’ve downloaded and installed the newer Scriviner file (1.1) so I have the updated version.

This is not a serious ‘bug’ but something worth mentioning - the spellchecker is not recognising certain words, specifically contractions containing the apostraphe ( ’ ). For example, the following words are underlined in red like so:
I’ve
Isn’t
Doesn’t
Mustn’t
Couldn’t
Wouldn’t
This is not a huge problem (I can manually add them to the dictionary as I go, or whatever) but for future release they should probably be recognised as words in the dictionary. Particularly as “I’ve” autocorrects to “I’vie” when the autocorrect option is on.

But I’m happy to report that otherwise the spellchecker seems to be behaving itself now!! :smiley:

Same problem here. I noticed such words only register as misspelled if the apostrophe is a curly quote. If you paste in a word with a straight quote, no problem.

Didn’t get around to trying just unchecking the curly quote option last night but it’s worth a shot, until this can be fixed.

^I can confirm that it’s the “smart quotes”. I had initially typed all the above words in and got those errors. However, when I went to Edit>Options>Autocorrect and turned off the “Use smart quotes” option, I could type all the same words out and not get any spelling errors. So it is an issue with the smart quotes.

Well spotted!! :wink:

Is this something that will be fixed in a future version, or will smart quotes always be incompatible, at least as far as the spell checker goes, with contractions?

Fair enough, I’ll take a look at this and raise it as a bug. Thank you for taking the time to provide feedback.