Scrivener 1.10 now available

Hi,

Scrivener 1.10 is now available for download. You can install it either by selecting “Check for Updates…” from the application menu, or directly from here:

http://www.literatureandlatte.com/downloads/Scrivener.dmg

Scrivener 1.10 is fully compatible and optimised for Leopard. It should also run faster on (and is of course still compatible with) Tiger.

The full change list for 1.10 can be found here:

http://www.literatureandlatte.com/scrivChangeList.htm

Be sure to read the “important notes” at the top of that page.

I hope you all like Scrivener 1.10; don’t let the version number fool you - it is a big release, and some developers would have called it 2.0 and charged you for an upgrade! (I’m nice, see.)

Thank you for your continued support.

All the best,
Keith

Great work, Keith. Really worth the wait. Thanks for your effort.

Cheers.

Wow, Keith, it’s great, and well worth the wait (well, it was a bit long coming, but I know, I know, you’re a perfectionist and so are all the others who have contributed ideas and feedback to the beta). Thank you, once again, for your dedication and hard work. This is one of the best applications for writers, students and others requiring this kind of organization and creation facility. I’ve just recommended Scrivener to my fellow grad students here in Vancouver, and encourage other users to spread the word far and wide, without, of course, annoying people.
scrivener_rave.pdf (45.2 KB)

Hi

I have just downloaded the update and it looks lovely.
One thing: the project I was working on when I downloaded was updated successfully, but if I try to view the project statistics, the program hangs.
I am doing Nanowrimo nanowrimo.org this month, and project statistics are the important thing, so please please help!

Juliageek

Please do not tell me that… The project statistics hang was a known bug in 1.03. If you have 1.10, the project statistics most definitely should not hang. I have spent a lot of time fixing this bug, there have been multiple beta tests on this, so please do make sure that it is 1.10 that you are using where this hang takes place (by selecting “About” from the Scrivener menu). If that is the case please send me your project to support AT literatureandlatte DOT come immediately! (If you don’t want me to read your work, make a copy of the project, and in the copy, use Edit > Find > Project Replace to replace random letters, e.g. “a” for “t” etc, a few times, until the text is garbled, check the project still hangs on project statistics, and then send me the garbled project.)

Please do make sure that it is not just that the project statistics take a little time to calculate - it may take a few seconds or even a minute for a large project.

Thank you,
Keith

This is a mighty update. The Change List itself is novel-length! And you’re right, it runs like an absolute rocket on Leopard.

Hi Keith

I mailed a garbled, still hanging project to you.

Sorry, sorry sorry

Julia

Well, I wasn’t sure you could make it any better, but I NEVER expected this.

10.4.9, went from 1.03 to 1.10, my project is BLANK, it hangs on stats and requires a force quit.

Thank GOD for backups–mine and the upgrader.

For now I’ll drag 1.03 out of the trash. That’ll be fine for now.

And I’m sorry, I can’t send it to you, it’s under NDA in any form.

drdstny -

Sorry you are experiencing problems. Please know that 1.10 has been through public beta testing for months, now, and no beta tester reported this. Unfortunately, in the first few days of release, several users have experienced it. Some users have now sent me their projects, so, could you please just confirm the following? Upon trying to update the project from 1.03 to 1.10, do you see the following in the Console:

*** -[NSNull caseInsensitiveCompare:]: unrecognized selector sent to instance 0xa002e020

I’m working on a fix for 1.11, which will be out in a few days.

Thanks and all the best,
Keith

RE: blank project bug. Try the following to work around it (I’m working on a fix for 1.1):

The problem is caused by a blank word in your custom auto-complete list. To fix:

  • In the older version of Scrivener, open the un-updated project and go to Edit > Auto-Complete List. Somewhere in that list is a blank item - it will just say “New Word” in grey.
  • Delete that item - and any other blank items - and save the auto-complete list.
  • Update Scrivener to 1.10, update the project, and this time it should open.

All the best,
Keith

Wonderful upgrade. It’s running seamlessly on my 10.4.9 iBook.

One suggestion: You might think about sending a notice of the release to Macintouch.com so that the larger Mac world can get in on the good news.

Robert

Keith, your update is a pre-christmas gift to many creative minds around.

1.10 is running perfectly on my seven years old Power Mac G4 400. No lag at all. Thank you for that, Keith.

Version 1.10 was working fine from 11-7 up until this morning. Now I get the blank project screen. I’m running Leopard on a MacBookPro. I deleted the new version and reinstalled 1.0.3, but it doesn’t seem to work either as I can’t open any files even old ones that haven’t been updated. I’m going to move all the files to a G4 still running 1.0.3 on Tiger and keep my fingers crossed.

One of the Mac forums reported that there were some last minute pre-release changes to Leopard that developers hadn’t seen so some software that was supposed to be fine wasn’t.

George

George,

It sounds as though you may have opened one of the updated projects on 1.03 by mistake, which will have corrupted it, so you need to go back to the backup copy that was made during update. Please don’t go back to 1.03, as that has a number of bugs that have been fixed. If you need further assistance, you could send me one of the problem projects or give more details about exactly what has happened, what you did this morning, or what you were doing when you had the blank project bug. I am wondering if you double-clicked on a file this morning that got opened in 1.03 if that is still in your trash…

Best,
Keith

I tried to open the file I was working on yesterday and got the blank project. Vers. 1.0.3 isn’t on the machine at all, I deleted it when I installed 1.10. I tried restarting but there was no change. I would attach a project, but they’re all 5+ MB. I’ll see if there’s a smaller one with the same behavior.

George

Oh wait… Here’s a thought. Did you edit the auto-complete list at all (Edit > Auto-Complete List)? If you did, and you left a blank item there, the project may open as blank! Just download the 1.11 beta 3 from the Beta Testing forum if that is the case, which fixes this silly bug.

Best,
Keith

The Auto-Complete list is empty as I don’t generally use it. Tired adding and then deleting a word from the list in two projects, but I still get the blank project.

I attached two files, both were open and working yesterday.

George

Attached where? You can zip them up and send them to me at support AT literatureandlatte DOT com…
Thanks!
Keith

No, I don’t see that. BTW, auto-complete never worked for me, but I probably wouldn’t ever use it.

Seriously, 1.03 is FINE, I actually love it and think it was well worth my money. I have zero problem using it, margin notes is the only possible thing I can think of that Scrivener doesn’t have…I could go on.

I thank you for this terrific product, I dearly love it, I just thought you’d like another viewpoint.