Scrivener 1.5 update, backups, syncing and errors

I just updated to v 1.5 tonight. I’ve been using Scrivener for a couple of years without incident. I have a backup routine that I follow whenever I work in Scrivener. Before I quit, I create a backup using Backup Project to… menu option–I backup a copy using that menu item to my hard drive and then to my iDisk (which then syncs it to .Mac)–to the same folders each time.

After updating through the Scrivener program’s prompt that there was a new version, the first time I got an error, then I tried again using Check for Updates. The second time worked. When I opened Scrivener, it opened to a version that was not my most current. Up until now, it had always opened to my most recent version. When I searched for the most recent version I did find what seemed to be the most recent version, but it won’t open. I get a window saying “Project not found. No project could be found at the specified path.” That one is on the iDisk. Odd thing is that the file size is way smaller than it should be: 344 KB vs 2.1MB from previous versions (it is a .scriv file, not a .zip). The file name also seems to be truncated. Normally the file name has a couple of brackets with dates in them and then another with the current date and time of that file. There are a several of those .scriv files missing that last bracketed part. I don’t know why some have it and some don’t, or if it’s relevant to this problem. I just noticed that the file name at the end after the two bracketed parts says “…2-.Mac.scriv” That’s the only file in the whole folder that has “.Mac” added to the end of the file. I didn’t do it. I never change the file names, I just let it name the file and I save it where it’s supposed to go.

I also get another window that says “The document ‘file name…scriv’ could not be opened. No valid project could be found at the specified path.”

One of my other most recent backups on the iDisk gives me this warning when I try to open it:

Warning This project was either not closed properly or is currently open on another machine. Please not that f the same project is open on two machines concurrently, daa could be lost. Before the project can be opened, its search strings need re-synchronising. This process could talk several minutes. Continue?”

The file was neither open on another machine (I only write on that machine) or closed improperly. I always go through the same routine when backing up and quitting. The same file seems to open off the hard drive backup, but it’s not my most recent version.

Can you think of any way to recover the file that won’t open?

This is all on a PowerBook G4 running OS X 10.5.6, no Time Machine.


“Warning This project was either not closed properly or is currently open on another machine. Please not that f the same project is open on two machines concurrently, daa could be lost. Before the project can be opened, its search strings need re-synchronising. This process could talk several minutes. Continue?”

I get this warning as well when opening any scrivener project. Not sure why.

You may get this message when opening a new project in 1.5 for the first time - don’t worry about it. Scrivener now does an internal check on projects to see if they were closed successfully or not (so it can fix things in case of a crash etc). Files prior to 1.5 won’t contain this information, so Scrivener will interpret them as having not been closed properly the first time it opens them. It will then update them and you shouldn’t see the message again. (This is why it’s a good idea to update the project templates by re-installing the Extras, because the old templates will also show this message when used to create a project.)

On to rkusa’s problems:

The brackets and dates indicate that those files were created using Backup To… Is that correct? I’m not sure about the .mac addition to those files. Is that something that iDisk does for backing up? Again, I’m not sure about this as I don’t use iDisk.

Have you tried a Spotlight search on “.scriv”?

Adam - do you use iDisk?

All the best,

Well one thing I would do before I use the copmuter anymore is startup off the System Disk and when the installer comes up select utilites then run REPAIR Disk Utility on the main HD and also REPAIR permissions. (You may even run a fsck in verbose mode).

The reason I say this is I have seen a similar problem happen before. The disk heirachy became corrupt and the finder would “lose” files. The corruption may have occured last year in 2008 (last shown recent files) and the planets alined just right and the corruption gave birth to the directory only seeing the data from a time ago.

Corrupt font caches, spotlight indexes, preferences, etc sometimes can lead to this problem.

If the directory is corrupt the files although they are on the disk do NOT appear in the finder. The finder sees these files as sectors to be over written hence don’t use the computer until you run utilites because you may inadvertantly write over the area of the disk where the file resides but because of a corrupt directory file the finder will not see the file and to the copmuter it does not exist. The ony thing that exists is the directory information that was not corrupted (like all the information from last year that was written awhile ago and is on a different area of the HD).

This is usually the signs of a hard drive that has corruption or sectors are failing. When those sectors fail the disk cannot read the information correctly and corruption start to occur as use continues.

Running a lot of beta software (like safari 4) can sometimes causes crashes. These crashes can sometimes cause corruption. The corruption can at times lead to data loss if the directory information becomes corrupt or the sectors on the HD start to fail. This is usually from a series of unfortunate events instead of usually the cause of just one action. (Leopard has routines in place to attempt to prevent anything like this from happening)

Or I could be way off base in left field while the stadium is empty and everyone is at the bar. :slight_smile:

But in my humble opinion it sounds to me like your disk directory has become corrupted. With that corruption there may be bad sectors, and probably a corrupt spotlight index.

Yes, I’m assuming that the naming convention is because I used Backup project to…

I have no idea why the .Mac appendage is there. It’s never been there before.

I ran Disk Utility for Repair disk and permissions from the Installer disk. No disk repair problems found, only permissions problems were for Flash files. I ran fsck and had no problems.

I tried duplicating the file and changed the file name to include the third bracketed segment with the last file modification date and time like some of the others (removing the “2-.Mac” part). Still won’t open–I get the same error that there is no valid project at that path.

I searched via Spotlight and the regular Find and turned up no other files that could be for my last backup. I did notice that there were a couple of other files that had no third bracketed segment in the name, but had just a single number, and one had appended with “-local.scriv,” something I haven’t seen on any other file names. Why is there such a difference in the pattern of file naming when backing up from the menu? I have now seen four different conventions used:

File name with 2 bracketed segments
File name with 3 bracketed segments, the last being the date and time of last modification
File name with 2 bracketed segments with a single number appended
File name with 2 bracketed segments with a single number and a dash with either .Mac or local

It’s very confusing. As a separate issue, it would be nice if there was a better naming convention for files that doesn’t create such enormous file names.

Anyway, the file still doesn’t open. Is there any method of extracting the text from that file?

I’m pretty spooked now about using Scrivener if I can’t rely on the backups. I thought I was being very safe with the backups.

By the way, I have no idea what you’re talking about when you mention updating the project templates by re-installing the Extras. What are Extras and where do they come from? As far as I know, I’ve never seen or installed any Extras.


Scrivener only uses one naming convention for backups. You choose the name of your project; when you use backup to, by default it will call the file [project name] Backup [Date]. But you can change that, of course. At no point does Scrivener append -local or .mac to file names - ever. This leads me to think that something is going on on your machine. Something else must be responsible for adding these to the file names, which may also be responsible for moving files around. Any other information you can give would be really useful. Again, more iDisk info would be helpful as I never use it myself.

As for the Extras - they just provide project templates. They come with the main Scrivener download.

All the best,

When I use Backup project to… command I usually backup first to whatever was the last location of my two backup locations–either my internal hard drive or my iDisk. This means that I’m alternating which one gets the backup first. The iDisk will then sync to MobileMe (.Mac). I figured that way, I’d have an off-site copy and one on my hard drive. I have never seen this behavior before (appending the file name) when saving to the iDisk. None of the other files have .Mac added to them. Maybe it’s something that happened after upgrading to Leopard, which I had done not long before that particular backup was made.

When I start up Scrivener the next time after a backup, it would automatically open the last version I saved. Unfortunately, the latest version is an unopenable version on the iDisk and nothing on the hard drive. That unopenable version is showing a size that is less than a sixth of the size of the most recent version I can open. I’m buying an external hard drive now for the PowerBook to backup via Time Machine. I see in another thread that you’re now recommending not to backup over a network. That would have been nice to know earlier.

The file names of my backups are usually like this (the bold type is the actual file name):

The Title 4 [22_Jul_2007_00_22] [22_Jul_2007_00_25] [2/4/09 7/42 PM].scriv

Why are there 3 sets of brackets? This makes for horrendously long file names. I have some backup files though without the third bracket that shows the backup date, so it’s not always as consistent as you say.

As far as I know, I’ve never seen any Extras. I’ve always updated through Scrivener itself since the first time I downloaded it. The Library>Application Support>Scrivener folder is empty, so that would mean that I haven’t installed any extras, correct? So I’m guessing that’s not something I would have done to cause the warning, and re-installing something I never installed wouldn’t work to fix it, right?

Is there any way to revert back to the previous version to see if it will open that file? I can’t find any older versions on your site to download, only the newest.

As a last resort, is there any way you know of to extract the text from the file that won’t open?


You probably opened up a back-up, started working on that, then backed up the back-up, and then repeated that process one more time. That would be how you ended up with three sets of brackets.

Luck at last!

I decided to test out Scrivener on my desktop computer with the new version and create a new project and watch where and how the files were created. Then I went back to my PowerBook and did another search, this time not for the backups. I was able to locate the original file. It had eluded me because when I had tried to open it previously I had gotten the Warning window and cancelled out of the window fearing that I might mess up something. I then went on to try to open several other Scrivener files hoping they would open correctly, which resulted in some opening, some not, some giving the Warning window–and none of the files that would open were my latest.

That all created a lot of confusion because when searching in the Finder or Spotlight, the results show Last Opened as opposed to a Modified date. I didn’t go through every file in column view to see the Modified date. After watching how the new file was created on my desktop computer, I went back and looked through the files without bracketed backup dates and checked all the Modified dates, and found the original file. So while my backups are hosed, the original is still intact. I clicked okay when I received the Warning window as you suggested, and the file opened!

It seems like there’s got to be a more intuitive default naming scheme for being able to tell files apart. I had a number of files with the same name with only a difference of a single stand-alone number after it. It didn’t help that the file names were so long that I had to expand my window out about four times the normal width to view the entire names. But the real difficulty arose from the combination of attempting to open a number of files that resulted in errors, and OS X returning only the Last Opened date in a search, making them all appear as though they were not the files I was looking for.

I’ve since duplicated and renamed the files something more recognizable. They open correctly, and will now avoid backing up over the network–or at least make that a third option and only using zip files.

Thanks for your help.

I’m so glad you’ve found your files. As soon as I read that you were using iDisk for back-ups, gentle alarm bells rang for me. I have both iDisk and DropBox and have run into trouble — never totally disastrously, thank heavens — with both. There has been a lot of discussion of problems we have encountered with using them, particularly those of us who have kept the working project bundle on one of those, in my case DropBox for keeping two Macs in sync. I still use DropBox, but no longer for live files. And I still have my iDisk, though it is no longer on the desktop and from now on I am only going to use it as a history archive of my files; no file that I am going to need currently will be on my iDisk, and if I need to retrieve one from there, then it will be copied back onto the main HD of the computer for working with and archived back when finished. For me, perhaps because of my location, I have found iDisk to be horrendously slow frequently and therefore vulnerable to network failure, my shutting down when having to leave suddenly without noticing that iDisk was still transferring stuff … too many problems. DropBox is much faster and it’s easier to see when its working. I would guess that those files with .mac/whatever/incomplete file/package names were ones where there was a failure in the transfer process and iDisk put that in the name as part of the temporary name being used while the file/package is being written.

It seems to me that the reality is that Scrivener .scriv projects, not being simple files but rather packages containing potentially thousands of files, are particularly vulnerable to any hitch in the transfer process. And when you combine that fact with the auto-saving of Scrivener — an invaluable feature in itself — and the possibility of the opening of the last modified version and so on, the possibilities for corruption followed by the overwriting of the good .scriv by a corrupt .scriv are legion when you are putting any great reliance on networked storage of any kind.

I think that as users we need to be aware that the very foundation of the strength of Scrivener as an app., it’s project structure, is at the same time potentially its greatest point of weakness and work round that. In this case, the moral to me is, use DropBox for transferring files, but in the case of Scrivener, only in the form of zipped back-ups that are then copied to a location on the main HD and unzipped there.

That said, I don’t agree about the naming convention for back-ups — I believe Amber is probably right about your triple dates; she has always been impeccably right during the time I’ve been on the forum — and I cannot imagine a more intuitive way of doing it than using the project name that you have given, followed by the date and time the back-up was made.

Perhaps Keith/Amber/Shadow-DMJ: (i) there needs to be something in the documentation that comes with Scrivener to warn new users very clearly that Scrivener projects are not simple files but complex packages of many files — but I can’t think how you’d word it — and (ii) perhaps the warning alert that comes up when a project created under an older version is opened under a newer version — as has been brought up many times in relation to 1.5 — clearly mentions that the templates also need updating and gives the instructions how to do so and the download URL. When moving to a newer version of an app, I never rely on the Sparkle system, but re-download from the website manually. That for two reasons: firstly it means I have a base copy of the installer package stored on my system in case of a hardware trauma … I don’t have to re-download; and secondly, I automatically re-install any support files, like the templates, at the same time. Sparkle is good for minor bug-squash upgrades, not version changes, and even then, I will usually re-download the installer for apps I use all the time.


In conjunction with the sticky note regarding network folders, and some new wording in the next version of the FAQ (which will be published on the Wiki fairly soon), I’m trying to get this notion across as gently as possible without being too intimidating about it. Especially for potential new users, you don’t want to convey the false notion that Scrivener projects are difficult to work with. They are no more difficult to work with than any other Bundle format—and there are plenty of them out there. It’s just that in recent months—really in the past year—there has been a big push to thinking of storage space as something one can abstract between an arbitrary number of computers. I don’t just mean networks, but sneakernets (kudos to Wock for reminding me of this lovely term) too. Everyone wants to couple their computers up and have them constantly synchronised, and the basic truth of the matter is: This is not a simple thing to do, even for a professional that spends their time designing networks and distributed systems. There is a huge potential for human error in many of these home-brewed methods for even the punctilious among us. I’ve made my tragic mistakes on DropBox myself. Fortunately I have the technical experience to patch up two corrupted project files and create a functional Frankenstein out of them, but if even someone who is aware of the issues and is generally very careful about things can foul up now and then, it simply is just not advisable to leap all over these brand new technologies in the hope of scraping off just a little tiny bit more “convenience” from the efficiency tree.

Remember a lot of these companies promise big to satisfy their marketing demands. Apple promises MobileMe will change your life and revolutionise the way you access information—just sign here and pay $100 a year.

Again, the problem isn’t Scrivener projects. There are plenty of bundle formats out there. There are plenty of bundle formats with aggressive auto-saving, and these issues are not new to any of them. You can even make a royal mess using some of Apple’s own disk image formats on their own iDisk technology. It is very simply nothing more than an abuse of what is technically sane and robust. It is expecting too much of technology; and in many cases being sold a lot of snake oil.

To be clear: This isn’t a “users are stupid” rant. I place total responsibility on the companies that are pushing alpha and beta protocols and methods on an unaware public. The public shouldn’t have to know about packet loss and signing and hashes and all of the technicalities and complications that come along with these abilities.

Not that it means anything to anyone, but I agree with Amber.

I would add that “multi-access” systems (which is what folks are approximating with these solutions) require more than passing integration with all tools that will be utilizing the common store. Unless you are using a tool written for express use with a multi-access store, you should avoid them with a passion.

[size=75]I am working on a little “thingy” (that is a technical term) that might help folks a little with this type of sync issue. I need to get the spec up, and see if KB will bless it before I mention it with any detail. [/size]

Snot!! It`s a Stockportesianequeish Colloquialisismm

Truth is, I agree with Amber too … which is why I said I didn’t know how to word any such message to new users. I use a fair number of other “bundle” apps — OmniGraffle Pro springs to mind … for that you can switch to “flat file” format to solve the problems that seem to happen with saving to a Windows network drive — but none of them so far in a way that means I want to access the “files” every day from whichever computer I happen to be on at the time. Scriv is … well not always immediately totally straightforward to use in that it’s so powerful … just look at all the threads we have in this forum … but the bundle side of it is brilliant, transparent and totally robust until you start working with network drives, etc. I think that is something that new users might benefit from being made aware of.

And yes, the developers are promising nirvana, but what you get is a banana* … delicious it may be, but it doesn’t solve all your problems and has a skin on which you can slip.

[size=85]*banana/nirvana became a family colloquialism when my daughter, at the age of about 4, began calling them that … :slight_smile:[/size]

Just a quick point to mark’s last post. The issue is not the package format, but an inherent problem with IO sync over latent media and/or unstable media. The package format is used by many progies on mac and is simulated on *nix platforms and by some M$ software (docx anyone?).

Back under my rock I go…

Jaysen, I think we are all agreeing … it’s just I’m not good enough at speaking Geek :blush:

And I shall withdraw into the woodwork once again. :slight_smile:


I’m afraid mountains are being made out of molehills, here.

It’s simple. When you create a new Project, save it in your Documents folder. You can find your Documents folder in the popup menu list that’s just below where you give it a name. If you want to save it on your Desktop that’s OK, too, but do remember exactly where you saved it.

If you want to backup your project, select Backup Project To… from the File Menu, check the Backup as ZIP file checkbox and save it to someplace that is not on your computer hard drive: another external hard drive or your keychain drive or your iDisk or your DropBox or your tape drive or your DVD or your CD or your Trans-ethereal V7 storage media.

If you are concerned that you won’t remember to do this, you can use Apple’s Time Machine, or a wide variety of more sophisticated backup systems that require serious attention when setting them up.

For the demented among you (or the serious sysadmin types) you can spend some real money and get BRU.


I’ve read this entire thread with interest, because I could so empathize with the OP. As one with a very non-technical mind so far, I’ve notice that Amber in particular has a way with words, of saying what she means, even very technical things, and getting her thoughts across. She’s cogent. That’s a real talent.

I got an iMac in Nov and a Macbook last month. That’s the only reason I have for wanting to Sync things. I’d like to know from Amber what she’d suggest first for just transferring normal files between my 2 computers, then what she’d recommend for more complicated programs like Scrivener, or even PersonalBrain.

I’m so glad the lost files were found! I love happy endings. :smiley:

Thank you very kindly. I think it has been mentioned before in this thread, but the best method is to simply use the “File/Backup Project To…” feature to create a zip archive on your iDisk. I’m not sure how iDisk works practically, really. I’ve always used free alternatives. However you transfer files using it, just move the zip file accordingly. Personally I like to keep all of these zips around since they are dated. Not only can I pluck the last one off when I sit down at a new machine, but it keeps a running backup of project progress. Detailed instructions here.

This worked for me!