Scrivener 1.5 update - missing scriv projects and lost work


I can see there are a few different threads here about Scrivener files going missing and work being lost, and while I don’t want to just add Yet Another Thread on the topic, I feel this is a very important issue, and I want to create a fresh discussion on it as my experience seems to relate to the recent 1.5 update.

I am a novelist, and have been using Scrivener happily for a year or so. This morning I opened Scriv, and it told me there was an update. I downloaded and installed, then when it was done I went back to my project.

Eight hours later I opened Scriv up again, and instead of opening my current project automatically, I was presented with a blank default screen. Going to File > Recent Projects, I was slightly alarmed to see that the only things listed were projects from months ago.

Puzzled, I searched my Mac for every combination of file name and file type I could think of, and could only find these very old .scriv files.

Everything else has VANISHED. Completely, utterly, miserable gone.

Now, fortunately I backed up on Thursday last week so I haven’t lost my entire 100,000 words - only about 4 days worth of work. But I’m now behind schedule, and recreating that lost work is a particularly nauseating experience.

I am a ‘pro-level’ Mac user. I know how my computer works. I know how Mac OS X works. I used to write for a Mac magazine. I used to work on Mac support for an ISP. I’ve spent a hair-pulling few hours trying to work out what happened, but the only thing I can think of is that the 1.5 update somehow reset Scriviner to a state of a few months ago, and deleted all projects created after that point.

I’m lucky as I at least didn’t lose everything, but seriously, for a programme like this to have a bug like that just DEFIES belief.

I really hope I’m wrong, that it’s not a bug and somehow the gods of chance have just turniped my computer, but this seriously needs investigating.

It looks like I’m not the only person, going by this forum. And I have to say that as much as I love the programme, I am now moving my novel into Word (or heck, even Text Edit) so I don’t lose any more.

I’m a professional writer with deadlines, and I just cannot take that risk.

I would appreciate the thoughts of the developer on this topic.



Hi Adam,

Could you please give me as much detail as you possibly can on this issue? Everything that happened before the upgrade and afterwards; when you last opened the project; whether you were saving to a local hard drive or an external drive; anything you have done to your computer; pretty much every detail you can think of, no matter how irrelevant it may seem. Obviously I take reports like this very seriously. Unfortunately in all of these reports so far nothing has come to light to investigate. In the other thread about lost work on this forum of the past couple of days, it turned out that the users had been adding text to their tutorial project (which does get reset whenever Scrivener is updated). In all other cases - and I stress that there have only been about five out of thousands of users, which does not make me take it any less seriously, just that there is very little to go on - the user has been unable to tell me anything other than that their file has gone missing. Usually while Scrivener has been closed (and it has never been related to an update in the past). Obviously Scrivener cannot do anything while closed; nor does it do anything malicious at close, other than save the project. Of course files do go missing occasionally - when the update was first released, the updater refused to work properly at first and this turned out to be because of a missing file inside a framework I was using. I have no idea how that file went missing from the Finder, but it did. So, whilst I very much want to investigate ANY incident of lost work, so far there just has been nothing to go on.

I hope you don’t take the above as an excuse - far from it. If you can give me as much information as possible, I will do my utmost to look into your issue. But there is, unfortunately, very little I can glean from a file just going missing. I have investigate the code itself thoroughly to ensure that there is nothing that could delete a project from the file system. I have tried everything I can from previous reports to lose a project, and have never been able to do so…

Thanks and all the best,

Hi Keith,

I appreciate the quick response, so here’s the lowdown as far as I can describe it:

  1. I use Scrivener every day. I started a brand new project for this novel. As well as saving the file with Command-S, every day I use FIle > Backup Project To and create an archive file which I rename with the novel title and the day’s date.

  2. This morning I opened Scrivener, and my current project auto-loaded as it always done, right where I left off.

  3. I was presented with an update available window - I hit the install button, and it downloaded and Scriviner quit. It did not re-open automatically like it said it would.

  4. I opened it manually, and my project was there as it was a few minutes earlier.

  5. When I was finished, I did command-save, then Backup Project To and created a new .scriv file.

  6. I have a 2.4 GHz iMac, with a 500 GB internal hard drive and 3 GB of RAM. All files were saved to this local hard drive. The drive has a single partition. The computer is running Mac OS X 10.5.6.

  7. The computer was on and used all day, but Scriviner was not opened.

  8. About ten hours later, I came in, opened Scrivener, and was presented with the starting dialogue window which presented the options of start new project, open existing project, etc. My project did not auto-open.

  9. I went to Recent Projects, but instead of the long list of my daily archived files, it showed just four files dated from last year.

  10. I searched my computer for all instances of .scriv, Scrivener, and any files with my novel title or the date format I use for the file name. There were no files found at all. The only Scrivener files were those old projects and the Scrivener application itself.

  11. Having found a back-up from last week (saved onto an external HDD that I plug-in and un-plug as needed), I’ve tried every way of replicating the data loss (including not saving the file, quitting the app, re-opening it, etc etc), but I can’t do it.

Let me know if you need any more information. I know I didn’t save my project over the tutorial file, as I had created a few project from scratch for this book.

Scrivener appears to have reset itself to a state from last year, and all .scriv files from a date after that point have been deleted.

The computer has not crashed recently. It was powered down at the weekend for a few days as I was away. While I tried to find the .scriv files I did restart it in case it was the Mac OS X Finder reporting incorrectly.



One question in here:

You mention it was in use all day, and then use the words “I came in”. Does that mean that the computer use was not done by you? Does anyone else with access to the computer know how to use the backup software and hardware? This sounds like a botched restore or something. Also you say Scrivener appears to have reset itself to a state from last year—you mean the application itself is back to version 1.11 (or whatever you were using at that time)?

Hi Adam,

Thanks for the detailed information. This is beyond strange. I’m not sure how anything could reset to a state last year. This actually makes me think that there must be something more at play than just Scrivener, though. I just cannot see how it could wipe all of the projects from the past year. In a worst case scenario I can imagine an application somehow wiping a file or two that had been open in that application - but not all the files you had archived or that hadn’t been open in Scrivener for a while.

Do you use any backup software? Such as time machine? I am wondering if there is some sort of conflict going on with some software that might restore files to an earlier state. Sorry, I’m still stabbing in the dark here, but the only thing I can think of is that something has somehow intervened and set things back to an earlier state on your machine, at least as far as Scrivener files are concerned (there is no way Scrivener can do this itself as it does not keep track of this sort of thing).

Could anything like this conceivably have happened? If you use Time Machine, I wonder if I need to investigate it, as I have never used it myself.

Thanks again and all the best,

Two more questions:

  1. Do you use any sync services?

  2. Have you checked if only your Scrivener files have vanished or if others have gone too?

Ok, some info!

  1. The computer was on all day running Mail app, and was also used as a large monitor to display a couple of PDF files that my wife was working on (on her laptop). She didn’t touch anything, and never does. Plus, she’s as Mac-savvy as I am.

  2. I use no backup software - no Time Machine, nothing. I do manual back-ups to the external HDD.

  3. I use no synch software.

  4. It is only these Scrivener files that have dissappeared - other files I was using at the same time, such as a word count tracker spreadsheet in Excel, are there and up to date (the spreadsheet shows the lost word count from this morning).

  5. The version of Scrivener is 1.5 - so it updated, and is still updated.

I’m lucky that I have that back-up so I could put this down to just exceptionally bad luck, it was just the posts from other users of missing files on this support forum that alerted me.

The fact that Scrivener is not displaying anything more recent than last year in the Recent Projects list, and that I have zero Scrivener files from past 2008 on my computer at all, is just completely baffling. Like I said, I know my way around Mac OS X and I have no hacks, haxies, mods or add-ons that might cause system instability. The only other recent install was Safari 4 beta from last week when it was released. I haven’t seen this kind of file disappearance before.

I’ve had no other problems with other applications recently.

I know it’s an old Mac OS 9 excuse, but are there such things as “corrupt” preference files or other Scrivener files (hidden or otherwise) that might have got hosed during the 1.5 update?

Indeed it is. And more than that: it is scary. But the fact that Scrivener is not displaying anything in the Recent Projects list from past 2008 does not mean that Scrivener did whatever was done.

The Recent Projects list only displays existing files. I don’t know how it works but I guess it’s an OS function—when you move .scriv files via the finder while Scrivener is closed after you restart it the Recent Projects list will track down the .scriv files to their new locations, even to the waste bin if it is not emptied. If a recent project is deleted its entry in the list won’t remain and cause a File Not Found message when you click it, it will just go too.

EDIT: One more idea born of utter helplessness: Without doubt something weird happened on your machine. So maybe the Spotlight index is corrupted too and does not find the .scriv files. You could re-index it but that would take some time and I would not recommend it without having a real reason to do so.

But you might search your computer with other software. Take a look at Leap would be a good choice, and there is something new called Fresh which looks promising. No, I don’t have any business relations to the Ironic Software guys, I find their apps pretty interesting and pretty expensive too. I was referring to trial versions, of course.

Baffling it certainly is.

I can’t help feeling that the main clue here is how it has reverted to earlier files somehow. Have you double-checked with your wife everything she did? Even tech-savvy users can do odd things. I consider myself a pretty tech-savvy user but I still occasionally manage to dump files in weird places or click a button I didn’t mean to.

Preference files can certainly get corrupted but that wouldn’t cause lost files. It could cause Scrivener to crash, to come up as the trial version, or to have no files in the Recent Projects list, but it certainly could not destroy any. On the other hand, the fact that the Recent Projects list suddenly showed projects from a year ago - this suggests that the preferences file was replaced with one from a year ago, given that the preferences file holds the list of recent projects. This again isn’t something Scrivener itself could do - the saving and loading of preference files is handled by the OS X architecture itself.

This recent projects thing is particularly interesting, in fact… Were those files still on disk anyway? Or have they reappeared from nowhere? Are they in an old state or the last state you remember them being in? As I understand it, the preferences file only ever keeps a record of the last eight projects open. So if these are files that haven’t been in the recent projects list for a year and only now reappear there, this suggests that the preferences file must have been replaced with an older one.

Out of interest, where do you store the Scrivener files? I know you said on the local drive, but do you store them in a folder of their own or are they in different folders around the hard drive?

Still stabbing in the dark here…

Thanks again and all the best,

There’s still hope that this is just a case of misplaced files. A search in the terminal might bring up some results:

find ~/ -name "*.scriv" | sort


sudo find / -name "*.scriv" | sort

Please do not be insulted but has anyone else been in your house? My grad student lost his thesis to an ex-girlfriend from whom he forgot to get his spare key. She wiped all his back-ups as well. But… only his thesis and nothing else, not a single other file. (She blamed his going back to school for the break-up.) Because of this, it took him a long time to figure out what happened. His natural response was to blame the software too. Who wouldn’t? I had an older version I had previously read through on my hard drive. He lost everything else.

When you lose everything but one old random preference file, it looks like some did a search and deleted everything on purpose. I hope this is not the case.


I’m just wondering if Adam, the op, is still following this thread, and if so if if he has any more information? The thread got a little sidetracked, and I probably should have split it into two, so apologies for that.
All the best,

Oops, sorry been flat out last couple of days! I’ll respond properly tomorrow morning… but, yeah, this thread is kinda big and off-topic now!

Hey! I resemble that remark!

I’ve split the topic in two to make it more manageable. The other topic is now here:

All the best,

Hi, Adam,

Here are my three troubleshooting offerings:

According to what you have said, not only did you not find your scriv projects, but, I gather, you did not find your Backup-Projects-To files /either/. Where on your internal hard drive were you storing these back-up-projects-to files? Where on your hard drive would your regular project files have been?

Two things I notice about the incident report:

i) Scriv did not reopen after the update install as, apparently, it said it would.

ii) I am very curious about this pair of statements: “When I was finished, I did command-save, then Backup Project To and created a new .scriv file.” and later “I went to Recent Projects, but instead of the long list of my daily archived files, it showed just four files dated from last year.” I am not sure what is bothering me about these statements, but it suggests a practice in how you use and manipulate your project files that is unusual and needs to be understood. This is definitely something I would explore in trying to troubleshoot this problem.

Here are some good questions to ask: where did the very old scriv files come from? Were they all the time sitting unused on your hard drive? Also, are there copies of these old files stored on your backup drive? Are the old scriv project files old versions of some of your current projects–and hence had the same names?


Here’s what happened to me.

  1. I downloaded and installed Scrivener 1.5 on Monday, after trashing the previous version.

  2. I used it Monday through Thursday with no problems that I was aware of.

  3. When I tried to start Scrivener this morning, nothing happened. I looked in the Applications folder and noticed the icon was still there but the size was 54 KB (something like that, anyway). I opened the file I was working on yesterday by clicking on it in the Documents folder and it opened in TextEdit.

  4. I downloaded Scrivener again and the program seems to be working but it certainly makes me nervous. When I installed it for the 30-day trial and then tried to register, Scrivener knew that I was already registered. On Monday, when I first installed the program, I had to register again.

  5. I installed the extras but when I went to /Library/Applications Support they weren’t there. I tried to open Scrivener.dmg to re-install them but I cannot open it. I got a “warning message”: “Device not configured”

  6. Fortunately my files remained on the hard drive in the Documents folder. I believe they are intact except for the Project and Document Notes. They are not the same notes I had yesterday.

I am running OS X 10.4.11 on an iMac with 512 MB SDRAM. The processor is 800 MHz PowerPC G4. I haven’t done anything unusual on the computer this week. Everything else is working fine. My files are stored on the internal 60 G hard drive.

Hi everyone,

Apologies for vanishing into thin air, but fact is I have a deadline to meet for my novel, and I’ve been too busy writing! Writing, I am happy to say, in Scrivener, which seems to be behaving itself.

So just to close the topic off, I haven’t been able to replicate the loss of work (deliberately or accidentally), and Scrivener has been reliable since then “incident”.

I have my work saved as a single .scriv file, and after each writing session I also use the Backup Project option to save a zip file to a removeable USB drive. Seems to work so far, and it’s keeping pretty tidy with the one .scriv file on the computer and a billion zip backups on the USB drive.

The reason I bowled in with my original post was that I did think that something was amiss in Scrivener, and looking at the forum I see people are still reporting lost work. The symptoms of the loss - the application opens but the project does not load automatically - seem to be the same or similar, and that’s what I experienced, hence my call to this support forum.

Anyway, nothing to report now and I’m happily heading towards my target wordcount… although I do need to go back and re-write those 1000 words that bit the dust!

If I an be of any further help, just let me know, and I’ll make sure I reply promptly!



Hi Adam,

Many thanks for the update, and I’m glad things are going well now. I’m still just trying to collate as much information from any reports that arise, obviously, to see if I can find any common thread. Let me know if you have any more issues or if anything else ever comes to light that might give any more clues, of course.

Thanks again and all the best,