I just got the notification to update this morning, and have tried several times to apply it. It downloads, then asks to install - like usual - but does not install after clicking. Am I doing something wrong? I’m running Windows 10 and have had no trouble.

Thanks for any advice… :slight_smile:

I also downloaded 1.9, but I don’t even get the install button to click; Scrivener just closes.

Where is Scrivener installed on your machines? Is it as an admin or standard user?

Generally, if you’re having problems with the auto-update from within the program, you can work around it by downloading the installer directly from the L&L website and installing over your current version when Scrivener is closed. Give that a try and see if fares better.

For what it’s worth, the auto-update worked fine for me, also on Windows 10. I do run as an administrative user, so I don’t know if that’s related, though it’s never asked for elevation. I was updating from the latest beta.

I tried looking for the direct download but I can’t find it. As far as I know, I’m admin on my laptop… But Windows 10 is still new for me. :blush:

Link is at the top right of this page, “Download for Windows”. Here’s a direct link for the installer.

Thank you! :heart: Giving it a try. Will let you know if it works better. :slight_smile:

Still would not update. :frowning:

Also tried locating the app in the start menu, right-clicking to select “run as administrator” and downloading the update again… nothing. :frowning:

Okay, so you’ve downloaded the full installer from the site, saving it to Downloads, double-clicking to run it while in an administrator account, and…what happens? Does the installer open at all? Also, have you tried rebooting the computer? You might try installing from Safe Mode, in case there’s some other software on the system interfering with the installer running.

… and absolutely nothing happens. It will not run from Downloads, from the Scrivener link, nowhere. I haven’t tried rebooting, will do that once I’ve finished working - it’s possible things will be different after.

But this has never happened before with any of the other Scrivener updates… I’ve had it for nearly five years now…

Thanks for helping by the way! :slight_smile:

Have you tried completely uninstalling your current installation of Scrivener? Maybe there’s a registry item or program file that’s causing problems and just needs to be removed first.

Uninstalling doesn’t necessarily clear the registry, unfortunately.

Uninstalling ought to clear Scrivener’s registry entries–file path and so on can get messed up sometimes, if you’ve had multiple installations, but uninstalling will remove that. It seems unlikely though that Scrivener’s registry settings would affect being able to start the full installer, however. I’d try the Safe Mode just to see if it will at least open there; that would help narrow down the potential conflicts.

In the folder where you downloaded it, right-click the Scrivener installer and select Properties.

If you see a warning there that the file came from another computer, click Unblock, then OK.

Now try it again.

worked perfectly on my system :smiley:

It isn’t labeled blocked, and whether I try to run the updater normally or as admin, now I get the message below (I didn’t type the whole message)

“windows cannot access the specified path…”

When right-clicking for the properties suggestion, I also tried running the compatibility option and the result came back that it was set for windows 7. Windows 10 is on my machine - would that make any difference?

Eureka! Dang, being pigheaded is sometimes a good thing. :stuck_out_tongue:

The problem was indeed in my security settings. Not in Windows 10, however, but in my antivirus software. I did three things (for anyone who has the same issues), and I’m not sure which one worked (though I suspect it’s the last and simplest one):

In my antivirus, I added Scrivener to the exclusion list of folders.
The same, but to the list of files.
Deactivated the anitvirus for 10 minutes while running the installer. I’m willing to bet it was this one that did the trick.

Update installed, happy camper here! :smiley: