Scrivener 2.3 Mac - OPML Import broken.

My normal method of writing is to outline my thoughts, formerly in OmniOutliner, now with MindNode. I export those to OPML and then import into a blank Scrivener document to create my index cards.

This morning I fired up Scrivener and it prompted me to update to 2.3, which I did.

Since then I am unable to import OPML files.

Requested Step-By-Step:

  1. Create new blank document
  2. File > Import > Files and navigate to the directory holding my file

No matter what I do, the file is grayed out in the file dialog. I cannot get any file named anything.opml to be selectable for import.

As a test I took a pre-existing .scriv and exported it to OPML. Scrivener grays out this file as well and cannot re-import into a new document.

This has worked many times in the past. Could this be a bug in 2.3?

This is sort of a huge deal for me because OPML import is a key piece of how I work. I don’t have time to recreate my outline in Scrivener so for this current task I’m going to try to just wing it in a text editor like Byword as a single document, using my mind map as a reference.

This is Scrivener for Mac, version 2.3, OSX 10.7.4.

File was originally in dropbox, but also fails from Desktop. File has spaces in name, but asdf.opml still fails. File originally had no .opml file extension but still fails after I renamed it.

Here’s a screenshot of the file dialog, note the bottom line:

I’ve got a massive paper due in about two weeks, I’m hoping that L&L can either fix this and release a new version, or, more probable, point out what I’m doing wrong. Without OPML import Scrivener is sort of broken for me.

Chris, this thread ought to solve your problem.


Hi Chris,

This is a minor bug in 2.3, yes, which will be fixed in the next update. Until then, it’s very easy to fix on your end. Just go to the “Import/Export” Preferences and add “opml” to the list of “Plain Text Import Types”. “opml” got accidentally deleted as an import type while I was creating this feature, so adding it there fixes it. I have added it back as a built-in import type for the next update.

All the best,


Fantastic. Just so I don’t look like a complete idiot, I did search for the problem, but I searched only in bug reports and not the tech support forum.

On the upside anyone who does the same will now find this thread :slight_smile:

And, as expected, this worked perfectly.

No harm, no foul.