Scrivener 2.5 crashes once a day now

Scriverner crashing every day now. Beeing frustrated and because I fear to loose my writings, I now went back to NeoOffice, which took me a full day. In principle, I like Scrivener. Thus I give you the chance to offer me a solution. – But I don’t not want to fiddle around too much with the software, I just want to have a decent working tool.

Just before Christmas I had to buy a new MacBook Pro with Mavericks. Updated everything. Even Scrivener: 2.5 (25236) (from App Store)

On 5 January, when I started again with the real work on Scrivener, it chrashed after about an hour when I switched from Scrivener to look a PDF file in the background. When I switched back, Scrivener crashed showing the chrash reporter.

After starting up the Mac and Scrivener and tried to repeat the switching, it crashed again. Now I am afraid to switch from Scivener to another programm or to call another program via the dock while working with Scrivener. It is quite awful.

On 6 January I started with Scrivener again, but is did not open at all, just showing the crash reporter. When starting Scrivener again, it came up. However, when shutting down the Mac totally and starting again, Scrivener crashed again, but ran again when I restarted Scrivener.

Since then Scrivener crashed nearly once every day. That is not the Scrivener I used to work with since about 2 years.

I am now very anxious to continue to use Scrivener, which is per se a fine programme for a writer like me and it worked on my older Mac since I bought Scrivener 2 years ago. But as I am in a final phase of a project and have a deadline with my publisher, I am now transferring all files to NeoOffice. Quite laborious, and not comfortable – apart from the additional hours I have to spend just to fix technical problems.

If I can do something to repair this bug, please describe it in simple words. I am not a computer specialist, only just a simple writer with laymen’s knowledge of computers.

Or even better: If the hack, you may propose it too complicated, please provide me with a totally new DMG-file.

Example crash report: download/file.php?id=4807

have you followed the troubleshooting steps to startup with extensions disabled?

The reason I ask is that this sounds like a conflict with an OS extension (based on others having high crash rate problems). the other thing that might cause a problem like this (from a generic perspective) is a hardware problem. I would expect you would see other apps crashing if this were the case though.

Hopefully the L&L team will give you a specific answer shortly.

There are two things that jump out at me from your crash report and so are worth checking:

  1. PDF drawing is mentioned near the top of the crash report. Do the crashes have anything to do with loading PDF files? If so, it may be that you have some bad PDF files in your project.

  2. An input manager plugin is mentioned near the top of the associated binaries area of the crash report: Ecamm plugin loader. Plugins can affect the running of applications, so I would suggest removing this plugin (from /Library/Input Managers) to see if that helps.

All the best,
Keith

Thanks for this. It happened not only when I switched to PDF file, but to any other application as well.

However, I deleted “Ecamm” now. But saved it on a stick in case some other important application may need it. I have no idea what “Ecamm” is for.

I’ll see if it helps and give you my feedback here in a couple of days.

Thanks for your efforts.
/ Hajo

Just a status report.

After having deleted Ecamm, I had the feeling that Scriv seems to be somewhat more stable, but still crashes ever now and then, approx. once every second day instead of every day. However, today it crashed already 3 times.

As to possible corrupted PDF files, I have the documents in the Research folder only as Aliases, not as files (except web pages).

Amazingly Sciv showed today also the crash message when I started it, although I Quit the program correctly before.

And it happened that Scriv crashed unexpectedly when in the background while I was surfing with Safari in the foreground.

Does that maybe have something to do with the sandboxing? For convenience I authorized my whole hard disk, because when renaming a folder or moving the project to another folder I always had to re-authorize Scriv.

The trouble began with my new MacBook Pro and the routine update from the Apple Store. Before Sciv worked fine and I liked it.

Very strange.
/ Hajo

One thing to try is to set up a second user account on your Mac and try using Scrivener in that. Does it crash there, too? If not, then it’s something on your main account causing the issue. If it does crash, then try booting in safe mode (which ensures no plugins are running) and use Scrivener for a while. If it doesn’t crash, this means there’s a plugin running on your computer that is causing conflicts.

I’m fairly confident this must be something on your computer causing the issues because the crashes don’t seem to be caused by anything consistent.

Thanks and all the best,
Keith

Big thanks again. I’ll try that.

Today again a number of crashed with about every second PDF file in the Research Folder.

But I will try you proposal as soon as I have a little time to play around. And tell the result.

/ Hajo

Status report:

I worked with Scriv for an hour in Mac’s secure mode. However, it still crashed 3 times during that hour.

Observations:

Scriv crashes after I have openend and closed about 3 to 6 PDFs with Preview one after the other which are stored in the Research folder. It was not a specific PDF at which Scriv crashed. Every time it was a different one. But I have the feeling that those PDFs seem to be especially sensitive in which I used one of the Preview tools to mark text or in which added notes/comments.

Sorry, but Scriv still crashes quite often when opening a PDF or a picture file (JPG or PNG). Not on the same files, but quite randomly after having opened and closed between 4 and 8 files. No matter if fully imported or imported as alias. Tried to run the Mac even in secure mode, set up a second user account and used Scriv from there, repaired the access rights. Even a friend of mine, who has much more expertise in Macs and OSX software (in my case Mavericks on a 4 month old MacBook Pro) than me, looked for half a day at the crash reports, fiddled around with the terminal, changed things back and forth. No result, no solution. The only thing we could not do was to set up Scriv totally new because it is an Apple store version and the Store did not allow to re-download and re-install it.

Very sad and sorry.

Because I still find that Scriv offers a very comfortable way to write my books and stories, I am not eager to look around for another app for writers. I decided now to ignore the Research Folder in the Binder totally and store my research files in Finder folders as in the old days and use them from there.

Unfortunately the Research Folder cannot be deleted from the Binder and hangs now around in my Binder without any function. This disturbs me a bit and I should welcome hints on how to delete the Research Folder.

I am sad, a bit frustrated, but not angry. 45 dollars for Scriv was okay, but I realise that you cannot get a perfect working app for that price. I can live with it.

@KB: Thanks for your efforts to help me, although with no success. But I am no software nerd, but just a writer. And that is what I still can do with Sciv in a comfortabe way. I do not like to test and fiddle around with the software for hours and hours (that is why I have a Mac, which is comfortable and easy to use).

All the best
/Hajo

Hi,

Sorry to hear about your problems. Two things I’d say as a user:

  • don’t try to delete the Research folder. It’s an intrinsic part of the programme, and despite the problems you’ve been facing, if it’s empty, it shouldn’t do any harm, and deleting it could - I’m guessing here - cause other problems;

  • in almost seven years of pretty much daily usage, admittedly none stretching the envelope of possibilities, I think it fair to say that I’ve never experienced a Scrivener crash. So I’ve no idea why you’re suffering what you’ve suffered, but from my own experience, I’m hesitant to blame the application. If it was happening to me, I’d look at the hardware, other software, and the files within the Research folder. And I’d send the project ‘file’ that has given you problems into L&L to be looked at.

H

Quick question: are all the PDF from the same source? Has KB had a chance to look at a PDF that is causing the crash? It might be that there is a problem with the way the PDF is being created that is causing the crash.

Hugh,

you have a nice signature under you post!

Well, I used Scriv since about 2 years only. Also using it every day without any problems – but on my old MacBook Pro from 2005, updated until OSX 10.6.

The problem came up with my brand new MacBook Pro with Mavericks. It was only Scriv which made problems. All other, even older software run (one is from 2006 and runs perfectly).

I like Scriv, that is why I do not abandon it. It is perfect for writing with all the possibilities of adding notes, footnotes, annotation, word/character countings and much more. It is okay even without using the Research folder (so I’ll leave as it is).

/ Hajo

Jayson,

no, different sources for the PDF files. I printed some from Word or TextEdit and web pages using the Print dialogue of the Mac (“Print To PDF”), some with NeoOffice’s “Export To PDF” function, but most have been downloaded “as is” mostly from scientific repositories, from web pages of science institutions or from government web pages.

It is okay form me just to write, sort, annotate, play around with my texts. It is also perfect to synchronise the texts (in the Draft folder) via the external Sync folder with my Android phone using my own web/server space of my provider and edit the text files while travelling.

I can live perfectly without useing the Research folder.

Best
/Hajo