Scrivener 3.0.1.0 broke TouchCursor

After updating to Scrivener 3.0.1.0, I can no longer use TouchCursor.

TouchCursor (martin-stone.github.io/touchcursor/) is a typing assist software that allows you to hold down the spacebar (or any key of your choices) and activate macros hotkeys that can do things like jumping your cursor one word forward or back, or jump to the beginning or end of the line, or move one space in any direction, or highlight an entire word or line in forward or backward directions, or delete/backspace entire words, etc.–all without ever leaving home row. It has been indispensable for me and completely integrated into my typing.

Prior to 3.0.1.0, TouchCursor had worked fine for many years while using Scrivener, but now it suddenly doesn’t work with Scrivener anymore. Holding down the spacebar simply behaves as if TouchCursor is not activated/installed. But in all other software TouchCursor still works fine, including with Scrivener 3.0

Maybe this is as simple as changing a setting in 3.0.1.0, or maybe it’s much deeper rooted, but I need TouchCursor as it’s been part of my muscle memory for over a decade and it’s very clunky to write without it.

Can I downgrade to version 3.0 so I can use TouchCursor again, and wait for whatever next version might be and see if this problem will be fixed by then?

I don’t see why not. If 3.0.0 worked for you before, it will work now. :smiley:

A downgrade would be a complete uninstall of 3.0.1 and then an install of 3.0.0. This will not impact your project data, although you’ll lose things like your Recent Projects setting. Also, I’m not sure what happens to custom layouts, projects templates, etc. Prior to the uninstall, to be on the safe side, you should review your Application Support folder (File > Show Application Support folder) and make a copy of the folders that contains things like custom layouts, projects templates, etc.

Also prior to the uninstall, if you haven’t already saved your Scrivener settings, do so first (File > Options > Manage > Save Options to File).

Uninstall 3.0.1.

Download 3.0.0 here: https://www.literatureandlatte.com/scrivener/release-notes?os=Windows

Install 3.0.0.

Copy back the contents of any of those Application Support folders that you saved.

Launch Scrivener 3.0.0. Select your Backup location. Open a project.

Restore your saved settings.(File > Options > Manage > Load Options from File).

That should do it. I hope the next update solves your issue. You may want to save the 3.0.0 installer, in case the next update doesn’t and you have to go through this again. :frowning:

Best,
Jim

I never heard of TouchCursor, but I love those kind of small but powerful utilities and know how easy it is to become dependent on them, and how disruptive it can be when all of a sudden they seem not to work. Hope you get it sorted soon… not updating Scrivener is probably not a great long term option…

I use AutoHotKey extensively, within applications and across Windows. Just starting to use it with Scrivener.

I just had to uninstall/reinstall v3 to solve another issue, but based on that experience, wanted to amend my post above.

  • The uninstall process doesn’t touch the Application Support folder, so no need to make a copy as I suggested.
  • If you’ve replaced the default dictionary with a custom dictionary, you’ll need to do this again after the uninstall/reinstall is done. Make a copy of your custom dictionary folder prior to the uninstall. :slight_smile:

Thanks. I’m currently trying to find other alternatives besides reverting back to 3.0, since as Mad Girl said, it’s not an ideal long-term solution.

Can AutoHotKey do what Touch Cursor can? Basically, It’s just programming the macros for CTRL or SHIFT + arrows/home/end/page up/down, delete, and backspace, then mapping to home row keys that are activated by holding down the spacebar (or any other key you choose to use as the activator).

I would imagine that AHK could do that; when I looked into TouchCursor, it sounded much like an AHK script, in its essentials. For example, I use AHK so that I can use the right Alt key + the Menu key in combination to simulate a Ctrl key, since my kb doesn’t have one on the right side, which I’m used to. I use that in another program, not Scrivener, but it works in Scriv just fine: when I press Menu+Alt+n, it creates a new document! It’s like magic! :slight_smile: .

But it would take more scripting skill than I possess to put together something like TouchCursor that worked reliably. I use AHK extensively, but not especially deeply. :slight_smile:

But the basic functionality of TouchCursor would likely not be too complicated.

Seeing this thread, I tried out TouchCursor, installing via TouchCursor-1.7.1.zip rather than TouchCursor-1.7.1.exe, and so far, on my system (Win 10 Pro,64-bit), it seems to work well with Scrivener 3.0.1.0.

You got me all excited, but I just tried it, and it doesn’t work on my end.

I wish I knew what to suggest, but this is the first time I have come across TouchCursor. That it works on one instance of Scrivener 3.0.1.0 and not another might, maybe, be a clue that some setting, on Scrivener or TouchCursor, is involved. Perhaps, to get another clue (and see if something affecting the spacebar is the issue), if you haven’t done this already, try changing the activation key on TouchCursor to something besides the spacebar, just for a brief test, and see whether it still doesn’t work on your Scrivener 3,0.1.0.

And by the way, Lunatique, thank you very much for this thread, because I had never heard about TouchCursor until I saw this thread.

Glad to spread the word about TouchCursor. IMO, anyone with the ability to touch type should use it, because it makes navigating/editing your test so much faster/easier.

I have been reluctant to upgrade to 3.0.1.0 on my other computer (laptop), because I didn’t want the same thing to happen, but I just took a chance and tried it, just in case this problem is only on my desktop. And turned out it works fine on my laptop with TouchCursor, so the problem is isolated to something on my desktop computer. I’ll have to figure out what it is.

I just tried to reinstall TouchCursor on my desktop, to see if that would chance anything. I didn’t have high hopes–it was more like a last ditch effort. But it actually worked! It’s now working again with Scrivener! I have no idea why this would fix the problem, when it worked fine with all other software besides Scrivener.

Anyway, problem solved.

I just downloaded the portable version of TouchCursor and it appears to be working just fine in Scrivener 3.0.1.0.

Maybe try running TouchCursor with a compatibility setting?

EDIT: I see you’ve got it working. It’s a clever little program. I can see why you’d want to use it! Glad you’ve got it back.

Ok, things just got even more strange.

So today, TouchCursor stopped working with Scrivener 3.0.1.0 again. So I did an experiment by simply installing TouchCursor again (without uninstalling it first), and that got it working again.

WHY IS THIS HAPPENING? I have never seen anything like it.

Another thing I’ve noticed, is that after I reinstall TouchCursor so I can use with Scrivener 3.0.1.0, it’ll remain “working” for the rest of the day, even if I close Scrivener and open it later that day. However, once I restart the computer, I’ll have to reinstall TouchCursor again so it’ll work with Scrivener.

Sounds like you may not have “Run at startup” turned on in the TouchCursor settings.

TouchCursorStartup

I wish that was true, because it’d be an easy fix. Unfortunately, that’s not it, because it’s always been running at the startup every day I’ve been using TouchCursor for that last ten years or so, and it’s always worked fine.

Unfortunately, the new 3.1.0.0 update that was just rolled out didn’t fix this problem. I still have to reinstall TouchCursor every time I want to use it with Scrivener, and this problem ONLY exists when using Scrivener, and not any other software I use.