Scrivener 3 claims to convert Scriv 1 project but does not import any text

Scrivener for Windows user here. I just upgraded to Scrivener 3 today and noticed something disturbing; when I open one of my projects in the new version, it seems to create all of the binder/folder structure correctly, but all of my text is completely blank. Fortunately, I have backups, but surely this is a bug of some sort? L&L doesn’t expect us to copy/paste all of our material from Scriv 1 to Scriv 3, right?

So, in a nutshell, how do I open my projects from my previous version of Scrivener in the new version and actually have it work?

You simply open it, provided that you give v 3 access to the whole project folder.
Have you moved the projects before opening with version 3?

How do you mean “give v 3 access to whole project folder”? Am I supposed to modify folder permissions at the Windows level?

Here’s what I did:

  1. Installed and started V3
  2. Opened my work-in-progress, which is a V1 project.
  3. V3 asked me if I wanted to convert the old format to the new. I chose yes.
  4. Project opens, folder structure is intact, but none of my sections contain any text whatsoever other than the section title.

Am I missing a step?

Have you moved the projects before opening?

No, they’re in the original location that V1 was using (I did make backups of those projects that I’ve been copying back into the original location once V3 fails to import correctly. Sort of a “wipe the slate clean and start over” thing).

If you have the whole .scriv project folder, sitting intact where you previously opened it with version 1, you should be able to simply open it with File → Open.

I know, right? :wink:

When I bring everything back to baseline, V1 opens everything just fine. All of my text is there. Without moving any projects, as soon as I try to open the same projects in V3, it goes through it’s conversion process but winds up not importing any text.

Before contacting support, check the exact version numbers.

My V3 version is: Version: 3.0.1.0 (1274136) 64-bit - 28 Apr 2021

And whivh version of v1?

V1 version is: Version: 1.9.16.0 - 14 Nov 2019

Then it shoukd work, and works for everyone else.
Contact L&L’s support, via email. You should find it on their web.

Will do. Thanks for the help!

Hi NatR,

This is definitely not the way it’s supposed to work. Conversion has worked flawlessly on all my various large and small projects, as it has for most posters here.

Have you tried to convert any of your other projects? I suggest you do so, even if only as a test.

If the others convert successfully, then perhaps it’s just the one “problem” project that for some reason caused the conversion process to fail on your documents.

If none of your projects convert successfully, then there is a slight chance this is related to your antivirus being overexuberant. (Other posters have mentioned this.) So if none convert, as a test, try disabling your antivirus and see if that makes a difference.

Best,
Jim

About half of my projects are giving me a “cannot access” error, and the rest are doing the same thing as the one I mentioned here.

The only antivirus running on this system is Windows Defender.

I can open all of the above-mentioned projects in Scrivener 1 with no issues.

Yes, the AV issue only seems to be with v3. Posters did not report this issue for v1 or the beta.

As a test, try temporarily disabling Defender and see if it makes a difference. It might, it might not. This will likely be the first thing L&L Support asks you to do, when they get back to you, which will likely be 3-4 days, based on how long they took to get back to me recently. (My assumption from the posts above is that you’ve emailed or will be emailing L&L Support. If it’s not the AV, I agree, you should email them.)

Best,
Jim

I’ll give it a try! Thanks for the advice. Probably going to take a break for the night and get back to it tomorrow.

All systems are different, but, fwiw, on my Windows 10 devices, the only AV I’ve ever run is what Windows runs by default, which is Defender, and I’ve had no problems of the kind described here and on other threads.

I might try doing a new installation of S3 in a new location, and trying to open again.

Maybe try from a different backup. Maybe have S1 regenerate its indexes. And also do a Save-as to a new location and try opening that in S3.

You could pare down the project and see what category or set of items might be the culprit.

Just some things to try.

I’d like to add a suggestion that’s probably, most certainly I’d say, of no help but maybe worth a try as it does take neither much time nor effort.

When you say your project is blank does it mean the documents do not show any visible content or have you actually clicked into one and tried to select some text? If not do so because maybe—highly unlikely as it is—the default font might have been changed to white and then, assuming you are using a white background, the content is there, just not visible.

That would not explain the Cannot Access error of course. Was any cloud service used for saving the projects?

1 Like

Couple more things: what happens if you try to create the Tutorial project from the V3 New Project screen? Also try to to create a new blank project and see if u can add documents and text to it.