Scrivener 3 multiple selection & subdocs - possible bug?

When I multi-select more than one text document, it shows them as scrivenings as expected. However, it has very strange behavior when it comes to sub-documents. It seems that all subdocuments are included in the scrivenings view, even if only the parent is selected, unless you specifically select a subdocument in which case the other sibling subdocuments are not included.

Is this a bug, or operating as intended? Is there a way to get it not to include the subdocuments? In Scrivener 1 it did not include subdocuments unless you specifically selected them.

Note I use the multiple selection feature all the time, not so much for scrivenings mode, but to get a quick word count of a group of documents. But if I can’t de-select the subdocuments then it no longer works for me, as I usually keep notes and such as sub-documents, excluded from compile.

I believe intended as seem same behavior in corkboard and outline views. If pick a folder all contents included

Are you absolutely certain those sub-documents aren’t selected as well in the binder ?
Because, on my end, I can’t reproduce what you described. If I select multiple documents, the sub-documents are left out of the scrivening.

Where do you select your documents from ? The binder, the outliner, or from the corkboard ?

If you use shift to set your multiple selection in the binder (and elsewhere too, I presume), all the parent documents/folders will include their siblings if they are showing (in the binder still).
If, on the other hand, the parent document is in its collapsed mode (not showing its content, but rather a sideward arrow “>”), then it is the opposite, and its child documents won’t be selected among the others.

I looked for a setting to make the parent document show its content in a scrivening by default, but found none.
. . . . . . . . . . . . .

If, on the other hand, what you mean is that you select a single document and are surprised to see its sub-documents display as well (in a scrivening), then just toggle off the scrivening mode for that parent document :
2022-02-27 15_50_11-2102 Le fou - Scrivener

It will then remain toggled off until you turn it on again.

1 Like

I was playing with it some more. One thing I found is that if the selection includes a document that has no children, it behaves more like I would expect.

For example, because “Riverroot” has no children, this selection only includes the parent docs in the scrivenings view, with a total wordcount of 1,986 words:
image

However, when I deselect Riverroot, the subdocs of Pet Friendly and Cats and Boxes are immediately included in the scrivenings, for a total wordcount of 4358 words:
image

If I expand the docs I can see that the child docs are NOT selected, even though their content is being included, and the wordcount remains 4358.
image

Now if I add just one subdoc to the selection, it becomes the ONLY subdoc to be included (wordcount now drops to 2178):
image

I would guess that, because the behavior is so strange and not intuitive, this has to be a bug. I think that only the selected documents should show in the Scrivenings view.

You may be right.
Something is odd here.

Solution :
On top of the documents you select, also select an empty one that is not parent to anything.

1 Like

Thanks, yes, I was actually just about to post this as a workaround! It even works with a Folder that has no children – just call it “DUMMY” or something.

I guess I should submit this as an official bug?

Unless explained otherwise, yes, I think it qualifies as a bug.

It might seem like odd behavior but it’s not a bug. See section 6.4 of the manual, Multiple Selections .

1 Like

image

image
Yep, seems intended as such.

But at least there is a workaround :wink:

You can also get a reliable word count by using the “selected documents” tab in the statistics
image

while unchecking this option first :

1 Like

Wow thanks! I never would have found that info.

So I guess it is working as intended, not a bug.

EDIT: Oh, and the good thing about the Project → Statistics tool is, I can actually leave the “count subdocuments” option checked, as the other option “Count only documents marked for inclusion” works even better for me.

1 Like