Scrivener 3 suddenly refuses to open

I am running Scrivener 3 on a Macbook Pro. My Mac OS is Mojave ver. 10.14.1. I have successfully used Scrivener in this configuration before. However, today Scrivener refused to open. Every time I try and open it I get an error message that says Scrivener 3 quit unexpectedly. This happens before Scrivener has even loaded. I have tried opening it while holding down the shift key, as well as trying to open it with my Mac in safe mode. I also tried uninstalling Scrivener and re-downloading it from the apple store. no luck,

Any suggestions?

Did you by any chance upgrade to Scrivener 3.1 recently? The version that is on the Mac App Store has a bug that will crash with certain older preferences.

Here is a link to the main discussion thread, which includes solutions and further discussion on them.

(And yes, we’re still waiting for Apple to publish the fix; it’s been four days that they’ve had it now.)

How can I tell which version of Scrivener I am running?

Is there any prognoses for when Apples App store will get the fixed version out? Are they just screwing us all?

Open a Finder window. Look in the Applications folder (or wherever you installed Scrivener, if not in the usual place). If you’re not in the column view already then click on the three column icon. Then click once on Scrivener. The last column should show you information about Scrivener, including the version number.

Can you guys not push App Store a little, getting them to publish the fixes version…five days is not acceptable…I believe we are lots of users that this is fucking up our work on projects!

You’ve quoted a reply in which there is a link to an immediate solution to your problem.

Not really. They don’t communicate the status of a review with us, and there is no way for us to communicate with them outside of submission notes (which starts everything all over again). Outside of that, our ability to “push” Apple on anything is about as potent as your ability, through the public feedback forms.

And yes, as noted there are multiple fixes, you aren’t stuck. One of them is as simple as resetting your preferences. In your shoes though I’d just install the direct-sale version. You get to keep your preferences, and that one is going to be kept up to date—we had this bug patched within the hour and shut down the update server until it was up. That’s how we do business anyway.

And this, boys and girls, is why releasing the Apple Store and the direct sale versions simultaneously doesn’t always work out the way we might hope.


I emailed Apple yesterday morning to find out what was going on. As of this evening, I’ve still had no reply, and Scrivener 3.1.1 is still sitting “in review” - it’s been six days now. It’s ridiculous, and incredibly frustrating that we can do nothing other than wait for Apple. It’s even more infuriating given that it is supposed to be an expedited review.