Scrivener 3 Windows - App Crashes when trying to activate licence

Hi there, I have a licence from Scrivener 1 and I am trying to activate this licence on the Scrivener 3 and the app keeps crashing before a prompt is shown. I am following the steps for activating the licence, clicking on the link “Upgrade from an older version”, but the app crashes while “Checking for existing licence” message appears.
I had the Scrivener 1 installed, I have already uninstalled it, but I am still getting the error trying to activate.

I attached the print screen with the error on this topic.

Can somebody help me to find a solution to this?

Thanks in advance.

Scrivener 3 will not accept a Scrivener 1 license. There might be a bug – it should fail gracefully – but that’s the fundamental issue. Upgrade information is here: … or-windows


Hi Katherine! Thank you for the reply.
I followed those steps for the upgrade process having the Scrivener 1 licence. It seems like it is a Windows problem with the app, because it crashes when I click the button that should prompt a new window for me to insert the licence.
I don’t know if I misunderstood the whole licencing process with the Windows version of Scrivener 3, but I remember to buy the version 1 and read that the version 3 would be available for free to those who bought the former one (link: … or-windows).

Hi everyone, to all of you who face the same issue, I just made it work uninstalling the App and turning off my computer and installing it again. I received a 100% free discount with a coupon and received the new licence.

The issue probably was caused by some cache on Windows.


Hi folks
Having the same problem as Victor but his solutions didn’t work for me - every time I follow the instructions on How to Upgrade it freezes Scrivener permanently at the point where I click "“Upgrade from an older version” . Have reinstalled 3 times with PC restart.
Any more ideas anyone?

Hi @diseaseofthewill, sorry about the late response, the e-mail notification of your reply on this post was consumed by the mess of my e-mail organization. Have you already solved your issue? If it is still an issue, I would suggest for you to run a software that clears any cache that Windows keeps in a installed Software. I often use CCleaner to do this kind of procedure. You can download it on

Let us know if your issue was solved!

Best regards!

I was having a similar problem and did the following to resolve it:

  1. Reboot in Safe Mode with Network Support. (This allowed me to launch the app and process the upgrade.)

  2. Reboot in normal mode. (When launching the app as normal, it was still crashing, so I did the following two things.)

  3. Locate the Scrivener.exe file, Under Properties → Compatibility Tab, Check run in Compatibility mode → Windows 7 and check Run as Administrator.

After doing step 3, my app launches and runs great, so far.

Hope this helps any who find this thread trying to get their app working.