Scrivener 3 Windows Toolbar Display Title

Hi all, I’m a longtime user of Scrivener 1 and recently upgraded to Scrivener 3. While using Scrivener 1, if I had two projects open at once, the Windows toolbar would display the window name as the short filename, such as “Project.” In Scrivener 3, however, the toolbar displays the window name as the full filename that the project is saved as, for example, C:\Users\my name\Documents… etc. The issue with this is that I can’t see from a quick glance what I’m working on - it’s quite annoying! Any fixes that anyone knows of for this?

Here is an example screenshot to show what I mean:
Instead of displaying “C:\Users\madel\Do…” I would like it to simply say “Project,” essentially.

It’s at Options>Appearance>General Interface, a checkbox for “show full project path in the title bar”.

That said, if the name is long enough to be a problem, I’d shorten the name. It’s important to know where your projects are.

I’m a big fan of showing the full path (as I’m known to have two similar—if not completely identical—file names in different locations), but the file path can become quite long (due to my obsessively organizing folders and subfolders into a hierarchical arrangement I alone might be able to navigate.)

Still, I do want to see both the path and the filename, so I use the Windows subst command at startup to map subfolders to unique drive letters. For instance, under my Projects folder (the full path to just that is already fairly long) I have the Fiction folder mapped as the F drive and the Non-Fiction folder as the N drive.

The benefit of doing it this way allows me to see F:\Non-Unique Project Name.scriv in one Scrivener instance, and N:\Non-Unique Project Name.scriv in another instance and I’ll still always know not only where the projects are located, but which is which.

As an unrelated side-note, when I look at my mapped drives in Windows Explorer, the various locations I subst’d are all named “Windows” so they show up as Windows (F:) and Windows (N:) whereas I’d LOVE to be able to name them Fiction and Nonfiction so their purpose was clearer in Explorer (i.e., they’d so they show up as Fiction (F:) and Non-Fiction (N:), but—sigh—I’ve not been able to figure out how to make that work (though it IS supposed to be possible.) So, if anyone knows the secret sauce, I’d appreciate being in on the “how-to”.

If I create a SUBST location then right-click on it, the Rename option is available. Do you not get that when you right-click on the name?

Just want to say that I love this use of built-in features to solve problems.

I do get the Rename option. And when I try to change the F-drive (currently named “Windows”) to be named “Fiction”, I always get a dialogue named “Invalid drive Label” that tells me “The volume label is not valid. Please enter a valid volume label.”

So, yes. I do get it. It just doesn’t honor it. It’s infuriating.

It won’t even let me rename it “Windows”! (That might be excused as Windows way of saying “But wait, it’s already called Windows” though.)

Apparently, relabeling a SUBST drive volume is not allowed. … ands/subst

Thank you for the help! This worked perfectly :smiley:

Maybe permissions are part of the equation, because I can definitely rename a SUBST drive. I created one from the command line with “SUBST D: \ C:\Dev\Applications” and it shows up in File Explorer. I then right-click, select Rename, and change the name from “SUSBST Drive” to “DevFolder.”


Hrmm. I’m curious about the first backslash in your SUBST command. My SUBST command looks like this:

subst F: "C:\Users\Charlson\Dropbox\Private Documents\Charlson DB\Writing\Scrivener3\Projects\WIPs\Fiction"

When I open a cmd window and type “subst /?” there’s no mention of a backslash parameter.

I have to wonder if my problem essentially stems from the fact I’m trying to rename a subst’d folder on the C: drive, where Windows resides…

But, as you can see from the length of my path, I really do have need to shorten it :slight_smile:

I tried it with and without the backslash on the drive being “created” and the results were the same – I could rename the substitution.

It does seem like a few levels could be pared from that. :slight_smile:

BClarke’s example is also on the C: drive.

I just tried it on mine, and I got the same issue that you did, Charlson. I’ve tried playing with combinations of admin/non-admin CMD windows, etc., and the only thing I wonder is that my C: has Bitlocker active. I wonder if that’s messing with it somehow?