Scrivener always changes "--" to "–"

Hi all,

I would like to use Scrivener to type my drafts and later compile them in Latex. But I often need to type in the “raw” Latex commands, so I want to write them inside HTML comment tags . But Scrivener always changes the two bars “–” into one bigger one and then the compilation does not properly work. Any suggestions how to avoid this?

Another question: Does someone know how to change the Latex document type from book to article when compiling using MMD?

Preferences > Corrections > Substitutions: uncheck Replace Double hyphens with em-dashes.