Scrivener and fonts -- what a mess

This is a list of gripes re fonts that I have started since beginning to use Scrivener:

Font presets: no indication in the drop down list of the current font preset used at the cursor location.

Pasting fonts: imo Scrivener should default to matching the current font style, or at least remove all font formatting. So often pasting from the internet or elsewhere brings a whole lot of font rubbish with it. At least provide some clean simple obvious way of removing ALL formatting and pasting as plain text, which could / should then default to the default font type for the project or document.

Changing font styles: unlike Apple Pages where it is really easy to set font styling to the current highlighted piece of text, Scrivener requires many mouse clicks and is just generally confusing.

Silly styles operation: I copied some text from another doc then wondered why I could not bold some of it. Found that it had imported the font setting from the doc and using the styles drop-down would not update the style. I clicked “Body” and it DID change the font to Body size, but the font remained unchanged as Arial Unicode MS.

Non-font issue – Silly cursor placement: Create a new text doc, enter the doc name in the LHS panel and press enter… where is the cursor? Where should it be? Why can I not just start typing into my doc?

Styles failure: Setting Project-> Text Preferences to override does no such thing. I can set a style in this menu, then apply a style from the editor’s dropdown and the style is different ?!

Text styles fail: Set blockquote to a font size in Project → Text Preferences, Override ticked, click OK to save, then apply the style from the editor using the drop-down, and Scrivener ignores the text setting !!!

PS. Why is this forum soooo slow and keeps failing to post my comment…?

Hello,

I’d hardly call it “a mess” - Scrivener uses the standard OS X text system and its treatment of fonts is exactly the same as other standard OS X programs, so you are essentially calling the way Apple has designed rich text to work on OS X “a mess”, and I disagree.

I don’t know what you mean here. The font pop-up does show the current font:

If that’s not working for you, then please provide more details.

This is not at all standard. Scrivener uses a rich text system, and as such, when you paste rich text into Scrivener, it should absolutely respect that. This is why Apple provides “Paste and Match Style”, which you will find in Scrivener’s Edit menu. If you prefer to use Paste and Match Style over regular Paste, then you can switch the keyboard shortcuts using the System Preferences keyboard and text preferences.

I don’t really know what you mean here.

Scrivener doesn’t have a styles system, and nowhere is it claimed that it does. It has formatting presets, that’s all.

Because this is how things work on OS X? I don’t know what you mean by the “LHS panel”, but I’m assuming you mean the binder. It would be incredibly infuriating if, after hitting enter to end editing a title, the focus moved to the editor. The focus remains in the binder, as it should do. Then you can use the arrow keys to move up and down the documents, hit Escape to rename another one, and so forth. If you want to navigate to the editor, hit Ctrl-tab.

Please read the documentation - it seems you have misunderstood Text Preferences. Text Preferences allow you to set different default text formatting for the current project. Normally, you set this via the Formatting tab of the main Preferences - which font and line spacing you would like new documents to use by default. But this affects all projects. Text Preferences allow you to override this for the current project and have the current project use a different default font. After changing these settings, any new documents you create in that project will use the default formatting you have set up. Obviously it doesn’t affect existing documents, as in a rich text environment that would be assuming way too much and could destroy much deliberate formatting. You can use Documents > Convert > Formatting to Default Style to convert the formatting of existing documents though.

This is not how things work at all. The presets are available in Text Preferences so that you can set up the default formatting of the project to use preset formatting if you want - it’s not where you edit the presets, and I’m not sure why would get that impression. Editing a preset works similar to how you edit styles in Pages - just select some existing text that uses the formatting you want and go to Format > Formatting > Redefine Preset From Selection.

Finally, could we please respect the forum rules, which come down to one thing: be polite. :slight_smile: Using terms such as “what a mess” and “fail” isn’t really the most constructive way of providing feedback. It may well be that Scrivener isn’t for you, which is absolutely fine - we don’t claim that it will be the perfect tool for everyone. But we work hard on it and are passionate about it, and would appreciate it if we could all show each other a little mutual respect in these forums, which is our work environment.

Thanks for trying Scrivener anyway.

Regards,
Keith

Thanks for the reply Keith. I have used many text editors and writing tools over the years, and quite honestly Scrivener is the most confusing that I have ever used. Anyway, more below…

Well, if you have used Apple’s Pages, you will find that it hardly works like Scrivener in terms of fonts and presets. e.g. if you apply a style to some text, the text actually changes to that style. Scrivener does not in my experience. Perhaps I am missing something pretty obvious here, but let’s try to figure that out :slight_smile:

Sorry, what I meant was that there is no indication in the dropdown list as to which style is applied to the position where the cursor is. e.g. if the cursor is over text that is “Body” then it gives no indication that that is the case.

But following on, when I do apply a preset to some text, the text does not change to the preset settings. I have set these in the Project → Text Preferences settings and ticked the override tick box. Yet the text setting that I apply the preset to does not change to the preset values specified. Apple Pages by contrast is simply superb in this regard.

Does that help to clarify?

Many thanks,

KWR

Hi again Keith.

Well, how do you define a preset in Scrivener?

  1. Click Project.
  2. Click Text Preferences
  3. Click twice to select the preset
  4. Click the font selector button
  5. Click the font setting
  6. Close the font settings
  7. Click other things to define bold etc…
  8. Click OK
    (Compare to Apple Pages… 2 clicks to redefine the style from the current selection. Perhaps Scrivener can do the same in 4 clicks, but it doesn’t work – see below.)

Note now that unlike Pages, the updated style is not applied to the document, so appears to do nothing.

Now I apply the style to an existing paragraph, and it moves the text to the left, but the underlining (as I set in my test just now) is nowhere to be seen. e.g. the style does not appear to have been applied to the paragraph. This is totally unlike Apple Pages, and so obvious that I am wondering what on earth I could be doing that is wrong?!

:slight_smile:

My suggestion. Add “Update style from selection” to the preset menu drop down (like Pages) and perhaps remove all the confusing stuff from the Project menu.

Hope that helps.

Regards,

KWR

I think you’ve misunderstood how the preset system works.

To define your own preset:

  1. Highlight a selection of text in the editor

  2. Format it using the standard formatting tools (bold, italics, line spacing, font etc) until it looks the way you want it.

  3. While it’s still highlighted Format > Formatting > New Preset from Selection.

  4. Give your new Preset a name and select the relevant options, then press OK

Your new preset will now appear in the Format > Formatting > Apply Preset list.

That’s it. Simple and an improvement on the default Apple text system. (Apple does not allow other developers to use the Pages text engine at all, which is why Scrivener can’t just copy it wholesale.)

I suspect you’re getting confusing this with the ability to set default text styles for whole documents, which you do in either the Preferences Formatting tab, or in Project > Text Preferences. Both those are meant to be used for new documents, or to be applied retrospectively using the Documents > Convert > Formatting to Default Text Style command. They are not used to change the format of individual words or paragraphs.

Once you’ve defined your preset, though, it will appear in the list in both places.

Sure, I understand that I can make my own presets. But it seems that I can also use the built in presets.

My question is, are these presets re-definable? It would seem the answer is yes, and that they can be globally applied. Using the “Project → Text Preferences…” menu…

TICKBOX “Overwrite text formatting for this preset”

But this simply does not work. Well, perhaps if you start a new document it may work… but it fail on an existing document.

Mmmm, I probably am confused, but I cannot see why it works like this, either by logic or by the menu? Surely if I tell the body style to be 12 pt then I should be able to apply the newly set 12 pt italic to an existing paragraph.

I think the confusion here is that Scrivener presets are NOT styles.

No, really, they aren’t.

Styles in Pages, Word, Quark, Indesign, etc. are a group of settings that are applied to a run of text dynamically–the next time you scroll through the text the group name is looked up and all the settings are applied anew. In Scrivener and other software that uses Apple basic (cough) text services, presets are Stamps–you select the text, stamp it, and there is no memory of where that stamp came from. If you change the preset it will Not automatically update all the text you stamped before.

Dave

The Project > Text Preferences dialogue is used to set the default paragraph or character style for new documents.

If you make a change in the Text Preferences dialog, that change will be reflected as the default style for new documents. I.e. change the font to Comic Sans 36pt and when you create a new document and start typing it will be in Comic Sans 36 pt. Or if you use the Preset button in Text Preferences and select “Block Quote” then the new document will have a default paragraph style of “Block Quote”.

This will not affect existing documents, by design. In fact the dialog tells us this (“Main Text Style for New Documents” under the Override tick box).

If you do want to apply the new default to existing documents then select them in the Binder and Documents > Convert > Formatting to Default Text Style… They will now all be in Comic Sans 36pt or Block Quote (although you’ll be given some control over what is actually changed).

Note: using the Project > Text Preferences dialog gives you no control over individual words, sentences, paragraphs: it is an ‘all or nothing’ option applying to entire documents.

If you want to apply a format to an individual word, sentence, paragraph, simply use Format > Formatting > Apply Preset in the Editor.

This is actually a logical process, once you understand that Project > Text Preferences is meant to set the default formatting for new documents and doesn’t apply to individual selections of text. You probably won’t need it very often at all. Set it once at the beginning of a project and forget it.

Hope this helps

David

I’m pulling my hair out over setting default fonts. The preferences for either Project or Scrivener Preferences don’t seem to stick. I go to…

Project>Text Preferences:

I click in the text area and click the paragraph icon, then choose Title (as an example). I then click the font button which brings up the standard Apple font chooser window. I select Verdana Bold 14. The sample text in the text box changes. I close the font chooser window and the formatting window, and I’m back to the editor. I then repeat the process, choosing Title - it’s back to the original font size (28) but does remember Verdana bold. I’ve set the Heading, Sub-heading, and Title to bold, but want Body to be regular (not bold). Each time I try to change Body, the “default” is now Bold. If I choose Regular, later it’s back a bold.

I’ve also done the same thing in Scrivener Preferences, in the Formatting tab, and the same thing happens. I’m not trying to apply the default fonts to a current document, I don’t even go there. It’s just that the Formatting Preferences never stick - they always go back to the previous font size.

So now I try another font for Title: Times New Roman, bold, 14. If I then go to Heading, the currently displayed font is Times New Roman, bold, 18. I change it to 13 and the sample text changes to my choice. (At this point I then go back to Title, and the default is Times New Roman, bold, 28. I can change it to size 14, but later it’s back to 28. If I change the font to Helvetica bold 14. If I then look at the other paragraph settings, and they’ve all changed to Helvetica, but they are back to the original sizes.

Am I truly limited to the original font sizes, Title=28, Heading=18, Sub-heading=12, etc.??? And must each of these be from the same family (Time Roman or Helvetica, or…)?

I need some help - I’m surely doing something wrong!!

Thanks.

It sounds like you’re still trying to set individual styles from within the Preferences dialogues. As we’ve tried to explain, you can’t do this. That’s not what those documents are for - they’re for setting a default paragraph style for a document as a whole, and each document can only have one default style. Every time you’ve gone back into the Text Preferences dialogue, all you’re doing is rewriting that single default for the whole document, not for individual styles.

When you create a new document, the first words you type will be in the new default format. If you convert an existing document the ENTIRE document will change to the default format, including overwriting any previous preset styles you’d used (although you can protect certain formatting according to your needs).

If you want to change the preset styles you must use the procedure I gave you before, using the Format > Formatting > presets menus. (But remember that this will not retrospectively change any previous text that you have formatted.)

The way I would approach it is this:

a) Decide what your basic body text format will look like, then redefine the body text preset to match it.

b) Go in Project Text Preferences with override formatting checked. Click in the text box, click on the preset button, choose body text. The dummy text will change to reflect the preset. Press OK.

Every new document will now have body text as the default format. Once you’re happy with it, you probably won’t need to touch the Text Preferences dialogue again.

Every other bit of formatting you will do (titles, block quotes etc, you will do using the Format > Formatting > Apply Presets menu.

You can convert any existing document you want to, but be aware that this will potentially change every single part of the document into body text, so you have to be careful which of the conversion options you choose otherwise you will override any special formatting (such as sentences or paragraphs that were set using other presets).

My advice would be: follow the instructions above to make sure that you’re happy with the concept of setting the Text Preferences for the default body text you want for new documents.

Then try converting a single existing test document to see how that process works.

HTH.