Scrivener and Mellel/Nisus

I’ve just downloaded and am trying the 1.0 release version. I have no doubt that I’ll be paying for this in the next day or so. I’ve been using Scrivener for a few weeks on a new book project and it is proving to be perfect for what I need.

At some point, I know I’ll be wanting to export my manuscript to either Mellel or Nisus Writer (Express for now, maybe Pro by that point). I’ve been experimenting with RTF export to both, and I’m having some issues.

When I export RTF to Nisus, it simply refuses to open the file. I don’t know if this is Scrivener, something about my file, or a problem with Nisus’ RTF implementation. Does anyone else have this problem?

With Mellel, the file opens just fine. One thing I notice, though, is that if I select to include footnotes as endnotes, they still appear as footnotes in Mellel. Again, is this a problem with Scriv or Mellel?

There is an entry in the FAQ on the various pecularities that exist between word processor’s RTF import features on the Mac. It is called, “What is the best way to export to a certain word processor?”

What version of Mellel are you using, by the way? When I last checked, it discarded end notes entirely. I do not have any data on Nissus, if you come across any way of getting RTF files into it, I would love it if you could drop me some details on its limitations. The RTF that you are trying to import, does it have any advanced features in it, like tables or images? If so, have you tried importing a simple RTF?

The latter problem - whereby endnotes open as footnotes in Mellel - is a Mellel problem, which is noted in the Scrivener docs (look under Exporting) and in the FAQ.

The former - whereby docs don’t open in Nisus - may be related to an export bug I thought I had fixed a long time ago. Try closing Scrivener, re-opening it and re-exporting. Does that fix it? (If so, it is almost certainly a Scrivener bug.) If you have a project that always has the export problem with Nisus, could you please send it to me at support@literatureandlatte.com? I will certainly take a look at it. (If you don’t want me to see the text, use Project Replace to garble your text and then just make sure the Nisus problem still exists.)

Oh, and thank you for your kind comments about Scrivener!

Thanks and best regards,
Keith

Thanks for the quick replies, all. Keith, I’ll try playing with the Nisus problem and it it doesn’t go away, I’ll be happy to forward the file to you. Running to a birthday dinner out right now, so it’ll be later tonight.

My payment will arrive soon. Wonderful tool!

I tried quitting/relaunching Scriv, opening that project, exporting to RTF, and opening it in NisusWriter Express again. Still no go. Keith, I emailed it to you.

The question about Mellel version: it’s the latest, 2.12.

Thanks. I have downloaded the latest version of Mellel, and indeed it does now convert endnotes to footnotes. I will update the FAQ accordingly.

Hi there. For what it’s worth, I quickly tested Scrivener (v1.0) and was able to pull the export RTF draft into Nisus Writer Express (v2.7).

I exported the draft. I’m not sure if this had anything to do with my success, but the only deviations I made from the default settings were…

  • Turned off converting italics to underline
  • Turned off converting em-dashes to hyphens
  • Turned off “override text formatting”
  • My default font in the document is Times New Roman

I exported the document to my desktop and then dragged and dropped that document into Nisus Writer Express. No problems. It was just a short document with some formatting (indents, italics, font changes, etc.) but nothing elaborate. Everything looked fine in Nisus.

I’ve just started working on several projects in Scrivener, and I expect to pull most of them into Nisus Writer Express for final formatting touch-ups. I’ll post another note here if I run into any .rtf import problems. But like I said, so far no problems.

Thanks for the extra info - it seems to be quite rare and random, this problem, so it is good to know that this is still working for some. Still on my list to look into and fix, though, of course.
Best,
Keith

UPDATE: Martin of Nisus very generously e-mailed me to help me with this. He looked at the RTF file that swilcox sent me, and it turns out that there is a bug in Nisus that causes this. However, by tweaking the RTF syntax Scrivener uses, Martin also showed me how to work around the Nisus bug (still using valid RTF syntax, obviously), and I have done this for 1.01. So, Scrivener will work beautifully with Nisus as of 1.01, or before that if Nisus is updated first. FYI, the bug is in the footnote syntax. If you’re not exporting RTF footnotes, this won’t be a problem.
All the best,
Keith

Thanks for this Keith! Any idea when 1.01 will be out?

Sherman

There are a good few things left to do for 1.01. A couple of weeks at least, I would say - updates won’t be frequent, especially in this early busy period.
All the best,
Keith

Those among us who plan to export their Scrivener Projects to Nisus should know that by admission of its own developers Nisus has stability problems with documents with many footnotes: see nisus.com/forum/viewtopic.php?t=2013