Scrivener and NAS

Hi everybody,

first, I want to apologize for my English, I am not a native speaker and have difficulties talking about technical stuff even in my own language, so I hope I can make myself clear (and understand your answers, should there be any …).

Here we go. When I start Scrivener, it tries to connect to our Network Attached Storage (diskstation). It doesn’t allow any action until the connection is established. Which means: When I’m out of reach of that storage (or offline!), I cannot work with the programme!

I checked the folder for backups: It’s on the mac. So that can’t be it. (Right?)
I emptied the list of authorized directories, so there’s no need to “contact” the NAS, either.
After compiling my project into a word-document, I saved it on the mac AND on the NAS, so I had the idea that maybe Scrivener tries to remember the last folder a compiled document was stored - but saving the project on the mac AFTER saving it on the NAS didn’t make any difference.

That’s all I could think of so far.

Any ideas? I’d really love to be mobile again …

Thanks in advance,

Ruth

Is Scrivener installed on your Mac, or has it been installed on the NAS?

There are two places where you can specify a directory for Scrivener to use: Scratch Pad (in the General preference pane) and Backups, which it sounds like you’ve already checked. Scratch Pad may very well be checked when you start Scrivener (this tool allows two-way use, so you can work on your scratch pad files on the go, the software will check this location repeatedly for updates). Backups shouldn’t cause a delay even if they are remotely located, unless you have set your backup settings to create a new backup when a project is opened. However, I doubt it is backups because we put a fail-safe in there a while ago for just this kind of problem, where the backup folder is on an external or networked disk that is no longer available. When that happens you should just get a warning—but maybe something with OS X is just halting everything until it finds the NAS.

You are correct that Scrivener will attempt to remember the last location you used for a variety of things, such as compile, export, project open and save operations, among others. But, this should not have an impact on start-up, as the Mac will only request status information from mounted drives when the file window is opened. When slow disks, such as CDs and networked drives are mounted, this can cause delays when using the file chooser.

Okay, this is what I was afraid would happen … I don’t really get everything you said.

The question I can definitely answer is: Scrivener is installed on the Mac, not on the NAS.

I have never used the Scratch Pad - could it be that Scrivener checks it anyway? I found it in the Settings and under ‘location’ there was no directory specified. I did that now, making sure it doesn’t involve the NAS - but on disconnecting it for a trial, nothing changed.

If OS X is the problem - is there a way to find out? And if so, how? I work on a Macbook Air 2012, mountain lion, and no other programme shows this kind of delay or - more correctly - insists on being connected to the NAS to work at all.

This is what I just tried: Disconnecting the NAS by turning off the WLAN while Scrivener was NOT open. Clicking it in the dock didn’t cause any reaction. It refused to appear. Reconnecting the WLAN, it opened at once.

Don’t worry about getting everything right now. There are folks with all levels of skill on the forums. We will keep working with you until things are explained.

Did you have your project on the NAS?
Was the last project you worked on stored on the NAS?

I don’t know if OS X is having a problem, other than the general expected delays that will sometimes happen when it tries to spin up a drive it hasn’t used in a while. This can happen in any program, and is more noticeable if you have something like a CD-ROM in the drive, or an external drive that has gone into power-save mode (you’ll hear it spin up and have to wait until it is on again before you can use the file window). There isn’t really anything you can do to fix that, it is just how the Mac works.

I will say this doesn’t sound quite like that, what you describe. Like I said, that sort of delay usually only happens when you use a file window, like Open Project…

If Scratch Pad was empty, then that is not the problem. That just means it was never set to begin with.

What I would try is resetting your preferences. That’s the one place where it may have some references to the NAS.

  1. Go to the main preferences panel in Scrivener and use the Manage… drop-down menu to Save All Preferences…, which will create a file on your computer that can be set aside as a backup of all your settings (this may not be important if you have not customised Scrivener heavily; you may just skip this step).
  2. Use the main Scrivener menu, and select Reveal Support Folder in Finder. Close Scrivener now.
  3. Switch back to Finder and go to this new window that step two opened. Press Cmd-UpArrow twice. You should now be in the “Library” folder, as titled at the top of the window.
  4. Double-click on the “Preferences” folder.
  5. In the Finder search bar, type in ‘scrivener2’ and make sure the search bar is set to search in “Preferences” for File Name.
  6. You should get one or two files. Drag these files to the Trash in the Dock.
  7. Now detach the NAS so that we can test conditions without it.
  8. Launch Scrivener.
  9. Use the Manage… drop-down to load your preferences from the desktop backup file if you saved them in the first step.

Let me know if you need any of those steps clarified.

Okay, here is what happened: I went through all the steps you mentioned (except saving my preferences, since I never customised Scrivener anyway and didn’t want to bother too much with finding the preferences panel in my translated German version …). So, when I launched Scrivener I was asked to specify a directory for backups. On trying to do so, it seemed that again something refused to work without the NAS, although I selected a mac-internal directory, of course. But it wouldn’t show me the sub-directories from which I could chose my already existing backup-folder plus it showed it was “work in progress”, no idea how to put that in English, sorry.

So, that went on for a few minutes. I turned on the WLAN (and the NAS, for that matter), and now my sub-directories on the Mac were shown. I chose the backup-folder, closed Scrivener, disconnected the NAS again and launched Scrivener once more. Now it showed me the general preset selection for new projects. But I couldn’t open my old ones. (And suppose I couldn’t have started a new one, had I tried.)

This is getting strange, isn’t it?

Ioa, sounds like OS is mirroring /Users to NAS. I’m wondering if there is an auto mount entry that is somehow triggered by scriv that is not seen in non-package format apps. That would seem to indicate a fairly sophisticated admin… It’s the only logical explanation that I can conceive.

then again I’ve been swearing at auto mount on linux all day so I may be overly sensitive right now…

Hi everybody,

it seems that I’ve found the solution. When you put me through the steps of deleting my preferences, I realized there were two projects with the same title in my list of recent projects. I checked where they were stored and found the one I was obviously using all the time (considering the date) on the NAS. I made a copy on the Mac and deleted the file on the NAS. Then a moment of panic, because now I had none of the two formerly identically titled projects in my list on Scrivener (plus it still refused to launch without the NAS).

But I somehow “forced” Scrivener to open the project I had just copied via the Finder (although I was told it was already open) and there it was. NAS disconnected and all.

The document in question was not a backup, but THE thing: titleofmyproject.scriv. I have no idea how it got on the NAS, surely my own fault. (If you have an idea what might have happened, please let me know, so I can avoid it in the future.)

Thank you all very much for giving me your time and your great thoughts! And sorry for bothering you.

Ruth

Possibilities based on every Monday I’ve ever had.

A. You likely saved or copied the file to the NAS as a backup without thinking about it (I do it all the time). Then you did a spot light or finder search for the file and the NAS entry was first in the list.

B. In a dialog box you clicked on the NAS in the far left nav pane instead of on your local drive. This is very easy if your NAS has a name close to your Mac (mbp13 and mbp17 in my case).

C. A dialog box opened to the “last location” that you saved a file too. I see this often. Without realizing it you happened to be on the NAS not local.

I’m glad it worked out.

I take A. :slight_smile:

Thanks for the analysis, dear Jaysen. I’m glad it worked out, too.

Reminds me - once more - of the fact that working systems are something we should be grateful for.

My pleasure.

As a person who seems to deal exclusively with broken systems, I know just how frustrating it is when things suddenly stop working as expected. Never hesitate to ask questions around here. Someone is likely to have had an experience that will help.