Scrivener balky on Windows 10 SP3...why?

I love the Scrivener software and just started my 30 day trial. I a using it on a Windows 10 Surface Pro 3 and purchased the iOS version for my iPad. The synching works great. The iOS version works very well. However, before I pull the trigger on the Windows purchase, I want to know if there is something I can do to make the Windows version less balky at times. My SP3 has the largest amount of RAM and hard drive capacities and processor available in that model. It has the capacity to handle the most complex and large software programs.

I find that after working in Scrivener for relatively brief periods of times, sometimes it becomes very slow to respond to commands. I try to cut some text…and there is no response for a while…and then when I can perform the action I want, it is tediously slow to respond. Also, when it enters this balky state, when clicking on menu options, the option menu only shows up as a faint outline with NONE of the options listed…if I wait a while, or click on that space a few times, eventually the menu with the text will display. It is very frustrating. I have found the exiting Scrivener and starting it again will “sometimes” fix the problem, but it always comes back. The best option, which is a hassle, is to restart my computer, and then it works fine. But eventually it starts to slow down and balk.

What is up? Anything that can be done. I a not sure I can survive with this and it is critical to my purchase decision :frowning:

I don’t think it is Scrivener. My guess is that your laptop is running an antivirus program or indexing or something else that is sucking up your CPU. I haven’t used Scrivener long, but have no problem or lags on a normal business Windows 10 machine. There is no reason to believe your laptop is weak. So, with those variables discarded, we should look elsewhere.

I"m assuming you are storing you data locally, not writing to the cloud.

You can run task manager or resource monitor in the background and watch what is using your CPU (or possibly storage) when the slowdowns occur. You can also check ram and see if it is getting anywhere near full or even over 80% which it should not be.

I don’t have that issue on my SP3.

Using the i7, 8 GB Memory / 512 GB Storage / Win 10 Pro; Scrivener runs without problems.

Thanks for the responses. These were my hunches also. I will do some resource checking next time it happens. It did not do so this afternoon, which is consistent with your suggestions…whatever may be running in the background was not doing so this afternoon. Thanks…this gives me more confidence in purchasing the program

The couple of times I’ve had this problem with Scrivener on my SP3 with Windows 10, I notice (if I looked carefully) I was seeing all sorts of random little issues in other programs as well.

The culprit I found is that Windows had applied some updates but I was preventing it from rebooting to finish installing them.

By keeping a closer eye on updates and giving Windows Update a chance to do its job, I’ve removed any performance issues in Scrivener.

This seems to depend upon the project.

Project i have been working this week uses 1.2 Gigabytes of memory.

On disk the project is 2 megabytes and 325.

It is a bit balky with respect to change the display when changing files/folders.

Total CPU use is around 10%, memory is at 44%.

I close that project and open one that is 500 K on disk with 45 files and it is using only 54 megabytes of memory.

What is it about the large project that requires so much ram? How can i change it?

w 10, all updates, 4-core processor, 8 gigabytes ram

Adding this here to collect this problem in one place (assuming they’re related).

I get a terrible cursor lag with Scrivener and Windows 10 Home. It seems to be getting worse.

The lag starts up after I’ve had Scrivener open for an hour or so. When I move the mouse the cursor stutters and stops. But that’s the only lag–the typing speed in Scrivener is fine. When I close Scrivener the lag goes away (but if I re-open Scrivener it starts right back up, so simply closing and re-starting Scrivener gives no relief. A re-start of the PC helps). It used to happen every once in a while but now it’s happening daily. The lag is so bad that it’s difficult to get the cursor to any specific location (e.g., click on a menu item). Since it’s getting worse I assume it’s because of some recent Windows update. My version of Windows 10 Home is up to date.

I auto-save locally every 10 seconds of inactivity then auto-backup to Google when I close Scrivener.


One thing I know, is that it is not Just windows 10 home and an update, as it does not happen to me. Also, since it gets better after a reboot, something else is happening. I would turn off auto save. Load no other programs. Disable your antivirus. and see if the problem occurs. I would suggest safe mode, but I’m not sure scrivener will run in safe mode. The problem is likely some interaction. It could even be a failing drive and your auto save.

If the problem still happens, lots of things have been eliminated, but we aren’t much closer. Then I’d try a new scrivener project and see what you have to add to the project to get the problem.

If the problem does not occur with other programs disabled, slowly re-enable them, starting with your anti-virus. See if you can determine what interaction causes the issue.

In general, good advice – except for disabling auto-save. Because of how Scrivener is laid out on disk, auto-save isn’t touching the whole thing front-to-back – only those documents that have been updated.

However do check your backup settings – if you have it set to do a full compressed backup after every save, then you could be getting lag from that.

I left the project open that was annoying me. When i returned many hours later it was using only 120MB, instead of 1.3G.

Today, I have had the project open for about 4 hours it is now at 226MB.

Closing it, the new project dialog is displayed and the mem use is at 67.

I close that dialog, wait a minute, open the project and it is at 189.

Might have something to do with retention of undo history. This used to be a big issue for Excel files when used for long periods and many changes.

Devin L. Ganger wrote

Apparently we agree 99% of the time, but disagree here. I’ve seen people saving stuff to network drives who weren’t aware of it and thought they were saving locally. Also, the drive could be failing, so stopping drive action is a good debugging tool if possible. Especially if you do not have control over the drive action. So, the AUTOMATIC saving isn’t like importing a file where you know what is happening. I do accept however that it would probably be smarter to re-enable auto-save even before re-enabling anti-virus, and that it is unlikely to be the problem, so it is probably a useless action.

Thanks for the heads up on the zipping backups. I’m new to Scrivener and hadn’t even looked at the internal backups.

Thanks for the replies.

My backup is zipped and saved to my local Google drive when I close Scrivener. Then Google syncs it to the cloud after the fact.

I haven’t looked at my CPU and memory usage during the lag like FredBob. I’ll have to give that a try.

Had Scrivener open all day as a test. Not one moment of lag. Here’s what I did thanks to all y’all’s suggestions:

  • Opened task manager to keep an eye on CPU and Memory. Scrivener never got above .2% CPU usage and stayed right around 75MB memory the entire day.
  • Scrolled through my opened applications to see what was running in the background. Found three programs that didn’t need to be running: Adobe Cloud (for my Photoshop and Lightroom), Akamai Netsession Client (used by a lot of companies to handle their download/upload stuff), and M-Audio (for making recordings).
  • Closed them all down (and turned them off in Startup).

I’ll turn Adobe Cloud back on (it’s the only one of the three I need to use) and see if the lag returns. Of course, today could have been a fluke so fingers crossed it’s actually fixed.


Gary wrote

If you can, it is always a good idea to try and turn off “startup with windows” in each program itself - If there is such an option.
Sometimes you don’t have the option, but if you do better not to start it than to start it and then shut it down.