Scrivener behaviour on wake up

This is an issue that that started a couple of weeks ago. If I am away from my computer and it goes to sleep, Scrivener becomes unresponsive on wake up. I can put my mouse pointer anywhere and click but the cursor does not follow; instead, random areas of text become selected. The only fix I have is to close and restart. I am resigned to it but was curious to see if it was a known glitch and why it has only started happening now.

I’d recommend closing Scrivener when you leave the computer, even without this issue.

Chances are the issue is with a Windows setting (especially since you say this only started a few weeks ago, and that there wasn’t any Scrivener update in quite a while). Something that is not truly “waking up”.
I use to have problems on a previous computer where whenever it would come out of sleep, I’d have no mouse control anymore. I don’t remember how I fixed it tho.

You can try disabling this:


It is responsible for many “on wake” issues.
Start / Settings / System / Power & Sleep / Additional power settings / Choose what the power buttons do.

The thing about “sleep” mode is that it freezes everything that the computer might be doing: automatic save and backup operations don’t run, cloud uploads/downloads don’t happen, general cleanup operations don’t happen.

If you’re going to be away from the computer for an extended period, shut it down. (Or at least shut Scrivener down. What you do with other applications is between you and their developers.)

1 Like

Thanks for taking the time to reply. It might be that now I should start shutting it down if I am going to be away from my desk for more than 10 minutes, or alternatively, I could just restart it when I come back. I run multiple applications simultaneously and to my knowledge it is only Scrivener that is affected. I have been running Scrivener since 2014 give or take a year and didn’t have this issue before so maybe it is a Windows update issue. Thanks again.

Thank you for taking the time to reply and add the screen shot. I had combo boxes 1,2 and 4 selected so I could try disabling #1. I run multiple screens so I have them set to go into hibernation after 10 minutes to protect them. PC hibernates in 30 minutes so perhaps that is something to rethink. Thanks again.

You say the problem occurs after 10 minutes?
Could perhaps be an issue with your video card then. (?) [Or more precisely, something related that would for some reason dislike Scrivener.]

Perhaps see if the driver could be refreshed…

@kewms Thank you for the reply. As I say this is an emergent issue so it might be down to a Windows update. Slight inconvenience aside, I dare say that for a developer it might be worth knowing, so please consider yourself alerted. I agree with your summation of what sleep mode does but implicit in the name is that it should wake up. It is not an unreasonable expectation that it does that.

As for your final point:

“If you’re going to be away from the computer for an extended period, shut it down. (Or at least shut Scrivener down. What you do with other applications is between you and their developers.)”

I’ll assume the tone was accidental but what I do with any application on my PC is exclusively my business. How developers ensure their products remain fit for purpose is theirs.

I don’t think so @Vincent_Vincent as I have no such issues with graphic heavy packages. If it was hardware, I dare say it would affect other applications. I think it is most likely a Windows update issue but I wanted to see if anyone else was experiencing this before rolling anything back. Thanks for your reply. I do appreciate it.

I found this here : “The processor manufacturer Intel mentions that if the computer is left sleeping for too long, the RAM memory is not restored correctly.” The page is not dated so I don’t know if it is relevant, but your problem could be related.

Also, some people reported having wake issues when using a machine running an Intel graphics driver, and most of those issues were solved by updating the driver.

@BClarke Thank you. I will check that out and let you know.

What I should add, in case anyone else has this issue in the future, is that I don’t have to leave the screen off for a long time. I did an experiment where I waited for the screen to power down and then immediately woke it up with the mouse; it still happened. On the plus side it has caused me to do some driver maintenance.

@BClarke I promised to get back to you and forgot. Sorry. I did update the graphics driver as you suggested and tweaked some settings to do with sleep behaviour. The problem is still there but only very occasionally, which is far better than what I had resigned myself to live with. Thanks for your help.