Scrivener big problems-- hangs on external folder sync for 1st time + forever indexing

I’ve tried eleventy times to create a new external sync folder and it always stops at file 6. then I ask it to continue and then it gives me this:
Exception Name: NSRangeException

Exception Reason: *** -[__NSCFString rangeOfString:options:range:locale:]: Range {9223372036854775807, 9223372036854783408} out of bounds; string length 7599

i have to force quit because it doesn’t give me the option to cancel-- then, when I reopen, it’s like a whole thing of rebuilding the database and it takes forever. Repeat.

also, I swear to scrivener that I HAD previously compiled manucript and it had maintained comments and annotations in word, but now they are gone. any way to get this in a word doc?

This is a bug we have recently discovered that seems to involve the use of some kinds of styles in the editor. We have plenty of test material to work with, so it should hopefully be an easy fix.

In the meanwhile, the workaround is to use TXT for syncing rather than RTF. That seems to work for most people.

The reindexing happens because whenever the project doesn’t close neatly, Scrivener cannot assume that everything is okay internally with the project, so it rebuilds the search index. This can indeed take a long time if the project is huge. There is no good way around that though, other than avoiding the hang that causes it.

As to the final question, make sure that when you compile you have the two checkboxes set to allow annotations and comments to export, in the general options tab on the right (gear icon).

Yeah a friend suspected that this was the case… but if you do txt. doesn’t that mean annotations etc don’t carry over?

Per the compile-- I don’t see that option: I see an option to remove them but not include them… when it compiles it makes all of the annotations and comments as comments, which I don’t want. Thanks!
Tricia

Inline annotations (and inline footnotes) can be optionally converted to plain-text and back again. You’ll find the option for that in the Sharing: Sync preference pane: Convert text inside (( )) and {{ }} to inline notes when syncing plain text.

The other alternative is to strip styles temporarily, which depending upon your circumstances may be less hassle than the above.

As for the compile option—not removing something is to leave it in. Could you rephrase what it is you are looking to achieve with them? Earlier you asked about them being gone and wanting them back, but now it sounds like they compile into the file and you don’t want them.

per the plain text-- if I do not click that does that mean they don’t appear at all?

as for compile, to clarify–I wish for the inline annotations (Which are questions for a reader /myself) and the comments (which are reference and source material notes) to appear in word as they appear in scrivener. but when I do the compile, it seems that everything is converts to a comment which shows on the sidebar. does that make sense?

Yes, it does. You’ll need to edit your compile format itself to change this. If you already know how to edit compile formats, please forgive the step-by-step instructions below. :wink:

  1. Double-click on the compile format name in the left sidebar of the Compile dialog. If it’s a built-in format, you’ll get an alert asking if you want to duplicate the format. Go ahead and click the “Duplicate and Edit” button in the alert.
  2. In the Compile Format Editor that appears, select “Footnotes and Comments” in its left sidebar.
  3. From the “Export comments and annotations as” dropdown menu, select “Inline comments”.
  4. Save your new or edited compile format, & select that for compile.

Note that all comments & annotations will be exported the same way—either inline or sidebar, not mixed.

No, it means when you sync back to Scrivener, they won’t be comments any more, just plain text.

Another way to look at this whole issue—the distinction between comments and inline annotations is lost, both when you export to Word, and when you sync to plain text. (It may even be lost in RTF sync—I haven’t used RTF sync so I’m not sure.) You may need to rethink how you’re going to pose your questions, as using both inline annotations and sidebar comments won’t survive export.

Hope this helps!

oh ok that’s interesting about the margin comments. but I just did it using the default (duplicated that) and opened the word doc and there were zero comments/annotations!

Also–so it’s not possible I don’t think to have the comments be in margins and annotations be inline in compile?

Recheck your overall compile options.

That’s correct. All end up either one place or the other.

Yeah, the main issue here is that word processors do not have inline comments like Scrivener does. It is a bit unique in that, so when it exports it must use the only tool available for comments. This tool is what most word processors, and perhaps even all, will display as margin comments.

Yes, when you export as inline annotations, the comments & annotations will show up as bracketed text, maybe coloured if you’ve set up your compile options for coloured text.

Word used to do inline display of comments, I don’t remember when /if they changed it. I have an older version and need to update. Pages might do it but not sure.

So, once I would compile this with annotations and comments as inline text, then, if edited it in word and re-imported this back into scrivener, this would be the method that would be easiest to preserve comments/annotations, I presume?

If you change the setting to use inline text, it will essentially become text, just formatted to look different. So that wouldn’t be the best setting to use if you intend to round-trip out of Scrivener and back. The default setting will be best, and if there is a way to display the comments inline then that would be something you can do in the word processor, but I’m not familiar enough with that procedure to know whether it would come back in to Scrivener as comments (or inline annotations, depending on your import settings). Either way, they will all become one way or the other when you import. It’s definitely worth running a little test to make sure it all works as you want.

I can’t see where to set the text as a different color… Checked my overall compile settings

I did a round trip, it worked pretty well. some of the annotations got turned into comments on the way back but not all of them.