Scrivener can't create a template

Hello,

I’m desperatly trying to save a project template, but all I get is an error message saying:
The template could not be created because the project could not be compressed.
and adding:
The project data could not be compressed into a template file. Check that you have enough free disk space and the correct permissions.

I have enough free disk space (30 GB), and also checked and repaired permissions. Nothing changed.
Do you have any idea what I could try to solve this problem?

I’m using Scrivener 2.3.1 (purchased through the App Store, if that makes any difference), on a Mac OS X Lion (10.7.5).

Thank you!

Hi,

I’m afraid this is a bug in the App Store version, caused by sandboxing. I’ve fixed this for the next update, but in the meantime, you can use our direct-sale version, which doesn’t have this problem. To do so:

  1. Move Scrivener to the Trash.

  2. Download and install Scrivener from literatureandlatte.com/scriv … atform=mac

As long as you have run the Mac App Store version at least once, which you have, the version downloaded from our site will recognise you as a registered user and can be used without limitations.

I’ll be submitting version 2.4, which, as I say, fixes the issue, to the Mac App Store sometime next month.

My sincere apologies for the inconvenience.

All the best,
Keith

Thank you Keith!

It solved the problem - and also solved another issue I had, and that I suspect was related to this sandboxing bug as well (since it involves the “Containers” folder).

Just for the record, here is this other (solved) issue I had with the current App Store version:
When I saved my own script format (“Script settings” --> “Manage” --> “Save for use with other projects”), it wasn’t saved to:
~/Library/Application Support/Scrivener/ScriptFormats
like it is supposed to, but to:
~/Library/Containers/com.literatureandlatte.scrivener2/Data/Library/Application Support/Scrivener /ScriptFormats

With the Scrivener version from your website, the ScriptFormat folder appears in the regular Application Support folder, where it belongs.

Thanks for the great work. I love Scrivener. It must be a pain in the a** to manage a Mac version, an App Store version, a Windows version… and soon an iPad version! :smiley:

All the best,
Paul

No problem, and apologies once more for the inconvenience.

That’s a good point, actually - I need to update the text in the panels that tell you it is saved in the former location. Under sandboxing, Scrivener no longer has permission to save into ~/Library/Application Support. The way it works is that, when Scrivener wants to access this location, it asks OS X, “Hey, can you give me the path to the Application Support folder?” OS X returns a different path under sandboxing - an utterly bloomin’ ridiculous path, if you ask me. It seems ridiculous to have a path like ~/Library/Containers/com.literatureandlatte.scrivener2/Data/Library/Application Support/Scrivener, but that’s what the OS X sandboxing team deemed was appropriate for app data under sandboxing…

Anyway, it’s entirely up to you whether you stick to the version from our site or move back to the App Store version with the next update. If you want to go back to the MAS version, just trash Scrivener and empty the Trash, then go to the “Purchases” section in the App Store to redownload. If you stick with the version from our site, it will notify you of automatic updates and such - just remember that if you install it on another machine, you’ll need to run the App Store version once first in order to register it.

All the best,
Keith

Keith,
I am using Scrivener 2.3.1, (20116), and I thought I got it directly from your web site. I also have the issue with not being able to create templates. Should I go through with the delete Scrivener and installing the latest Beta version?

I love the software, but use it for much more utilitarian purposes, writing standard operating guidelines, training curricula, fire investigation reports, and other documents necessary to run a fire department.

Thanks for great software,
Jeff Webb

Hi Jeff,

Yes, please try downloading the beta, as our direct-download version really shouldn’t have this problem. Please let me know if you still have problems with the beta.

Thanks for the kind words!

All the best,
Keith

Keith,

I deleted the 2.3.1 version of Scrivener and downloaded the 2.3.5 (22136) beta version and installed it. The fire investigation template that I was trying to save worked like a champ. I was able to open it when starting a new project. Now it is time to create a Standard Operating Guideline template and training templates for instructing our firefighters.

Thanks for the help,

Jeff Webb

Glad that helped! Let us know if you run into the issue (or any other issues) again.
All the best,
Keith