Scrivener continually deactivates


Every few weeks or so scrivener seems to lose my license and I’m continually having to reactivate the program on my machine. Is anyone else having this issue? If so is there anything I can do to stop it from happening?


Hello Mitchell. Welcome to the forum!

There is a bug in the Paddle license-activation engine, which is affecting some of our users. Our Windows development team are trying to resolve with Paddle (our licensing provider). We are very sorry for the inconvenience.

The latest update to Scrivener 3 for Windows includes a workaround for this, which should help until a final resolution is released. I would recommend that you update your installation to version 3.1.1 if you have not already done so. You can verify which version of Scrivener you have installed by going to the Help menu and selecting “About Scrivener.”

If you are using Scrivener 1, you might consider upgrading to Scrivener 3. We offer discounts to those who have Scrivener 1. For some users, the upgrade may be free, depending on when Scrivener 1 was purchased. You can learn more about how to upgrade your license here.

If you’re on Scrivener 1 and are not interested in upgrading, then you might try restarting your PC in Safe Mode with Networking and activate Scrivener that way. This Microsoft support page explains that process.

If you continue to have issues, please consider opening a help ticket. If you need to go that route, please include a link to this post so that the tech-support person who gets your ticket can see what you’ve already tried.

I am having the same problem. A minute or two after I start a session, I get a message saying that there is no valid activation and then I am unceremoniously dumped out of the program. I restart in trial mode, activate using the same license key, and I’m good to go for that writing session.

I have version - if there’s a workaround in it for this apparently known problem (other than leaving the program open forever), I haven’t found it yet. What is this workaround?

First, make sure that your security software (both AV and Internet/firewall, if they are separate) has the Scrivener installation directory and binaries whitelisted, so that it allows the Paddle licensing library fire up a network connection and talk to the licensing server.

If that doesn’t work, then you will need to open up a help ticket per the link in the previous message from RuthS. There may be something wonky with your specific license entry, and support cannot address licensing issues via the forums in order to stay compliant with various privacy regulations.

Thanks for the reply.

My security software is not the problem as far as I can tell - no changes were made to it, everything had been working fine since I first installed it in May, and this problem just came out of the blue a few days ago. I am able to reactivate the license each time, so there’s nothing on my side I can see that would be blocking access to the Paddle server.

I’ve already opened a help ticket, but the support staff is out until Jan 3 so who knows how long it will take them to go through the tickets that have piled up in their absence. In going through the forum, I noticed that Mitchell mentioned a similar problem; Ruth acknowledged that this was a known problem they were working on and mentioned a workaround in the current version (which is what I am using) but didn’t specify what that was.

If I have to wait until my help ticket finally bubbles up to the top once they get back, I guess I’ll deal with it. It’s just very frustrating to have to enter the license number every time I want to start working on a project.

Make sure nothing has changed with your network settings — VPNs and the Windows network location functionality can all cause the Paddle network code to think you need to re-authorize. The only public workaround I know of is to ensure that you are on the very latest update, as they did make some changes in the code there. You may need to go to the manual download site and get it and manually install it instead of relying on the auto-update function depending on what version you currently have.

Thanks. I’ve checked all those things, and as far as I can tell, nothing has changed on my system. I’m digging deeper to see if there might be a firewall problem, but I don’t expect to find anything.

I do have the latest version installed, and as I said I am able to activate the product with my license code, so the Paddle server is reachable. The problem is that the program won’t stay activated from one session to the next, so unless the software uses one port for activation and another port for checking activation at startup, the problem isn’t on my side. The message from RuthS acknowledges that it’s a bug.

I was unaware that Scrivener requires an active internet connection in order to load properly - it’s not listed as a requirement, nor can I find such a requirement in the license agreement or in any of the FAQs. If I were to install a licensed copy on a laptop and tried to use that laptop somewhere that doesn’t have internet access, I would run into the same problem? If so, there needs to be an option to work offline.

Anyway, thanks for your help. Until tech support returns and can address the help ticket, I’ll muddle through.

1 Like