scrivener crashes directly after opening current workfile

Hi,

I have a big problem here and hope that anyone can help me.
I work with Scrivener 2.0.4 and it worked just fine till today. This morning it was absolutely impossbile for me to work with scrivener on my current file. I could open the file but immediately everything froze: I could not move the cursor and I had to shut down scrivener with a key sequence.

Then I tried to open scrivener first and get to the file in the second step but that did not work either.

I tried to export the file to work with another program on it since I heed to finish it but … well, that did not work, too.
I am sorry, maybe this is a common bug and I haven’t noticed another thread about it, if it may be so, please just lead me to where I can find answers. I am desperately lost here.

Kind regards,
Venera

Hi,

Could you please zip up the affected project and send it to support@literatureandlatte.com? That way we can take a look. In the meantime, try re-downloading and re-installing Scrivener from our main product page. Sorry you’re having problems, but hopefully we can get you back up and running shortly.

Thanks,
Keith

Hi Keith,

thank you for the answer. I just sent the file zipped to you.
This morning I did the reinstallation of scrivener but it has no effect.
An hour ago I managed to open scrivener again and I also could open the file but after a second it shut down (without the freezing part).
At least I managed with some copy and paste to get the data into another program so I can work on it. Otherwise I would have bitten the table in front of me.

I have big hopes now. Thanks in advance for your effort.
Kind regards,
Venera

Out of curiosity, do you have Scrivener set to reopen projects that were open on quit? (I think this is the default in the general preferences.) I had a problem with this when I had a corrupted/crashy project that caused Scrivener to continually hang when I tried to open the application because it kept trying to load that un-closed project. You could try moving the .scriv file to another location on your hard drive and then opening Scrivener to see if that’s the case–your project might be corrupted and need to get fixed, but at least then you’d be able to keep using Scrivener.

The project file you sent appears to be all in order, I could find nothing wrong with it, nor any settings turn on in it that are known to cause issues on some systems.

What happens if you create a new blank project from scratch? Do you get the same sort of crashy freezing behaviour? If not, what happens if you in that same blank project, use [b]File/Import/Scrivener Project...[/b] to select your .scriv file that is causing problems. You ought to get everything imported into folders, which you can move back into the correct sections.

If the above still causes crashes, I’d suggest resetting your preferences:

  1. Go to the main preferences panel in Scrivener and use the [b]Manage...[/b] drop-down menu to backup a copy of your preferences to the desktop
  2. Close Scrivener
  3. Navigate to your [b]~/Library/Preferences[/b] folder
  4. In the Finder search bar, type in ‘scrivener2’ and make sure the search bar is set to search in Preferences for File Name.
  5. You should get two files as listed below; drag and drop to move these two files to the desktop:
  • com.literatureandlatte.scrivener2.plist
  • com.literatureandlatte.scrivener2.LSSharedFileList.plist
  1. Launch Scrivener again
    Now try to repeat the problem using the same steps you took from before. If all looks well…
  2. Insert your name and registration details again
  3. Use the [b]Manage...[/b] drop-down to load your preferences from the desktop backup file

Hi,

@ MimeticMouton,
I don’t think I have this preference set. I am not quite sure, though. I had the problem described by you a few months ago but it went well after a bugfix. The problem I had yesterday was unfamiliar to me.

@ AmberV,
thank you very much for your answer. I don’t know why but today, as I tried to open Scrivener, everything worked again (without trouble so far but the morning is still young). Nevertheless I followed your instructions to save the settings and by doing so I noticed that, when I search for ‘scrivener2’ in the preferences-folder I only find this one: com.literatureandlatte.scrivener2.plist
Can the absence of the other file maybe affect scrivener? (Still I have no idea why I can open and work in my file today whereas yesterday everything was messed up.)

So far, thank you very much (all of you). If the problem occurs again I will definetely try everything (again). The idea to open a new file and import the older one is good but I am afraid it won’t work if Scrivener played dead again.

Kind regards,
Venera

Actually the second .plist file that Ioa mentions is only used on Snow Leopard - it won’t be there for users on Leopard or Tiger (this was an internal change Apple made with 10.6), so that is nothing to worry about.

I’m glad things are working again, but if it crashes again could you please copy the contents of the crash report and post it into a reply? (The crash report is the gobbledegook available in the “Quit Unexpectedly” window.)

Thanks!

All the best,
Keith

Hi Keith,

thanks for the clarification.

I will copy the crash report as soon as it shows up (again). Unfortunately, yesterday wasn’t anything to copy. Hopefully next time Scrivener gives me some information I can share with you.

Thanks again,
Venera