Scrivener Crashes on startup El Capitan OSX 10.11

This morning I purchased Scrivener. I have heard lot’s of good things about the software (apparently it is the go to software application for serious writing!) and wanted to give it a try!
I downloaded the software, registered and fired it up…… It didn’t fire up. The software does not launch anymore. Wondering what the issue could be I turned to Google search. The most common issue, that fits within my situation, is the privacy settings. To be more precies, the privacy settings concerning Scrivener and Contacts. I turned them off but the problem still persists.
Can you guys help me resolve this issue?
Cheers,
SC

I’ve used Scrivener for more years than I care to remember and written eight books using it, but I’m having exactly the same problem. I just upgraded to El Capitan and it’s now unusable. Crashes on startup 50% of the time, managed to get it open the other 50% of the time but it refuses to load any of my projects and says they are all corrupted. After trying to load one a bunch of different ways, it finally opened…then crashed in less than a minute.

What in the world is going on? Scrivener has been solid as a rock for years and now it’s a complete mess (and, yes, I am running the current version).

It’s a bug in El Capitan. The solution is here:

scrivener.tenderapp.com/help/kb … -os-x-1011

That should get you up and running again.

All the best,
Keith

Thanks, Keith. Yeah, I found that fix on another thread I discovered subsequent to putting up this post and (so far at least) that seems to have solved the problem…

I reached out to Scrivener, via Twitter, and got a fast reply with the solution!

It was the same solution Keith posted!

Thanks :slight_smile:

Hi,

I’ve tried both solutions and neither work. The first,

$ defaults delete .GlobalPreferences NSFont

begets:

2015-10-14 14:20:29.957 defaults[658:12661]
Domain (.GlobalPreferences) not found.
Defaults have not been changed.

When I move the plist file to ~/Desktop and restart, I get the same behavior. Scrivener freezes when I attempt to open a Project. If I try to open it using 2.6, I get a message saying that the project is already open. Scrivener won’t respond to Quit, and the only way to close it is by using the Force Quit method from the apple menu.

UPDATE:

I’ve managed to get Scrivener to work by deleting the updated version entirely and re-installing a fresh copy from the website.

literatureandlatte.com/download_mac.php

This was per Jeff’s suggestion via the email thread I spawned shortly before jumping into the forum.

One thing I noticed was that the existing, crashing, not working version of scrivener had a timestamp of 1984 and a file size of 72MB. So, I deleted it and re-installed. So far so good! Will update as fit.