Scrivener crashes when backing up

I have installed Scrivener Version: - Nov 14 2019 on Windows 10 Home v1909 18363.752. I’ve been using it for a week now and was really happy with it, but today I find that the program stops working (doesn’t respond when backing up automatically). I tried closing the computer and reopening it. I also tried to open the .scriv file I’m working on another computer, but the result is still the same (if I open a new, blank file there is no problem so the problem is in the .scriv file )
What can I do?
Thank you so much

System: Win7 32bit, Purchased Scrivener some time ago.

I just want to mention that I too am having the same problem. I only just recovered this machine and was hoping to use it as my writing station (hadn’t opened Scrivener on this system in about a year or so); however, when I
open a project, it mentions that it is of the old format and promptly backs it up to a different folder. After that,
the backup dialog closes and nothing happens.

I went into the registry and killed off some of the ‘recent project’ entries and opened Scrivener directly.
It would fail to open. I’m not sure which version I had but iirc, it’s circa 2018 Oct. Seeing as there’s a new
version, I downloaded it and installed it over the old version. (In hindsight, I should’ve just installed it
in a different directory, or even removed the old version then installed the new one).

After that, starting Scrivener, I get the splash screen + the Trial key. After a few attempts at
entering my activation key on the dialog, Scrivener finally opens.

However, I can’t open any of my old projects. Scrivener would just backup the file to a
different folder name, and then promptly crashes.

So I figured I’d test out creating a new project.

1 - Start Scrivener
2 - Create new project.
3 - Entered TestXX in the project name and clicked create.
4 - After a bit, Scrivener just crashes with the “Scrivener has stopped working” error.

I then tried opening my old project and it backs up the project; but after backing up, that dialog disappears and nothing happens. Task Manager shows no instances of Scrivener working.

Noticing that there’s a scrivenerlog.bat file, I ran it and tried opening the TestXX project, and I get:

I think I’ll just uninstall Scrivener and install the new one in a different directory.

Incidentally, the above also perturbs me a bit. While it is ‘assumed’ that the “Sending command: Stop” implies that the message sent to the license server was "stop’, but that begs the question. Why? I’ve never been a fan of products phoning home for license checking or not. I’ve never ever trusted these types of software, particularly products which either need to regularly connect to the license server. Anyway… what’s done is done.
Paddle is just not worth the frustration; but to each his/her own. [my $0.02].

Not sure if I should uninstall Scrivener or just wait for a better update?

Incidentally, if I start Scrivener, I get the Getting Started page; but I have no idea where to find the version.