Scrivener crashes when opening SCRIV file

Hi,

Scrivener crashes when opening (loading) one of my files, but is able to open other files and able to create new files.

Strangely, the file that causes the crash was having no issues yesterday.

Please see attached for the 2 crash logs.

Any way to resolve this?

Tried opening the same file in Scrivener iOS and it works; no issues at all.

Seems the problem is with MacOS. I updated to Big Sur some time back.

Have you tried using the test build referred to in this post?

[url]https://forum.literatureandlatte.com/t/bug-instacrash-after-3-2-upgrade/93358/17]

Stephen

I’m having the same problem. It crashes then tells me it’s open on another system. This seemed to start right after the 3.2.1 update. I’m on a Mac running 10.15.7. After I restored the file from a backup it opened once then the same thing happened. it crashes every time.

Please try the test build Stephen_C linked. If that doesn’t help, please open a support ticket and attach a copy of the crash report.
literatureandlatte.com/contact-us

Katherine

Just wanted to say this worked for me as well! Thank you.

The test build worked! I can open the file now. Thanks!

Hope to see the new update with test build patch soon.