Scrivener crashing on OSX 10.12.6

I’ve just updated by Macbook to OSX 10.12.6 from 10.12.5 (both Sierra) and now my Scrivener won’t open blank documents or let me type a single letter in current documents without crashing.

I’ve uninstalled and reinstalled three times with no improvement.

I’m currently nearing the end of a second draft of a novel and honestly I’m kind of massively freaking out here. Can anyone help?

Can you revert the update?

Scrivener’s running fine for me on 10.12.6. Have you tried reinstalling Scrivener?

She says she’s done that three times, to no effect.

View from left field here. I think the update process from 10.12.5 to 10.12.6 can be screwy! I’ve updated both my MBA (256 GB SSID) and my MBP (512GB SSID). The MBA is perfectly fine, though it does tend to run a bit hot—it’s a late 2010 MBA with a 1.86 GHz processor, a 1.07 GHz bus speed and 2GB comparatively slow RAM—but upon updating the MBP, Techtool warned me I had less than 15% of disk space left! I use that mostly for video editing, it has fewer apps taking up under 20GB of disk space, and virtually no documents as I keep the Final Cut Pro libraries, etc. on a FireWire 800 external disk to ensure there’s plenty of temporary space on the SSID.

I eventually found the culprit: my user library, which, for no good reason I can see, has suddenly ballooned to 375GB, while that on the MBA remains at under 20GB. So I’m going to have to bite the bullet and do a completely clean installation of 10.12.6 and all the necessary software. I’ve copied major application support and preference files and fonts from the library, but it’s still going to waste most of a day.

So, I just wonder if Heather is also a victim of a screwed up system update. Apple has also made it more difficult to find the Combo updater. Heather I recommend you go (if you can) to
support.apple.com/kb/DL1931?vie … cale=en_GB
if you’re in the UK … though presumably the GBs should be replaced by US or whatever your country code is. However, you may have to follow the trail through MacOS Support.

Hope that may help.
:slight_smile:
Mark

EDIT: I see the URL is shortened with ellipses when this is posted. The end of it is DL1931?viewlocale=en_GB&locale=en_GB

Mark, why not use a tool like DaisyDisk (which is brilliant), to drill down and work out what is eating your space?

On topic, I’ve upgraded 3 Macs to 10.12.6 (using the Combo updater), and no problems on any of them…

Thanks, Ian for your concern. I have TechTool Pro and Cocktail, but with under 9% of the drive space available in the end, the best solution was to set up a Genius Bar appointment and get them to re-initialise the SSID and re-install 10.12.6. Each time I booted up, the library consumed more space, The guy reckoned that the download had gone wrong and it was trying to reinstall the library, adding it to what was there each time with every boot up.

There was virtually no data on the SSID as I said, so once it was done it was only a matter of installing essential apps … half a day taken up though.

I didn’t have a bootable backup disk, but I must set one up. Trouble is having to find a Thunderbolt 1 or 2 or Firewire 800 disk, as the only other ports are slow old USB 2! I guess I’ll have to get a suitable one of those and re-purpose an existing disk.

I too have updated my 2010 MBA and a 2010 iMac without problems; obviously the update process can be a bit flaky!

Mark

EDIT: and now I’m up and running, I’ll set up a TechTool Pro rescue CD too. :slight_smile:

A slow bootable backup is better than no bootable backup :stuck_out_tongue: I have a thunderbolt to SATA 2.5" adaptor from Seagate (so I can plugin naked SSDs), and I’m pretty disappointed with its performance considering its cost (it is no faster than USB3). It is faster than USB2 though! If you don’t have it, I can highly recommend Carbon Copy Cloner for setting up automated cloning. Anyway, glad you got it sorted. I’m planning to clean install 10.13 when it comes out, so will be doing the same as you soon enough…

Offtopic, but for some of our scientific software I work with Dell workstations running Windows and Linux. Cloning is such a complex nightmare on these systems, and the flexibility and simplicity of clones booting on any mac is such a strong, if often overlooked, advantage of Macs over PCs.

Couldn’t agree more, but I’m perpetually having to juggle disks … Final Cut Pro libraries can easily run into hundreds of GB, and I need to store backups, going back years, of original footage and final masters if not the FCP libraries, so most of my disks are pretty full. As there was no data on the MBP, it was best not to use up space.

I’ll be looking into another large new drive. I have Chronosync, which I use to create a (more or less) weekly back up of my MBA. It too is very good in my experience.

I’ve had to use Windows periodically over the years since I became Mac-based (somewhere around 1991 I think) and each time I get very frustrated; I’ve never had to try and clone one, so I’ll believe you. As for Linux, a while back, I still had my original 17" MBP as well as this one, so I thought I might try installing Linux on it. I can’t remember which version of Linux it was I tried, but I failed utterly to get it installed, and in the end thought I didn’t have enough life left to be bothered with all that hassle. :slight_smile:

Mark

If you do a clone using CarbonCopyCloner (and update it every day) you will find USB2 and a cheap external HD more than adequate for booting from a clone.

Having been in sysadmin/Ops/consulting side of IT over 25 years, it’s all a matter of the tools you use. I miss Ghost.

Windows is easy to clone if you don’t have an AD-joined machine and repair the bootloader.

Linux is as easy to clone as FreeBSD, and modern Mac OS is a FreeBSD variant with custom filesystems.

BUT using the clone on a different machine is the issue I have. I clone a working set up of Windows 10 from Dell workstation A to a USB3 disk to try to boot on workstation B (both Precision 5810’s separated by a few years). Both BIOSes are setup to use UEFI etc. and disks were the same size or larger. But B just hangs (after repairing boot tables etc.). I try with Ubuntu 17.04 from A in the same scenario, also hangs on boot (reinstall grub2 etc.)[1]. There are reams of conflicting advice about restructuring partition tables, removing specific config files and the like. Although I am a geek, this is not my day job, and I end up wasting time I should be spending doing scientific research. I’m not talking about large scale virgin-OS cloning, I do realise imaging a large number of identical machines is fairly straight forward. And you obviously have tons more experience than me.

Yet I clone any mac boot drive to an external and it works wherever I go. Move A ⬄ B ⬄ Z. I’m sure this is just because macOS deals with a limited set of possible hardware targets and a simplified boot partition structure, but I don’t care. Life is short, and although I could moan all day about other myriad problems of Macs and macOS, dealing with clone/transfer/boot is not one of them.


[1] all cloned using clonezilla, but I will now try the file-level fsarchiver, which I will test later this week as our main research machine gets a replacement M.2 SSD from Dell.