scrivener crashing!

I am using the Nanowrimo trial version. Now that I have imported a document and am trying to set it up in Scrivener, whenever I go into the document, I get a warning that Scrivener has stopped working and needs to shut down. I can’t even scroll through the document without having to turn it off.

What is going on? Does it have anything to do with the import from Open Office, Windows 7, or the free trial?


It might be the imported document–certainly seems likely, since trying to work in that is provoking the crash. Try opening the document in Open Office, copying the text, and pasting into Notepad, then saving with the default ANSI encoding. You’ll lose all your formatting, so I know this isn’t ideal–it’s mostly just to test if this is an issue. When you save like that in Notepad, it may give you a warning that some characters will be lost–say OK. If that happens, those characters will turn into a ? character, and my guess is that you’d find them around double and single quote marks, em-dashes, and ellipses. You can try dong a find/replace to see where they are. (Not every quote mark would have one, I just mean that before or after a quote is one of the more likely places you’ll find this.)

If that all happens, try deleting the originally imported document from your project (and empty it from trash) and then pasting that stripped text into Scrivener (or importing the newly saved .txt file). Can you work in that without a problem?

There seems to be a bug with certain Unicode characters rendering incorrectly which I think is triggering a crash, so the above method of stripping them out should work. Lee’s still in the process of sorting this out and fixing it, so it’d be great to hear if that works for you. Otherwise it may be some other bug, though I still would guess it’s related to the file you’re importing. You might also try stripping any particularly fancy formatting like styles out of the document in OpenOffice and saving it as an RTF before importing to see if that works.

the font is Book Antiqua and I don’t use any characters that I would consider unusual–I’m not fancy at all. I did notice that my contractions were missing apostrophes after the import. Is that pertinent at all?

Yes, I’m pretty sure that’s exactly the problem. The code for those characters isn’t being handled properly. Try the Notepad method and see if that works for you.

I’m having the same problem with data I imported from the Mac version (2.1 I believe). The apostrophes and quotes are missing and as soon as I try to edit Scrivener crashes. I don’t think I imported from anything into the Mac Scrivener, but it has been long enough I can’t totally vouch for that.

I tried cycling text through NotePad. I no longer have issues with the missing quotes or apostrophes and so far no crashes on the text. It is a time-consuming process because it does strip all formatting and so far wants to insert paragraph breaks at the end of each line. There is probably a way to avoid that if I knew NotePad better.

Have you upgraded to the 049 beta? Lee’s been working on this issue and 049 should correct things–the problem is with certain characters that Scrivener’s strict RTF base wouldn’t allow, but these illegal characters are now cleaned up to display as an unrecognized character symbol, which you can easily clean up from your project as needed. (I don’t think it’s in 049, but there will be an option as well to just have these characters stripped entirely rather than displaying with the unrecognized symbol, so if you prefer you’ll be able to set that on.)

If you’re using the NaNo Trial version, redownload that from the offers page–it’s been updated there to this newer version as well, and that will give you still the extended Dec 7th expiration date. (Make sure you clear your browser cache first, as some browsers will just regurgitate the old file for your rather than noticing there’s a change and downloading the new one.)

I tried downloading the new version and reinstalling. Still got a couple of crashes. Same pattern–trying to edit text with missing quotes or apostrophes. I’m not entirely sure I was successful in the installation though, so no guarantee that the newer version is what I’m running.

Sorry, just so I’m clear, you installed 049 (you can check by going to Help > Check for Updates) and then did you re-import text and still not have the apostrophes or any “unknown character” symbol show up there, or were you working with already imported text and it still didn’t have the apostrophe/unknown character show? They should be showing up now so I just want to make sure I’m clear on what bugs are here.

I checked the help and apparently the last update didn’t take for some reason. I was still on .46. I just did the update. Haven’t had a chance to see if it still has the issue. I’ll experiment with it as I have time (doing NaNo so I’ll have to get my word quota done first) and get back to you. One problem: It does say it will expire Nov 7 rather than after the end of NaNo now.

Ah, okay, thanks for the info.

Yes, sorry if I wasn’t clear–the regular betas, of which 049 is the most recent, will expire on Nov 7th. The NaNoWriMo trials are the only ones that have the extended expiration to Dec 7th, so for that you’ll need to install the NaNoWriMo trial, the newer of which is version 046. If you reinstall the NaNoWriMo trial, it will get you back to the Dec. 7th date.

As for the testing, I’m sure you’re extra busy with NaNo, and I realize the hassle of trying to deal with the different expiration dates, so don’t worry about this if you don’t get a chance to go into it. We’re still investigating and Lee has made some fixes for the 1.0 release, so the issue you’re experiencing may well be already solved. It just would be great to get some additional details on this to make sure we’ve got the right error.

robini - something to do is go through your document (in OpenOffice) and make sure it’s not using Smart Quotes. That will do the ‘fancy’ double quotes, but also a ‘fancy’ apostrophe/single quote. (Might even want to do it in Word, if you’ve got it - Word has the ability to recognize the difference between a smart quote mark and a regular quote mark.

If you manage that, try importing it again and see if there’s a problem with Scrivener crashing.