Scrivener does not recognize .webarchive (treats it like .rtf)

I have a strange problem since a few days. Whenever I drag/import a URL form a browser (Firefox or Safari) into the binder, Scrivener only shows the URL (example.com) in the main window instead of the content of the Website. Before everything worked fine. I didn’t change any settings in Scrivener. What’s wrong?

I did some research in the meantime. It looks like Scrivener ist treating the imported URLs not als .webarchive but as .rtf. When I go into the project file (show package content –> Files –> Docs) I only find example.rtf files despite of the fact that they are imported Websites/webarchives.

Why all of a sudden does Scrivener no more recognize .webarchive? How can I fix this?

Help would be very much appreciated. I work with Mac OS 10.11.6 and the latest Scrivener version.

It’s certainly possible to have a website converted to editable text when you import a website, rather than using WebArchive. Make sure your settings are as you prefer, in the Import/Export preference pane.

Granted when you import a page as text, it doesn’t merely print the URL in the middle of the editor. I don’t really know what that means since nothing is programmed to work that way. Maybe provide a screenshot of what you are seeing to help?

Oh, and since it just started happening, try to think of any utilities or updates you might have recently made to the system within that timeframe.

Thank you for your response.
The strange thing ist, that it worked flawlessly before and I didn’t change a single thing in the preferences.

That’s the way it looks, when I pull this site from the forum from Firefox in the binder:


As you can see, the icon is not shown as a .webarchive (as it should) but as a simple textfile

And this are the settings in the import/export preferences:


I try to figure out, if there was a update recently, but the only thing I remember was the (automatic, grrr…) Dropbox-Update

Update: I have the exact same issue on my second machine, a MacBook Air with 10.11.6 and the latest Scrivener version.
I have a suspicion that a “under the hood” update either from Dropbox or from Apple causes this problem. Here are the latest system updates that Apple applied (without asking).
screenshot_38.png

That’s odd, it looks more like the result you might get if you drag the URL from a browser into an open text editor, that would print the link there—in case you need to cite it for instance—but you say you definitely are dragging the URL into binder and you get a text file with the URL in it?

Well what happens if you drag the URL into the research folder, or anywhere outside of the draft folder (entwurf). You can’t put WebArchives files inside there at any rate, so that might be making things confusing.

Oh, and you can shut off Apple’s auto-update in the “App Store” tab of System Preferences. :slight_smile: That gets rid of the annoying Windows-style daily update notification as well.

I pull the Website into the binder, the same way I have done it housands of times it in the last years. I use the program extensively since the first beta releases. It makes no difference if I place the URL in the draft, the research or any other area of the binder: it is not recognized as a .webachive and I always get the strange text-icon and the full URL written in the main window. Here is another screenshot:

This happens on two machines. A MacMini and a MacBook Air, both with OS 10.11.6, Dropbox an LittleSnitch but otherwise different software environements.

It’s almost acting as though it’s not getting a URL and is instead getting a snippet of text. For example if you select some text out of this thread and drag it into the binder you’ll get a document very much like depicted. Or here’s an even better demonstration: select the URL from Scrivener’s own text editor and drag and drop that text into the binder—that’s what seems to be happening. The question is why.

Might it be Firefox that changed (another aggressive automatic updater)? I don’t have the latest version at the moment, so it’s working fine for me, even when I drag the URL as text out of the URL bar instead of the little website icon.

Here are a few other things to check to see if WebArchives are working in general:

  • Try dragging the URL into a References pane, and then drag from there into the binder. That will test to see where Scrivener is handling a proper URL drag. (And if it doesn’t drag properly into the References pane, just make a new external link manually and paste the URL in yourself).
  • If that doesn’t work, try using the File/Import/Web Page… menu command.

It looks like Firefox is the cause. For a test I quickly installed Chrome and Safari an gave it a try: Bingo. With both browsers Webarchives are properly imported and the correct icons appear in the binder. At least on the MacBook. Tomorrow I’ll try with the MacMini in the office. Looks like I have to switch to Chromium…
Thanks for your help.

I’ve been using Vivaldi for the past half year or so. If you’re looking for something with a few more features than Safari or stock Chromium, but yet with a solid plug-in expansion capability (it can take every Chrome plug-in I’ve thrown at it so far), it’s pretty good! It’s made by the same team that did the original Opera browser, and they are still expanding its capabilities.

It still has some rough edges in my opinion, but I feel very little urge to switch back to Firefox at this point.

I tried Vivaldi for a while and liked its features, but the big problem for me was there was no 1Password extension. Then one of the updates I downloaded came with some malware, so I gave up. I might try again, as there have been more updates.

Mark

You might want to avoid Chrome if you value your privacy…

Vivaldi and 1Password play along just fine at this point. I’ve never had an issue with the integration between the two. I’m currently using Ghostery, uBlock Origin, ScriptBlock, Vanilla Cookie and Stylish to keep the Web clean and relatively tracker free.

The recent updates have been good. The history function is something to see—finally a browser that respects browsing history!

Yeah, Chromium is a bit better though with the right preferences (basically turn off all of the search help and preload stuff), though to me it feels more like a tech platform than a proper full-featured browser.

Thanks for this recommendation, Ioa! I installed Vivaldi today and am glad I did.