Scrivener don't open before one hour long

Hello everyone.

I’m using Scrivener for more than two years now and I’ve got some problems with one of my computers. Both are on Windows 7.

When I tried to open Scrivener, the soft take a looooong way to open. And when I say a long way, it may take to one hour to open the soft window, add 30 minutes to be able to interact with it. The process is running on the background but the soft isn’t showing on the desktop.
It came a morning after some years of good practice and I don’t know why. I tried uninstall and reinstall, even installing it on my SSD but nothing change. I tried to open a new project instead of my big one which I was working on but same results…

On my other laptop everything is working OK.

If someone has some clue about it, I would be really happy, it’s kind of anoying to cannot use it on my main computer…

Thank you and have a good day.

Sounds like you’re having the same problem a lot of us are having. Check out this thread:


Thank you… Yes it seems quite similar you’re right.
But I already tried to change to older version (I’m on 1.9.0 currently) and i’ve still got the same problem. The soft won’t load anymore at all. there is just a window saying “not responding” on my screen all day as I was waiting to see if it woul open or not. Seems it didn’t want to :frowning:


Because I’m not an expert in Scrivener, maybe I can help from a computer perspective. These questions may seem simple or obvious, so forgive me. Usually something this huge comes from a simple [hidden] reason.

Q: When you start Windows, does everything else run as expected?
Q: When you start Scrivener, can you go to your Task Manager and see if it is taking high CPU, Memory (RAM), or hard drive access?
-Right-Click on the task bar and select “Start Task Manager”.
-Click the tab at the top that says “Processes”.
-Click the top of the list, on the header labeled “CPU”, so the bigger numbers are at the top (may have to click once is not already sorting that way).
-The left-most column is called “Image Name”, and these are the actual processes running. One application can have more than one, or the name can be strange.
-Note if anything looks like it is taking close to 100% CPU.
Q: When you click Performance”, do you see either the “CPU Usage” or “Memory” full/high?
Q: Look at the little numbers in boxes at the bottom, which is another way to interpret the graphs.
-When Scrivener is in this long loading, what is read for “Physical Memory (MB) > Total and Free”?
Q: If nothing jumps out at you for CPU and Memory, click that button at the bottom that says “Resource Monitor”.
-Click the “Disk” tab at the top. At the right you will see pretty graphs moving in real time, showing how much load (file transfers) each disk is under.
-Do you see any that are all green (graph is high), or close? If you have a lot of disks, there is a scroller thingie at the right to see the ones below what you can see.
Q: On that same “Resource Monitor” screen/application, note the following things:
-Under “Processes With Disk Activity”:
-Under “Disk Activity”, check out the column “Total (B/sec)”, and sort by it like you did above by clicking on the header of that column. Don’t worry, you can’t click anything in any of these screens to hurt your computer.
-On the left, you see which application is taking up the most disk usage. Remember, disks are the slowest thing your computer talks to, and a problem with a drive, a controller, etc. will show up here first.
-Next move down to the next window, which is “Storage”. You will see a small table, with each hard drive (C:, D:, G:, etc.) in it’s own row. Note any that have a small value in the “Available Space (MB)” column. a number in that column less than 1,000 on a Win 7 machine can be the source of trouble (full disk).
Q: Feel free to go through the “CPU” and “Memory” tabs as well, looking for high load, errors, or a lack of space/overhead.
Q: Where are your project/book files stored, as compared to the program itself? Different hard drive?
Q: Do you have Scrivener set to load your last project when it comes up? Try disabling that so it just comes up empty. A problem in that project would look like the software taking a long time, but might have something to do with the project/book file.
-see: “Tools > Options > General > Startup Options > Reopen projects that were open on quit”.
-After your Scrivener app starts, create a new, simple project from scratch, and then save it. Don’t even add any text, leave it as a clean, empty template. Save it, close Scrivener, and fire it back up. Does Scrivener now load as expected?

Scrivener opens 56 or more files when running, and this doesn’t count DLLs and other system files referenced in the Qt code. It also has 8 windows, 7 of which are hidden. The point is, that modern applications are not like they used to be, where you ran a file, and it ran all by itself. Clues may not be obvious.

I don’t even want to guess based on what you’ve posted, but perhaps smarter minds than mine here will be able to pinpoint things once you share the results of the above.

I know how frustrating things can be… :frowning:

Hats off to you, Easily Distracted, that did it! I’ve had some major slow Scrivener loads, and have been poring over the Task Manager all along. But today, inspired by your post, looked closer and found that Task Manager itself will report the hangup.

In Windows 10 (at least) you’ll see a Details tab in the Task Manager. If you right click on the Scrivener entry there, you’ll see an option Analyze Wait Chain. And there it is: if Scriv is not responding, you can see just the process it’s waiting on.

And for me the answer turns out to be: Splwow64.exe . That’s the Windows process that enables a 32-bit program to use a print driver on the 64-bit operating system. It seems to tie up Scrivener if it’s already running when Scriv is launched. I’m getting a faster load by locating the Splwow64 entry in Task Manager and clicking End Task before launching Scrivener, thereby letting Scriv invoke Splwow64 on its own.

Thanks again, ED!

Cheers – Jerome


Another great tool to help L&L get to the bottom of this: the Process Explorer program from Microsoft/Sysinternals. Properly configured, you can see every system, file, and registry call your program is making and find out what it’s hanging up on.

I would offer to do it, but my Scrivener 1.9.6 installs aren’t exhibiting the problem.

You’re no doubt talking about procmon-good stuff! Based on the user’s description of the issue, I hesitated throwing that app to them, as it has a steep (i.e. discouraging) learning curve. But if you know how to filter in it, it can nail the exact issue-even if a file being opened or registry access.

For the daring out there, the link to the tool(s) devinganger is talking about are here.

Procmon is probably what I was thinking of, but Process Explorer is a good one too: … lorer.aspx

If nothing else, being able to run that, dump it, and see if the expected Qt DLLs are being loaded or if (as someone previously opined) there’s a conflicting version of Qt earlier on the path would be a large help in clearing certain problems up, or pointing to which resource on the machine is unavailable for Scrivener to open.

I personally still think the majority of this is due to over-zealous securitywear that practices DLL injection and other sneaky hooking technqiues to intercept valid system calls (McAfee, Norton, Symantec, I am looking at you!) – but that’s only because I have to deal with that sort of issue on an ongoing basis in my day job. Right now, I’m trying to trace down the cause of a miniscule percentage of dropped network packets and once again the security software suite the customer insists on sticking on all machines (including servers) is a potential candidate for causing the issue.

Was there something in the print queue from a “compile” or normal print operation that got stuck?

Whaouh, thank you all for you replies !
I’ll take a bunch of answer :slight_smile:

For all that thing with the task manager, I’ve already wtach a lot of it when I first encounter with the problem, but I did it again to be sure with your list, Easily Distracted. So are we :

  • Everything is ok when Windows is launching. The computer is quite new, I change it just a month ago.

  • For the RAm and cpu everything is OK. I never exceed 30% of my cpu usage when I try to launch Scrivener and my ram don’t go above 3Go (for 8Go in total). I don’t see any task that could break the process and nearby all my soft - including my antivirus - are closed when I try to launch Scrivener.

  • Concerning the disk, again, nothing out of normal… The one where Sc rivener is install is not overload by i/o and the principal activity is with my system, wich is completely normal… Also got plenty of free space (Going to 50Go to 550Go depending on the disk).

For your other question, yes, my Scrivener project are stored on a different hard drive than the Scrivener installation but until now it never was a problem neither.
Also, I can’t change any option in Scrivener. As the installation is new, the soft don’t try to open an odl project, it’s just trying to open the windows to select a type project (like tutoriel & Co.). But that window stay blanck with a nice “not respondig” message on top of it and I can’t intercat with it at all.

JJSlote : Arg, you gave me hope with that wait chain story but unfortunetly in my case, there is nothing on it :frowning: It feels just like the soft crash on itself when I launch it. But I’m glad you found out what was wrong with your slow Scrivener :slight_smile:

devinganger : I will try procmon or Process explorer in the next few days… Still a better idea than doing nothing and wait :slight_smile: I’ll tell you if I found something weird.

Really thank you again for your asnwer, it’s great to be able to have someone to help !

Nope. Scriv (or Qt) appears to invoke splwow64 on its own, perhaps to find print settings. It doesn’t timely obtain the response it’s awaiting, and holds up the binder load. Other users may have some entry in the registry that isn’t as expected. Etc. I’m hoping L&L will find a way to remove some of the guesswork and user to-and-fro over these load stalls.

Rgds – Jerome

Oh, I haven’t give up yet!

I have another idea for you, and again, based on knowing absolutely nothing about your machine…

Please uninstall (what you have to lose?), but when you go to re-install, please open the installer (assumes you have full confidence in the installer you downloaded?) as Administrator. Windows problems that aren’t obvious, and only affect a few people, are almost ALWAYS permissions.

There are 2 ways to install as Administrator, and one, both, or neither may work:

  1. Right-Click on the installation file, and select Run as Administrator".
  2. Log off as you, and log back in as the Administrator user.

Anyone who has earned their chops working Windows at a busy helpdesk will tell you that there is a difference between the 2 above. I would try #1, then #2.

Don’t worry about installing as Administrator and using as your common user, it will make no difference in the operation of Scrivener.


Developers can fix that easy with an Asynchronous timeout. I don’t see any additional printers, so I wonder why it sits there… Re-install as Administrator like I suggested above? Maybe Scrivener isn’t Top Dog in the permissions stack for the spooler?

Appears that Microsoft has released updates for Windows 7 at least as recently as July 2016, which could result in behind-the-scene changes on machines. Antivirus updates might also be a possibility.

Have you tried the following compatibility workaround? … y-settings

What antivirus is installed?

Oh my !
SpringfieldMH, THANK YOU.
I didn’t think to force the compatibility to my own system… Feeling a little silly now. (It 's king of strange to force the soft to open with a window 7 compatibility on a windows 7 but well, it works !).

@Easily Distracted : I had already done the two step you was talking about, maybe two or three time each :slight_smile: Never changed a thing.

I’m so glad this soft works great again. Very very thank you all ! :smiley:

Wait. So SpringfieldMH’s solution did it? If so, I hope there is a way to get it in the FAQ/Troubleshooting…

Good news!

Yay… Don’t really know why you have to force the compatibility but well… It’s working great right now. Don’t have any lag or a not responding error again.


With these smart people, I knew you’d be back in business sooner or later!

I go to TASK manager and it says it’s running normal… but I don’t see it ???

I’m having a very similar problem. It doesn’t take an hour to load Scrivener on Windows 10, but it does take quite a while, and it is totally unpredictable.

The process is running in the background even when it doesn’t appear to have started, and when I analyze the wait chain I always find that it is waiting on splwow64.exe. For me running Scrivener in compatibility mode doesn’t help. I’ve tried reinstalling, reinstalling as an administrator and it hasn’t changed the situation at all. Sometime running the program as an admin seems to make it load quickly, but I’m not sure if this is legitimate since it doesn’t always hang when starting up.

However, another issue is the Scrivener will also hang when I search my document. It comes back eventually with my search results, but the bigger my docs get, the more I need to search, and waiting a minute each time isn’t viable.

I should probably add that this only has been happening only on my new laptop, my old laptop (which is also Win 10) never had this problem, and hasn’t since the few times I’ve used it.

Anyway, it has been a while since there have been any updates on this thread, but the issue is still happening. Does anyone have suggestions? Or could there be a known work around by now?