Scrivener.exe - Bad Image error

Can someone please help? I’m feeling kinda desperate now. I saw the previous post about this, but the fixes from helpful users are not working for me.

‘Bad Image’ C:\Program Files (x86)\Scrivener\QtWebKit4.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system adminstrator or the software vendor for support. Error status 0xc000020.

I’m using Windows 10, just had an update a few days ago. My virus protection is McAfee. I uninstalled last night and Scrivener worked fine. Now I’m have the same error. The file QtWebKit4.dll is getting reduced to a 0 kb file, so something is deleting it. PLEASE HELP! I’m in the middle of NaNo and need Scrivener to work!

Can someone from Scrivener Tech Support weigh in!

Thanks

It is likely that McAfee was causing this. I un-installed and then re-installed Scrivener, then excluded the quarantined .dll files so McAfee wouldn’t zing them (if it was them doing the zinging). Scrivener seems to be working again, fingers crossed that it stays that way.

Same error observed after updating Windows 10. Uninstall and reinstall of Scrivener fixed this, but don’t have the skillset to theorize why the bug occurred. Running McAfee as well.

That is what I have seen on a couple of installations – something caused a false positive in several of the key executable files and the virus scanner quarantined them. I either had to remove them from quarantine or reinstall after disabling the virus scanner. To keep the files intact for future runs, like you said, I had to add them to the exclusion list.

McAfee seems to be the worst at this – there’s something about old Qt4 programs it doesn’t like.