Scrivener Folder Icon?

I’ve been trying to hack something like this together, but I just don’t have it in me to take it any further without a little help. Anyone know a good way to make a folder icon “branded” with the Scrivener logo? Better yet, anyone have one already made hat I can download? I have accrued tons of Scrivener projects since I started using it and would love to keep them all in one folder. Of course I could just keep them in a bland folder, but I want one that fits with the ret of the OS a la my Dropbox folder, Movies folder, etc. Anyone have this or want this?

I made one a while back for my Scrivener stuff which is meant to look good with Leopard on up. It was just a quick thing I made in a few seconds, so it doesn’t look amazing.

Update: I added another that is slightly more pronounced, and has distorted the logo to match the perspective of the folder leaf in front.

It looks better with larger icon sizes. There isn’t much space to get the logo inside of the folder area in the smallest Finder icon size available. :slight_smile:
ScrivenerFolder2.icns.zip (331 KB)
ScrivenerFolder.icns.zip (104 KB)

Thanks for sharing these. It’s probably a sad testament that having a fancy icon is what finally made me gather all my projects in one, easy-to-exclude-from-Time-Machine folder. Not the utility or convenience or potential organizational benefits, but the appearance. :neutral_face:

But hey, it’s a nice icon. Just looking at that icon makes me want to write!

Then it is an icon worth having! :slight_smile:

This is exactly what I was looking for! Thanks so much.

Unfortunately, no matter how many ways I try I cannot seem to apply this icon to a folder. It shows up as a .icns Preview icon. I’ve tried dragging and dropping and copy pasting into the icon in Get Info. I’m on Snow Leopard. Am I missing something? Thanks!!

Did you click on the icon in the Get Info window so that it gets the blue glow around it before pasting?

I’m having the same problem as poritsky. It ends up applying the Preview / ICNS icon, and not the icon inside the file (which I can see fine when opened in Preview.

I can successfully copy icons from other folders / files by copying them from the Get Info window, but of course the icon for the ICNS is not the icon it contains, if that makes sense.

Clearly I’m missing something, any idea what it might be?

Sarah

Thesis completion anxiety?

I know that is missing.

Hi ex-studentSarah. Miss us?

Hallo Jaysen!

Veeeery Possibly. I got bored waiting for my viva date, so I’ve started working for a teaching qualification in HE. Glad I did too, because I’ve realised that I still enjoy learning, and remembered how much I enjoy teaching. :smiley:

Very much indeed, even Vic-k :open_mouth: Absence, heart, fondness etc.

Things seem really quiet round here… is everyone on holiday?
Sarah

If you open the icon folder in preview, you can select all and copy the actual image there, then select the icon in the Get Info window for whatever folder’s icon you want to change and paste the image there.

  1. Open the ICNS file in Preview.
  2. In Preview, go to Edit > Copy.
  3. Get Info on the folder you want to apply it to in the Finder.
  4. Click on the current folder icon in the Get Info window, so that you get the blue selection glow around it.
  5. Hit cmd-V.

Worked for me. :slight_smile:
Best,
Keith

P.S. Looks like MimeticMouton beat me to it!

Thank you both - MimeticMouton and KB, brilliant :smiley:

It works with a ‘but’… that method does get me the icon on the folder, but if I zoom in the finder, once the icon gets to a certain size, it will switch to a black background instead of a transparent one. Looking at the images in the ICNS, I’m guessing that OSX automatically selects the right size image from the ICNS for the icon size it’s displaying, and the larger icon in the package does have a black background. So in my long-winded way of waffling, what I’m asking is: am I correct in assuming this is normal behaviour?

Sarah

Actually I think it is a sign of the employment times. Fewer people, same or more work. At least that is my excuse.

Sarah, I think the problem is with the original version (non-brightened). When I made that one, I must not have been paying as much attention to the details and it ended up with some bad size options (the black background is one symptom). The second should work better under all display scenarios. If you really prefer the more muted one, I can go back and remake it the same way I made the second one.

Ioa, very kind offer but no need - it never occured to me to try the other file :unamused:
works perfectly (of course), and I do prefer the brighter one.

Thanks once again, these icons are beautiful!
Sarah

You’re welcome! Yeah I like the brighter one better, too.