Scrivener Freezes and Becomes Unresponsive on Start Up

Yesterday, my Scrivener wouldn’t start up. The application opens, but I can’t do anything in it, not even quit. I have to force quit it, even though my system is not registering it as an unresponsive app.

It worked the day before, but now it simply isn’t responding. I forced quit Scrivener, then relaunched and it wouldn’t even start up. I next tried to open one of my projects directly (by double clicking on the project in Finder) and this time it would open the project, but freeze immediately until I am forced to force quite again.

After I force quit it, there is no prompt to report the issue, so I have no idea what is causing the crash.

I have since deleted and reinstalled Scrivener and the problem is still there.

If anyone has any idea what could be causing this please let me know. I have a whole novel in scrivener that I can’t access now and this is really frustrating!

Nevermind…I managed to fix it. It appears a project didn’t close properly and was causing all sorts of problems in the background. Either that, or the sync with google drive was to blame.