Scrivener freezes on launch

Scrivener is freezing on launch. It will present the menu, but that’s it. The menu is no active, and if I switch to another app, I can’t switch back. Force-quit is my only option. Completely unusable. Thus far, I have:

  • removed everything in the ~/Library folder I could find with ‘scriv’ in the name. This includes stuff from Preferences, Caches and Application Support.
  • reinstalled Scrivener using a freshly-downloaded copy.
  • gone through my entire home directory, zipped all .scriv files/packages.

None of that worked (by removing the prefs, I was re-prompted for the automatic updating, but then it freezes after that). I have another account on my Mac, so I logged in on that account and Scrivener worked fine, so it would seem to me to be something related to my account’s data, but I’m out of things I know about to try. Any help would be greatly appreciated.

–jmike

FWIW, I had this same problem. It seems to be related to the auto-update or something, because if I disconnect my network cable, Scrivener boots without difficulty.

Me too, and the same thing cures the problem, but only temporarily. I turned off Airport on my laptop and that allowed Scriv to launch, but just now (a few hours later, with Airport turned back on) it had frozen again. Turning off Airport and force quitting and relaunching Scrivener worked.

Any idea what is causing this? I’m running the latest Scriv - 2.4.1 and the latest Mac OS - 10.8.3.

Any thoughts about this, anyone? It makes Scrivener unusable while the Mac is connected to the internet: not a trivial problem.

I’ve also trashed everything Scrivener-related in ~/Library and it makes no difference.

Nothing relevant is showing up in Console, except one line when I force quit Scriv:
18/05/2013 12:51:04.003 com.apple.launchd.peruser.505[161]: ([0x0-0x30f50f2].com.literatureandlatte.scrivener2[50116]) Exited: Terminated: 15

A complete guess, in the absence of any other advice - could it be related to the report elsewhere in the forum that esellerate have apparently lost/changed their web address?

Maybe that was it, Hugh. It isn’t happening today, I’m happy to say.

Did anyone at Lit and Latte look into this? It seems to be fixed now, but it’s not good to have unexplained intermittent problems: for all I know, it might be back tomorrow, or next week.

Did you contact support at Lit & Lat? While they usually respond to posts here, they don’t always see them (especially once someone replies). However, I have found their response to support emails to be rapid and thorough.

No, I didn’t. I thought (from previous experience) that they monitor this forum. I’m not inclined to bother them at this stage with a problem that has gone away. I was just hoping to hear what had happened behind the scenes, and to be reassured that it wouldn’t happen again.