scrivener freezing up while navigating through documents

Hello,
I recently imported about 80 photographs into my large-ish scrivener project and inserted some into a couple of documents in my project. i noticed that scrivener seemed to slow down when navigating around these photo-laden documents (even though i reduced the photo size). this was not a problem i’d noticed before when inserting photos into my scrivener project documents. nonetheless, i moved the 80 photographs to the trash and emptied the trash. i did not move the few photos that i’d inserted into my documents, however.

now scrivener is freezing up during normal navigation in non-photo-laden documents in this project as well. just moving a line or two down, or selecting some text to make it bold or ital, seems to involve a 30 second delay. what can i do? it’s made it impossible to work on the project.

thanks in advance,
sonia

It sounds to me as though perhaps one or more of those pictures is either corrupted or is using an encoding that doesn’t mix well with the text engine. If you can’t get into the project at all, or the documents in question within the Binder, to remove the graphics from the text files, then you’ll have to dig it out manually.

  1. Since this will involve messing with the internal structure of the project, I recommend creating a backup of the project first. Simply right-click on the project in Finder, and choose to “Compress” it. This will create a copy of the project alongside it, archived in the Zip format. If things blow up, you can get back to where you are by removing the damaged project and double-clicking this Zip file to extract a fresh copy of the project.
  2. Next, right-click on the project file in Finder, and select “Show Package Contents”.
  3. Navigate into the Files/Docs sub-folder.
  4. You’ll see a long list of serial-numbered files. I would recommend sorting the Finder window by document size, then using Quick Look, arrow down through the files until you find the RTF file(s) that contains the pictures. Note: you won’t see the pictures in Quick Look, you’re just looking for text here, as the text rendering engine it uses is incapable of reading RTF graphics. This is probably a good thing, as otherwise Finder might crash once you try to look at the files! :slight_smile:
  5. Drag these files out to the Desktop or somewhere else convenient. Whenever you do this, drag out the associated links file, too. For example, if you drag out “26.rtf”, check for a “26.links” and move that out as well.

Now try re-opening the project and see if everything can be viewed without seizing up the software. The sections you removed the RTF files for will be empty. That’s okay for now. Once you’ve verified everything works fine, open these RTF files in TextEdit. By its nature, TextEdit cannot handle RTF graphics, and so in theory they should be completely omitted from the file. Copy and paste the text from TextEdit into the appropriate Binder items in Scrivener.

Finally, if you had to drag out any .links files you will want to re-instate your comments and footnotes:

  1. Close the project again.
  2. In Finder, right-click on it and select “Show Package Contents”.
  3. Drag the .links files (not the RTF files) back into the Files/Docs folder.

Now when you re-open the project, you should have all of your footnotes and comments back, and any cross-reference style Scrivener Links will once again be functional.

At this point I would recommend clicking on the File menu, holding down the Option button, and choosing “Save and Rebuild Search Indexes”.