Scrivener, High Sierra, and Backups

Hello friends.

I did the upgrade thing with OS X, and by and large we’re on a winner! Most apps mostly work :slight_smile:

Small boggle with Scrivener though. Ref: this error:
Screen Shot 2017-09-28 at 9.05.24 AM.png

My automated backups are no longer working. They did work immediately post the upgrade, but stopped working shortly after. The last backup was made successfully at mid day, and then I got my first instance of the above error message. Since then, no more backups in any Scrivener project. Here’s what the filesystem looks like:
Screen Shot 2017-09-28 at 9.06.44 AM.png

You might be asking, “WTF! It worked, why not now?” and I was wondering a similar thing. About the only thing I can tie this to is that at about mid day yesterday the FileVault encryption completed on that volume. I can’t think of anything else it would be, and while I appreciate this isn’t highly scientific it’s about the only mildly smoking gun I can see.

Anyone had this problem / suggest a fix? I definitely like having automated backups :slight_smile:

EDIT: The disk is not full and the backup path exists.

Lo! After my 40th (wild guess) reboot, it appears to have started working again.

I wonder if there was still something screwy with the underlying FS due to the encryption process?

I personally avoid FileVault like the plague. I’ve upgraded to 10.13 and haven’t found any problems with Scrivener … yet! :wink:

Mark

I get why you would :slight_smile: It’s come a way since I first used it, but it still has some rough edges. Since the device in question is a) highly portable and b) highly desirable, I figured it was worth a little gritting of the teeth for the added peace of mind.

Volume encryption works great for me. I’m on High Sierra as of this afternoon, but I have never had an unencrypted Mac. 'Course, I’ve only been using Macs about three years.

Did you try going into the preferences in Scrivener to confirm the backup location? Maybe that field got set to null, like the error says, and Scrivener was complaining it needed to write the files somewhere. As beatniks and other protohippies might have said, null is, like, nowhere, man.

Edit - just saw your mention that the backup path exists - but was the backup path still set in the preferences? Just curious, glad it’s working now.

Yep. Also worth noting, I tried changing it to a different (also existing) location and it grenaded there too. The backup path was still set in Scriv. It “started working” after a reboot without altering those settings.

It appears to have been some kind of disturbance in the Matrix with a) a newly activated FileVault and b) Scrivener backups. After a couple of reboots (for various other reasons) it seems to have solved its own problem. I do wonder if the dialogue in OS X saying the encryption had finished was in fact erroneous, but that borders on wild conjecture and fever dreams.

Hello,

I’m here because I’ve been experiencing this exact same issue.

Here are my experiences and settings in case they help the developer to debug:

  1. I upgraded recently to High Sierra. My memory tells me that’s when this all began.
  2. Since FileVault was mentioned I’ll confirm that I have it activated …however, it’s been on this whole time, prior to upgrading to High Sierra. Never been a problem as far as I know.
  3. I can re-set the backup location and it works fine for a few saves or sessions (haven’t kept close track). Eventually I get the error message again and I have to re-re-set the backup location.
  4. Here are my backup settings in case helpful: Preferences… > Backup > “Backup on project close” / Compress automatic backups as zip files / Use date in backup file names / Only keep 3 most recent backups.
  5. Should also mention that my backup location is iCloud which uses that convoluted “special” Library file path.
  6. I have latest MacOS updates and my Scrivener app is from the Mac App Store

Thanks.

Same problem for me: Backup folder location reverts to “null.”

  1. Started after High Sierra Moc OS upgrade.
  2. I’ve been using a Dropbox folder for the Scrivener Backup location for 18 months or more with no problem.
  3. Now I get the “Backup folder does not exist” error most of the time when Quiting.
  4. If I check the Scrivener Preferences, Backup, Backup location BEFORE Quiting, I often see “null” in the location. If I reset it, then the backup works on Quit.
  5. I don’t think it’s anything to do with Dropbox, because I tried setting the location to a local folder, but had the same problem.

It’s like Scrivener is not holding the Preference setting.

A second problem:
Also at the same time as the OS upgrade (I think), I started having problems clicking and dragging selected text. If I select a word, phrase, or sentence, then try to click and drag, the selection disappears and begins again as I drag the cursor. I’m forced to Cut and Paste instead of drag text. This is usually fixed temporarily if I Quit Scrivener and Relaunch.

I have no solution, but just letting you know you are not alone. I am experiencing the same issue. Looks there is a bug somewhere in how Scrivener works with High Sierra. Not sure if this forum is monitored by Scrivener staff, otw we should submit a bug report.

Yes, you should submit a bug report through our support system. Various people watch the forums, but not as consistently as we do the formal support queue.

Katherine

Hi all,

I do not have that issue. However, whenever I hear “path / file system trouble right after High Sierra upgrade”, I immediately think of the new file system that Apple introduced with High Sierra. I think(!) the old file system is updated in the background to the new one after the High Sierra upgrade (similar to FileVault encrypting the hard drive in the background once activated for the first time). This might be the trouble, and it would explain why it can be fixed eg. by a restart.

Just my EUR0.02 for the L&L dev colleagues…

Kind regards, Joerg

I have the same “null” issue for auto backups on closing projects, however I’m not using FileVault and my Late 2012 Mac has the old type HDD drive with HFS+ Journaling, so it didn’t convert to the new file system when High Sierra was installed. When I check Preferences --> Backup, the field for backup location is always blank, even though I choose/select a target ever time. It won’t save the location. Oddly I haven’t noticed this behaviour until today, and that’s after installing the latest update from yesterday: High Sierra 10.13.1

We’ve been seeing a few cases of this cropping up in support as well, and as yet don’t really have any clues.

  • One person was able to get around the problem by disabling the zip compression feature.
  • Someone else reported that this didn’t help at all (and in their case they are still getting backups created even though the warning message indicates otherwise).
  • Another case is seeing not only the backup preference go blank, but other preferences get sporadically reset as well.

All of this seems pretty macOS level in terms of whence the shenanigans originate, but it’s hard to say yet. That it works for a bit and then stops working feels a bit to me like Apple’s preference cache system is failing.

As a long shot you could try cleaning out the cache, indexing and temp data with a tool like Onyx or Maintenance. That’s always a very good idea to do before and after a major OS upgrade anyway—if not doing clean installs rather than upgrades.

The thing is, if that were happening, if something was deleting the key from the .plist file, then the default behaviour would be to reload the default settings in the direct-sale version, not to select nothing as the backup folder.

Hello, Amber.

I’ve suspect that this is happening on one project file. I’ve tested the others, the backup file location seems to hold. And it’s absolutely periodically, not all the time. Should I try to create a new project, and then import the old pages/files into it?

I’ll look into those two apps and see if they’re suitable for this purpose. Thank you.

My version was purchased from the App Store, if that adds any useful information.

I’m mistaken. I just tried to create a new project, and the backup folder location was blank. It’s not just one project; this is an issue with the app’s preferences.

I have three different Mac’s. All have been updated to the latest High Sierra as soon as it was officially released. Two of them, a new iMac and a 2015 Macbook, lost their backup settings and had simply no value in the preferences and did not do any backups. They didn’t even warn me about not backing up.

The iMac only needed one correction of the settings and then it worked okay.
On the Macbook I had to repeat the process three times before it stuck.
On my 2013 MPB retina nothing changed. It kept the setting.

A possible clue: On both the iMac and the Macbook the backups were directed to a Mega-folder, i.e. a folder for cloud storage, whereas on the MBP it was directed to Documents on the internal SSD disk. I later changed it to the same Mega cloud storage and it seems to work without problems.

Also, I have the Mac App Store version of Scrivener.

Right, application preferences are not specific to individual documents (projects in this case), and we wouldn’t expect there to be any fluctuation in their behaviour from one project to the next. Project preferences do exist, but they are managed by Scrivener and stored into the project itself, using its own tools for doing so.

Application preferences are not only read and written using Apple code for doing so (Scrivener doesn’t even have code for where the file is saved) but the Mac also manages preferences outside of files, using a dynamic caching system that in recent years has been less than stable or predictable and often disregards files entirely. This is why I mentioned earlier it might be worth doing some system level cleaning since preferences are system level infrastructure.

It’s always worth doing that after an upgrade, as I say, but especially so if the infrastructure is misbehaving.

I should note that whether the software is sandboxed (MAS) or not doesn’t seem to be a factor. We have reports of this happening with the direct-sale version as well.

And yes, as lunk mentions it’s not pervasive. I’ve never seen this error either, and if everyone did we’d be utterly awash in reports. There are a number of them, enough to indicate it’s a fairly common configuration scenario that causes it—but we have no clue what that is. Could be APFS, could be whether or not you sleep the Mac between sessions, could be a buggy upgrade script that impacts only the firmware version of your SSD installed into some Macs. There is no good pattern yet except that it happens periodically and for most people after a few sessions.

With respect, this just isn’t true, unless it changed sometime after Mavericks. Until then, preferences were at user level not system level - except for a relatively small set of preferences that would apply for every user account on the machine. I’ve just checked in my user library and found 2 .plist files prefaced “com.literatureandlatte.scrivener2”; there are none at system level.

I’d suggest that those with this problem should set up a new user account and create a new test Scrivener project there to see if the problem persists. If, as I suspect it will, it does persist, then it’s possibly deep level OS ‘interference’ causing the issue, and not preference files per se.

I’ll try that tomorrow. As an observation, I stepped away from my iMac for a few hours today, it went into sleep, and when I woke it up and checked the preference settings in Scrivener … the backup location info was blank again. This (BTW) started happening after the OS update this week to 10.13.1 Before that I had absolutely no issues.

In your opinion, is it worth deleting and reinstalling the app to see if that solves anything?

You could try, but from what everyone else has said, it does sound like a High Sierra issue rather than Scrivener.