Scrivener, High Sierra, and Backups

ScriverTid, I think you might be misreading my comment. Yes, of course the concept of preferences, as storing which checkboxes you click in different programs and such, are user folder things. I don’t mean preferences are system level in the sense that they impact every user account on the Mac. I mean that the infrastructure for handling preferences on a Mac is system level—and by that I mean even the loading and saving of the .plist file itself, as well as the construction of that file’s data as it saved to the disk. Scrivener doesn’t handle the .plist directly or what goes in it, which is all I meant by my comment.

You could compare it with a similar system on Windows: the registry. Each user has their own registry, but how it is managed is a function of the operating system. Apple’s method uses a hybrid text file approach (the .plists), but it only uses those files if it doesn’t have a cached version of a program’s preferences. The cached preferences can persist from one session to the next, typically only being reliably reset when one reboots, or manually resets the preference caching daemon, but they may also sometimes reset after a certain number of days or program sessions.

Which happens to correlate with the the one common symptom we’ve seen in the reports to date, hence my suspicion that the cache is the root of the problem.

It wouldn’t hurt anything, but we’ve already tried that route with several other people, along with resetting preferences, and neither makes a difference.

It’s suddenly holding the backup settings, and I’ve not tinkered with anything since Saturday evening. Fingers crossed that this continues.

Yes, of course. Got you now.

The problem may be that the paths are corrupted. I noticed that a number of my aliases no longer worked or used generic icons. Piece of cake.

This issue goes back 30 years or more and the solution is the same: Shut down and boot while depressing the Shift key—in OS X, lift when you get to the login screen, enter your Admin password and wait till your desktop icons finish rebuilding. This can take a few minutes. much longer than a normal start. When done, shut down and reboot normally. Don’t try to run any apps until you reboot—almost none will.

In the old days, this was called rebuilding the desktop; nowadays it’s a Safe Boot which happens to include a desktop rebuild. This resets the caches to default and reestablishes and rebuilds default paths.

I take care of many Macs and had to do this on every one of them. I didn’t have to do it again after the recent OS 10.13.1 update a few days ago.

I’m not positive this is the issue with Scrivener except that I haven’t had this problem and I did a Safe Boot on all my Macs.

I’ve got some updates to share on this from my end.

  1. While the most regular behavior is to have “null” reported as the backup location, I’ve had it error out but the preferences still show the correct backup file location (this is rare, but it does happen - that is, Scriv thinks /this/path is where to put backups, but still says the backup path “null” error).
  2. I’ve had Scrivener* take to some of its other preferences with nuclear fire (specifically where it stores the scratchpad, and which fonts are being used in the editor … there may be others but these are the two I’ve found).
  3. I’ve experienced some projects being very sticky/resistant to having the backup path set. In order to fix these, a different backup location must be chosen and then the original one re-selected (simply applying the setting makes no difference). I haven’t tracked down what special characteristic this is related to excepting that the problem children are both novellas, not novels, and thus quite short (smaller size, fewer chapters etc.).
  • note that it sounds like I’m somehow blaming Scriv but I totally buy that this is likely an OS X issue / incompatibility.

Switching user ID was a huge pain and didn’t seem to fix it (or a different user account had the same problem).

A previous poster noted that they are using iCloud as a backup folder, and I’m using OneDrive for backups. Disabling OneDrive (shutting it down) doesn’t appear to fix the problem. Disabling Dropbox (prime storage location) doesn’t appear to fix the problem.

Not sure what it is but would be nice to get a look at a solve, esp. with Scriv 3.0 coming out. Apple have borked other things in High Sierra (my favorite is the bug that stops Apple remotes from working with Plex due to the different reporting of up/down), but this seems to have a less obvious smoking gun than the OS’s remote control API :slight_smile:

Adding another voice to this. I have both the null backup issue, and my general preferences being reset (font style and size).

I’ve seen some of the posts mention a possible issue with File Vault encryption, but I don’t use this at all.

Could I have a show of hands? How many of those with the null backup/lost preferences issue obtained Scrivener via the App Store?

Safe Boot is known to not permanently fix the problem, but it certainly won’t hurt to try as a temporary fix. Likewise other tools for cleaning Mac OS caches.

The first few cases we encountered involved File Vault, but that appears to have been a red herring.

The automatic backup location is a Scrivener-wide setting. Are you saying that some projects throw the error and some do not, while the backup setting is unchanged?

Katherine

I got my copies directly from you. I run it both on my desktop setup mac mini and my Macbook Pro.

Apologies, I just double checked. The copy I run on my Macbook Pro was purchased on the Apple App Store

I’ve not noticed any issue on my desktop, only on my Macbook Pro. I’m only working on one project at the moment, but every time I open it up again after closing (the project, not the whole app) - usually having left the Scrivener app running, but having let the mac go to sleep - the preferences have been reset.

I’ll do my best to help with any other questions you have.

Duncan

Got mine from the App Store. Which I will remedy on Monday when 3.0 launches and I can get the u/g direct :slight_smile:

Yes kinda :slight_smile: But I need to be clearer because re-reading what I wrote it wasn’t clear what I said, so :slight_smile:

To be more precise, sometimes the field is rendered to null / empty (the setting appears to be reset). However! Other times it is set (you can see it in the Preferences as holding the correct path) but Scrivener still has a cry on exit about a null location. Open Scriv, setting is there, exit, error, rinse, repeat. To fix this it needs to be changed to another existing location and then reverted back.

So:
Scrivener will sometimes complain about a null location and the setting has reverted to null. This is remedied by adding the backup location back in.
Scrivener will also complain about a null location while holding the location “correctly.” No amount of restarting Scrivener fixes this; even pasting the same value in won’t change it. The backup location must be altered to a different path, before reverting back to the original, to fix this.

I hope that helps. The problem sounds like a horrible one to track down :frowning:

App store.

And I never got any error messages. The only indication of something being wrong was that the notification window and progress bar didn’t appear at project close. [size=85](I always close any open project when I start doing something else and stop writing, in order not to have an open project in case I later try to access it from somewhere else)[/size]

Purchased on App Store, but I’d like to note that Safe Boot (seemed to) fix the problem. I’ve not seen a repeat of it since performing Safe Boot.

Did anyone figure out the backup issue on Mac with the newest Scrivener version? I keep defining the backup folder, but it goes blank each time I close the software and reopen it. Anyone find a solution?