Scrivener is not holding on to Project References

Don’t know if this applies only to the latest beta, as I only tried it recently.

Scrivener is not holding on to my Final Draft 8 .fdx Project Reference link.

Videos and Word docs seem to be OK, as far as I can see.

Let’s say I make a link today, then open that project the next day.

The icon for the FD file has been replaced by a generic icon.

When I right click on the generic icon next to the title of the script, I get a warning box saying that the file can’t be found. ( I have NOT moved the file to another folder)

This happens whether I’ve worked on the script in FD in the interim or not

Any one else notice this? Help would be appreciated.

Thanks,

Hm, are there any special characters in the Final Draft file or its filepath? Are you able to access the link from Scrivener after you first import it, just not after closing and reopening the project?

OK, now I know you’re a genius.
the issue was that–in order to import and split into Scrivener-- I added a # character by each header (imports beautifully, BTW)
for instance
#INT. FACTORY - NIGHT

So, to differentiate that script from a version that doesn’t have the # marks, I named it
TheName #1-9-13.fdx

Apparently, THAT was the problem

I closed Scrivener, renamed the script without the # Even made changes in the script in FD, reopened Scrivener. the lovely FD icon was there. No more warnings. A right click opened it up in FD
YAY!
You guys are the best support tech support ever!
thank you,