Scrivener keeps corrupting back up files

Here is what is happening:

I opened my project today and noticed that ‘somehow’ the content of a whole chapter has disappeared.
The page is still there, but blank. 3,000+ words gone …

Not sure how it happened, perhaps it was when Scrivener crashed last week? The cat walked over the key board and deleted the chapter content?

Anyhow, I don’t panic as I do back up regularly. So I go into Timemachine and download an earlier version of the project.

I check in file preview and yes, the missing chapter is there. Yippee!

I restore it to a different folder, not my project folder, and check again, missing chapter still there.

I open the restored project and CHAPTER CONTENT GONE!

I have now tried this with back up files from three different sources, the files look fine in preview / quick look, but as soon as I open them with Scrivener, the same chapter content is missing again.

Any help appreciated, SY

Madly googling around I found this solution which worked for me: … -from.html but I still need to know how to avoid this happening in the future, SY

Are you using Dropbox or a similar service?

This sounds like a problem with the master .scrivx file that tells Scrivener which file belongs to which Binder item: the content is there in the file, but the link to it within the Scrivener project is broken.