Scrivener lags while typing

I am using Scrivener for years now and never had such lagging while typing as in the past weeks (don’t know when it first occurred).

Has anybody working with Windows 10 the same problems?

I have checked the forum and tried several things:

  • first I thought that it was caused by backing up to a network drive via my 10 MBit/s Ethernet - and switched to backing up to a local harddrive - no change.
  • then I thought it might be because the working files are on the network drive as well and switched to a local drive - still the same.
  • I saved and created the index new - still lagging
  • in options I reduced the last opened projects to 5 and auto save up to 30 seconds of inactivity - still lagging

So what else can I try? Scrivener lags only a tiny bit but I find that I hit the keys harder and harder subconsciously to make it work faster and this becomes very tiring.

Regards
jester

“Has anybody working with Windows 10 the same problems?”
Yes and it’s really annoying like you state. I have nothing running in the background but since updating to windows 10 I have the annoying lag where the cursor freezes for a moment or so. It makes typing difficult. I have the auto save running at ten seconds but it makes no difference. If you find the cause please update your post.

I work on Windows 10 (Pro, 64 bit) and am not experiencing this.

Sounds like you’ve assured that all related files/activity is on local hard drives (HD) or solid state drives (SSD), as opposed to network, cloud/Internet, USB thumb/flash drives, etc.

Other things that come to mind:

  • Any new or upgraded apps installed recently?
  • Assure at least 10% free space on the drives
  • Rule out other applications or background utilities that might be running and interfering or consuming significant amounts of system resources and performance
  • If editing in “scrivenings” mode (concatenated view of more than one document at a time), don’t or reduce the scope/number of documents currently being viewed
  • If have picture(s) in the document you are editing, reduce the number of pictures by splitting them out/place them in multiple smaller documents
  • If have a large amount of text in the document (many tens of thousands of characters) you are editing, split it into multiple smaller documents.
  • Any third party keyboard text expander or macro utility running?
  • Start a new empty project and see if experience the issue when working in it.

Beyond that, it is worthwhile, though admittedly tedious, to search the forums (via search field in upper right corner) on “lag” and skim through the discussion threads that it turns up, to see what other folks experience and solutions have been.

Hope that helps.

Thanks for your reply - I checked all you suggested.

I have a system with 16 GB RAM since I am working with Adobe Software - so that should be enough for Scrivener, too. My disk has 500 GB space, half of which is free. As I have described I have changed the location from my network server to this local disc with no improvement at all.

Of course I have other applications running - just as with all other software I am using and not having problems with. So this is not an option.

The project is fairly new and I am not working in scrivenings mode. There are no pictures in the document.

Since I use Scrivener to pre-write my blog posts you can imagine that I am not dealing with large amounts of text. The lagging starts immediately after writing a couple of lines. My documents are between 500 and 2500 words long. I don’t have any text expander or macro utility working. The lagging happens in all projects, also in new ones.

And you have probably not read what I wrote: I actually did use the search function of the forum and read what other folks experienced and tried that first as described.

I did read what you wrote in your original posting. In it, you did not detail that you had checked the specific things or specific search I proceeded to suggest. And I’m not a mind reader.

Two additional things come to mind…

Yes, that is somewhat by guess and by golly. Fundamental point is, something likely changed recently on your PC. The trick is to find out what or bracket it until the problem goes away. And no, there’s no particular reason, at this point, to assume that Scrivener is at fault.

Beyond that, your best bet is probably to directly email Scrivener tech support as discussed here literatureandlatte.com/support.php

Hope that helps. Shutting up.

Sure you are not a mind reader - and I am not a native speaker of English - so I thought what I had described was sufficient. Sorry about that.

I will try the uninstall, redownload, reinstall procedure, thanks for guiding me to that. Thank you also for the link you provided, I’ll check that, too.

I will keep this thread updated of what I found out.