Scrivener launches, projects won't open—resolved!

KB & wock—thank you for your quick responses. I decided to open Scrivener in another User account, where the same problem occurred, except this time I got an error message referring to the possibility of a problem with permissions. I used Onyx to repair permissions, and that seems to have solved the problem.

I’m guessing that what caused this is that I moved Scrivener into a subfolder, within the Applications folder, for all my writing applications, then thought better of that plan and moved it back out, into the Applications folder. The error message that tipped me off said something to the effect that the application might be in a folder that didn’t have access permissions.

All of the projects are OK. Your responsive support is much appreciated. Scrivener is an excellent application and I’m glad to have it working again.

I’d bet my Scrivener license that something else fixed your problems. :wink:

Any ideas about what the something else might be? It does seem like moving the application to a subfolder caused the problem—I had trouble with another application that I moved to a subfolder, and that problem cleared up as soon as I moved it back into the main Applications folder. In the case of Scrivener, I deleted the application, preferences, and all of its Application Support files, then reinstalled—none of which fixed the problem (projects wouldn’t launch, even the tutorial), which persisted even in another user account. I ran Onyx from the new user account, and the only option I chose was the permissions repair, didn’t even rebuild Launch Services. Immediately after that Scrivener worked fine. I am really curious about what happened, especially whether it’s not OK to group applications in subfolders within the Applications folder.

When you created the “subfolder” you may have created a folder with limited permissions causing Scrivener to Not be able to launch because its parent Folder did not have permission. Onyx would not have fixed this since repair permissions only repairs certain system permissions and certain Apple applications but it would not fix the permissions set on that subfolder would fix the problem.

Now there are TWO Applications Folders per user account and not ONE.

HD/Applications (For all users)
HD/Users/AccountName/Applications (For that user only)

If Scrivener was copied into the User Only Application Folder it would probably NOT launch for any other user account and could cause Permission errors.

The second Applications Folder (for user only) is for that case when an installer asks you if you would like this application available for Everyone (First application Folder) or for that account only (User Application Folder) this is used mainly for Parental Controls or for administrators to limit the use of applications for other users. (A scenario usually for when it is a family shared computer with young children or teens)

Also what may have happened when you moved SCR out of the Folder and back into the Application Folder is it was no longer controled by the “parent folder” permissions and was allowed to run. But since you trashed the prefs and other files it opened but did NOT open any project. Since there is no splash screen (1.11) it could appear as if it never launched. The next time you launched it maybe you launched it by clicking on a project file instead of the icon and then it would Open the project on launch. (This is very common and since then Team KB is having a screen in 1.12b so users are more easily aware that SCR is actually running.

If you want to have folders to organize applications for easy navigation the simplest method that causes the least problems is make your subfolder and then make SHORTCUTS of each application that would reside in that folder. YOu open the subfolder and click on the shortcut icon and it runs the application.

Apple and many third party software writers have their apps coded to look into the APPLICATIONS folder. (HD/APPLICATIONS) I think this may be a carry over from the habit of Windows programmers looking for PROGRAM FILES. Many Applications (Like Dictionary) will run but not properly if moved from the Applications Folder (Context menu to launch dictionary will not work unless Dictionary app is in Application Folder). SCR can run about anywhere as long as its parent Folder wherever it resides has the proper permissions to allow it to execute but as a rule of thumb I would recommend putting it into the Applications Folder (HD/Applications) and if needed make a shortcut and use the shortcut in a subfolder for easy navigation.

If that makes any sense?

Glad to here you are up and running.

Yes it does make sense. Thank you, wock.