Scrivener Lice

This is my running list of niggling issues in Scrivener land. These bugs aren’t big issues or crashes, they are just a little itchy.

  • When running a search for VW and a project replace, “Volkswagen” becomes “VOLKSWAGEN”. The replaced text seems to inherit the capitalization from the input.
  • If you are searching for text and leave the window to check something in another application, when you return to scrivener, you are typing in the document, not the search window that you were just typing in. This is pretty high risk because the text upon which you are typing is usually covered up by the search window and you may not see the mistake you introduced before you continue searching. (I see this behavior in the way that I use Scrivener, running within a full window and switching between panes on Mac OS X). I observe the same behavior when I hit enter to execute the search.
  • For some reason auto spell check ceased to function in my main document window, even when I turn it on (though it works when I go to “check document now” in the menu. Oddly, spell checking does work in the notes.
  • Footnote edits in the QuickReference panel are not always synced with the document. They only show up once the panel is closed.
  • If you create a comment over a few paragraphs, it deletes all of the comments and notes that were in those paragraphs. An action like that should have a warning, “creating this comment will overwrite 3 footnotes”.
  • When you click on text with a footnote, the footnote is highlighted in the sidebar, but not when you click on text with a comment. It makes it hard to find your place in the sidebar with the comments.
  • There is sometimes a response lag when dealing with notes in longer documents. If you’re not careful, you can accidentally delete 2 or more notes by clicking to close them. But the note minimization feature speeds things up a lot. That is extraordinarily useful.
  • Why is Scriverner auto-correcting capitalized words (like names). That is a terrible idea. Two major mistakes were caught by copy editors: Deleuze->Delouse and Boehner->Boener, Simmel->Simmer, Ungerson->Unreason. I turned off autocorrect. Even though Boehner is a total boener, there should be a proper noun exception. It is fine to underline them, but it is bad practice to auto correct. I realize that you can turn off the "correct spelling mistakes while you type, but there needs to be a distinction between “correcting” a typo like teh->the and changing the spelling of a capitalized proper noun.
  • When I am cleaning up text, I often run a find replace on spaces next to each other. For some reason project replace seems to disregard punctuation. So, replacing " " with " " seemed to remove the period from " . "
  • Scrivener suggests links to sections that are currently in the trash. That can be very confusing. When I want to link, I create a parenthetical that says (see xxx xxx), highlight the name of the section to which I want to link, xxx xxx, and in the context menu, select Scrivener link/suggestions. The fact that sections in the trash are suggested in that menu as well as sections in research and ideas leads to a lot of confusion. The top level icon from the menu structure (trash can/light bulb, newspaper skewmorphic) would make these suggestions much clearer.
  • In the table function, you can merge cells that are in the same row, but you cannot merge cells that are in the same column. When you paste an excel sheet with a merge across columns, the columns are separated.

Some interesting thoughts, thanks.

I think some of them are to do with your specific setup or installation (i.e. it may have become corrupted) rather than Scrivener’s standard working. In order from above:

  • Search window. This doesn’t happen for me when moving from full window to another program and back again – the Search Window retains the focus. Perhaps I’m not following your steps properly though. (Sierra 10.2.2, latest Scrivener version).

  • Overwriting comments. Good spot. I think it’s to do with the fact that the comments / footnotes actually work on spotting a specific formatting style and of course, when you create the long comment it’s overriding the other formatting. The only workaround I think is to have a shorter anchor for the new comment.

  • Highlighting comments / footnotes in the Inspector: I don’t see this issue. They both work the same way for me.

  • Capitalising names. This works fine for British English for me - it never autocorrects already capitalised words. Which language are you using? Do you get the same problem in TextEdit?

  • Punctuation. Again – I can’t reproduce your issue. It works as expected for me.

Thought it was worth mentioning…

I wonder if it’s work backing your projects and preferences and reinstalling Scrivener to see if some of the issues go away?