Scrivener locking up when manipulating formatting pane

When I try to alter things in the Formatting pane of the Compile window, Scrivener freezes. I can click on the various levels but if I try to toggle on something, such as “title”, everything freezes. Can’t get it to work. This only seems to affect projects that are using novels with parts profiles.

I would try reinstalling the software, first. Interface glitches like this can creep into an installation, particularly when conditions on the system change (upgrades, etc.).

For those coming to this thread with the same issue, please review the Known Issues article in our knowledge base, for a bug description and workaround.

How do I reinstall my software?

Although written for scenarios where the installed copy flat out won’t run, this FAQ answer goes over re-installation.

That didn’t work. Still broken.

It seems like it has something to do with the compile presets. Even when I try to make a brand new one starting with the Paperback with Parts preset, it locks up when I try to toggle something in the Formatting pane.

For a cleaner reproduction sequence, I would take it even a step further and start from “Original” for the test, rather than a more complicated preset like the paperback variations.

But seeing as how the action you are taking introduces potentially new fonts into the preview area below, I would reset your caches (the font cache in particular, but all of them to be safe) and reboot the computer. This is easily done with a tool like Maintenance. A corrupted font cache could cause a crash or “soft” UI hang.

Also let me know what OS X and Scrivener versions you use (I’m assuming 2.6 at this point no matter what, since you just downloaded and reinstalled).

Okay, I ran Maintenance. My disk needed to be repaired but even after I did all that, I still ended up having the same problems. So for now, I’m going to have to build all new compile presets. I’m using the latest versions of OS X and Scrivener. It seems like I’ve had more problems since updating to Yosemite.

All right, too bad it didn’t fix the problem, but it’s good you ran it anyway, as it needed repair.

I wouldn’t spend time doing that yet (maybe ever, I doubt it’s a problem with the physical bytes as stored on the disk since we’ve done a full re-install which will include the built-in presets), we’ve only tried a few basic and generic troubleshoot steps. What you’ll want to do next is attempt to capture any warnings or errors that the software or system may be producing.

There are two things to do in order to acquire better information. For both things, you’ll want to enable these settings before you even load the project you’re testing with. Some bugs start well before they manifest in a way that is noticeable to you.

[size=120]Turn On Debugging[/size]

  1. In the General preferences pane, enable the “Show internal error alerts” message.
  2. If a window pops up at any point, simply copy and paste the error contents into a text file (TextEdit is fine). Create a new file each time this happens, and attach them all to your response.

[size=120]Getting Log Info From The System[/size]

  1. Click on the Finder icon in the Dock
  2. Use the Go/Utilities menu command.
  3. Double-click the Console icon.
  4. Click the “Clear Display” icon in the toolbar.

Now with both the debugging alerts enabled and the Console window open, switch back to Scrivener and compile the project until it gets to the point where it hangs. Did any messages get printed in the Console window? If so, just click on any one of them, press Cmd-A to select them all, and then copy & paste them into a response.

Also, when you say the software “freezes” what do that mean precisely? Are there error messages on the screen, crash reports, or what? We may be able to capture information from the hang itself.

When I try to toggle something in the Formatting panel, Scriv freezes, and I see the spinning pinwheel cursor. If I open the Force Quit pane, it says Scrivener (not responding).

Here is what came up in Console:

11/10/14 6:51:13.028 PM Office365Service[650]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.0 instead of 10.10.0. Use NSProcessInfo’s operatingSystemVersion property to get correct system version number.
Call location:
11/10/14 6:51:13.028 PM Office365Service[650]: 0 CarbonCore 0x90d4c7e7 ___Gestalt_SystemVersion_block_invoke + 135
11/10/14 6:51:13.028 PM Office365Service[650]: 1 libdispatch.dylib 0x9962c130 _dispatch_client_callout + 50
11/10/14 6:51:13.028 PM Office365Service[650]: 2 libdispatch.dylib 0x9962c0b5 dispatch_once_f + 251
11/10/14 6:51:13.028 PM Office365Service[650]: 3 libdispatch.dylib 0x9962d0d8 dispatch_once + 31
11/10/14 6:51:13.028 PM Office365Service[650]: 4 CarbonCore 0x90cdefb8 _Gestalt_SystemVersion + 1050
11/10/14 6:51:13.029 PM Office365Service[650]: 5 CarbonCore 0x90cdeb69 Gestalt + 150
11/10/14 6:51:13.029 PM Office365Service[650]: 6 Office365Service 0x000589e3 Office365Service + 358883
11/10/14 6:52:22.000 PM kernel[0]: process Scrivener[619] thread 67743 caught burning CPU! It used more than 50% CPU (Actual recent usage: 99%) over 180 seconds. thread lifetime cpu usage 136.463317 seconds, (135.397591 user, 1.065726 system) ledger info: balance: 90003202275 credit: 136397789992 debit: 46394587717 limit: 90000000000 (50%) period: 180000000000 time since last refill (ns): 90132999631
11/10/14 6:52:22.159 PM[1]: ([651]) Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in():
11/10/14 6:52:22.161 PM ReportCrash[651]: Invoking spindump for pid=619 thread=67743 percent_cpu=99 duration=91 because of excessive cpu utilization
11/10/14 6:52:23.815 PM spindump[440]: Saved cpu_resource.diag report for Scrivener version 2.6 (2.60.5) to /Library/Logs/DiagnosticReports/Scrivener_2014-11-10-185223_Stuarts-MacBook-Pro.cpu_resource.diag

Okay, there isn’t too much in the console that helps us specifically. The one line relating directly to Scrivener just states it is using a lot of CPU, which could mean it is stuck in a loop. To see what it is stuck on, we can get a report of what it is doing while the wheel is spinning. Get that to happen, and then leave it instead of force quitting. Return to the Utilities folder in Finder (where we loaded Console), and this time load Activity Monitor. Select Scrivener from the list, and then use the View/Sample Process menu command. This will take a few moments to generate a report. Use the Save button to capture all of that to a file. I’d recommend sending this to our support e-mail address as an attachment. Just make sure to reference this forum thread URL so that whoever gets it can forward it to me.

I sent the email with the report attached. I also started building a new compile preset from the Original setting. I started setting things in the Formatting pane and eventually the same thing occurred.

If anyone else is experiencing this issue, we figured out that it is a bug in the Mac’s dynamic scroll bar feature. If you have “Always” set in the General System Preference pane, for when scrollbars should be shown, then temporarily set this to “When Scrolling”, while using the Formatting pane. Once you’ve finished setting it up, you can switch this feature back on safely.

A way to code around the underlying problem has been found, so this will be fixed in a future update.

This seems to have done the trick.

Thanks for all your help, AmberV.

I had the same problem - and the solution worked immediately. Thanks, folks.